Moode Forum

Full Version: 5.3 is not stable
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Iam running 5.3 on a Raspberry Pi2 and it is really unstable, it disconnect very often (let's say after 15 seconds). Not such an issue with 5.2. Connected by Ethernet
Statement from Kent:

A recent issue on the Raspberry Pi Linux github repo (https://github.com/raspberrypi/linux/issues/2964) illustrates why we need complete hardware descriptions in your bug reports. 
In this issue, it was reported that downloads were stalling on kernel 4.19.40. Because the chipsets on different RPi models differ (for this issue, notably the LAN controller chip), "[T]his only affects rpi B, B+, 2B, 3B boards using the ethernet connection. 3B+, Wifi, or other network devices are not affected."

I believe that this issue has affected some of us (even in the UPnP discussion; you know who you are) but that's not my point here. I believe this issue is a perfect illustration of why we need your bug reports to include not just a statement of moOde and DAC, but of the RPI model and its connection to your LAN, of other USB devices, hubs, and other devices or connections. It's easy enough for us to ignore information we don't need but impossible for us to make progress without the information we do need.

PS - Speaking of hardware, please please please be sure you have adequate power supply and power-connecting cable. While the page [color=#d35400]https://elinux.org/RPi_Hardware is out of date in some regards, its discussion of power supply problems is still relevant.
(06-03-2019, 02:25 PM)amontag52 Wrote: [ -> ]Iam running 5.3 on a Raspberry Pi2 and it is really unstable, it disconnect very often (let's say after 15 seconds). Not such an issue with 5.2. Connected by Ethernet

The symptoms suggest something external to moOde software for example a bad SDCard, network issue, PSU issue, hardware issue, etc.

This morning I booted a Pi-2B running moOde 5.3 connected via Ethernet and I'm not experiencing any issues. The logs are clean, system is stable and no interruptions in network connectivity. A radio station has been playing continuously.

Code:
pi@moode:~ $ sudo /var/www/command/sysinfo.sh

         S Y S T E M    P A R A M E T E R S  

       Date and time   = 2019-06-03 15:01:13
       System uptime   = up 4 hours, 27 minutes
       Timezone        = America/Detroit
       Release         = moOde 5.3 2019-05-30
       Update          = None

       Host name       = moode
       ETH0  IP        = 192.168.1.220
       ETH0  MAC       = b8:27:eb:ca:82:f9
       WLAN0 IP        = unassigned
       WLAN0 MAC       = no adapter
       WiFi country    = US

       HDWR REV        = Pi-2B 1GB v1.1
       SoC             = BCM2835
       CORES           = 4
       ARCH            = armv7l
       RASPBIAN        = 9.9
       KERNEL          = 4.19.46-v7+
       KTIMER FREQ     = 100 Hz
       USB BOOT        = not available
       Warranty        = OK

       ROOT size       = 2.9G
       ROOT used       = 77%
       ROOT avail      = 657M
       FS expand       = not expanded
       MEM free        = 691 MB
       MEM used        = 67 MB
       Temperature     = 40.1°C

       CPU GOV         = performance
       P3-WIFI         = None
       P3-BT           = None
       HDMI            = On
       ETH0 CHECK      = On
       MAX USB CUR     = Off
       UAC2 FIX        = Off
       ETHPORT FIX     = Off
       SSH server      = Off

       LED0            = on
       LED1            = on
       SD CARD         = 50 MHz

         C O R E    S E R V I C E S  

       PHP-FPM         = 7.0.33
       NGINX           = 1.10.3
       SQLite          = 3.16.2
       HOSTAPD         = 2.7
       WIRINGPI        = 2.50

         A P P E A R A N C E   S E T T I N G S  

       Theme                   = Default
       Accent color            = Emerald
       Alpha blend             = 1.0
       Adaptive background     = No
       Background image        = No
       Cover backdrop          = No
       Cover blur              = 20px
       Cover scale             = 1.25
       CoverView auto-display  = Never
       CoverView style         = Animated
       Auto-shuffle filter     = None
       Extra metadata          = Yes
       Playback history        = No

         L I B R A R Y   S E T T I N G S  

       Artist list order       = Artist
       Ignore articles         = a,an,the
       Compilation rollup      = No
       Compilation excludes    = greatest hits
       UTF8 character filter   = No
       Cover search pri        = Embedded cover
       Hi-res covers           = Auto
       Pixel ratio             = 1

         A U D I O    P A R A M E T E R S  

       Audio device            = On-board audio device
       Interface               = SoC
       Hardware volume         = Controller detected
       Mixer name              = PCM
       Audio source            = Local
       Output device           = Local
       Resume MPD aft src chg  = No
       Volume knob                = 0
       Volume mute             = Unmuted
       Saved MPD vol           = 0
       Preamp volume           = 0
       ALSA version            = 1.1.3-5+rpt4
       SoX version             = 0.1.2-2

       Bluetooth controller    = Off
       Bluetooth pairing agent = Off
       Airplay receiver        = Off
       Spotify receiver        = Off
       Squeezelite             = Off
       UPnP client             = Off
       DLNA server             = Off
       GPIO button handler     = Off

       Rotary encoder          = Off
       Encoder params          = 100 2 3 4 5
       Crossfeed               = Off
       Parametric EQ           = Off
       Graphic EQ              = Off
       Polarity inversion      = Off
       Auto-shuffle            = Off
       Autoplay                = Off
       MPD crossfade           = Off
       MPD httpd               = Off

         M P D    S E T T I N G S  

       Version                 = 0.20.23
       Volume control          = software
       ALSA device             = hw:0
       SoX resampling          = disabled
       SoX quality             = very high
       SoX multithreading      = off
       DSD over PCM (DoP)      = no
       Replaygain              = off
       Replaygain preamp       = 0
       Volume normalization    = No
       Audio buffer (kb)       = 4096
       Output buffer size (kb) = 131072

         B L U E T O O T H    S E T T I N G S  

       Bluetooth ver           = 5.50
       Bluealsa ver            = 1.3.1
       Speaker sharing         = No
       Resume MPD              = No

         A I R P L A Y    S E T T I N G S  

       Version                 = 3.3
       Friendly name           = Moode Airplay
       ALSA device             = hw:0
       Interpolation           = soxr
       Output bit depth        = S16
       Output sample rate      = 44100
       Session interruption    = no
       Session timeout (ms)    = 120
       Audio buffer (secs)     = 0.0
       Resume MPD              = No

         S P O T I F Y    S E T T I N G S  

       Friendly name           = Moode Spotify
       ALSA device             = plughw:0
       Bit rate                = 160
       Initial volume          = 0
       Volume curve            = Logarithmic
       Volume normalization    = No
       Normalization pregain   = 0
       Resume MPD              = No

         S Q U E E Z E L I T E    S E T T I N G S  

       Version                 = 1.8.7-1052 "DSD/SRC enabled"
       Friendly name           = Moode
       ALSA device             = hw:0
       ALSA params             = 80:4::1
       Output buffers          = 40000:100000
       Task priority           = 45
       Codec list              = flac,pcm,mp3,ogg,aac,alac,dsd
       Other options           = -W -D 500 -R E -S /var/loca
       Resume MPD              = No

         M O O D E    L O G  

   20190603 102809 worker: - Start
   20190603 102809 worker: Successfully daemonized
   20190603 102809 worker: Integrity check (passed)
   20190603 102809 worker: ALSA volume set to (0%)
   20190603 102810 worker: Session loaded
   20190603 102810 worker: Debug logging (off)
   20190603 102810 worker: - Platform
   20190603 102812 worker: Rel  (Moode 5.3 2019-05-30)
   20190603 102812 worker: Upd  (None)
   20190603 102812 worker: Rasp (9.9)
   20190603 102812 worker: Kern (4.19.46-v7+)
   20190603 102812 worker: MPD  (0.20.23)
   20190603 102812 worker: Host (moode)
   20190603 102812 worker: Hdwr (Pi-2B 1GB v1.1)
   20190603 102812 worker: Arch (armv7l)
   20190603 102812 worker: Gov  (performance)
   20190603 102812 worker: USB boot not enabled yet
   20190603 102812 worker: File system not expanded yet
   20190603 102812 worker: HDMI port on
   20190603 102812 worker: File check ok
   20190603 102812 worker: - Network
   20190603 102812 worker: eth0 exists
   20190603 102812 worker: eth0 (192.168.1.220)
   20190603 102812 worker: wlan0 does not exist
   20190603 102812 worker: - Audio
   20190603 102813 worker: ALSA outputs unmuted
   20190603 102813 worker: ALSA card number (0)
   20190603 102813 worker: Audio output (On-board audio device)
   20190603 102813 worker: ALSA mixer name (PCM)
   20190603 102813 worker: MPD volume control (software)
   20190603 102813 worker: Hdwr volume controller exists
   20190603 102813 worker: - Services
   20190603 102813 worker: Reset renderer active state
   20190603 102813 worker: MPD conf updated
   20190603 102814 worker: MPD started
   20190603 102814 worker: MPD accepting connections
   20190603 102814 worker: Configure MPD outputs
   20190603 102814 worker: MPD output 1 ALSA default (on)
   20190603 102814 worker: MPD output 2 ALSA crossfeed (off)
   20190603 102814 worker: MPD output 3 ALSA parametric eq (off)
   20190603 102814 worker: MPD output 4 ALSA graphic eq (off)
   20190603 102814 worker: MPD output 5 ALSA polarity inversion (off)
   20190603 102814 worker: MPD output 6 ALSA bluetooth (off)
   20190603 102814 worker: MPD output 7 HTTP stream (off)
   20190603 102814 worker: MPD crossfade (off)
   20190603 102814 worker: Audio source (Local)
   20190603 102814 worker: Output device (Local)
   20190603 102814 worker: - Music sources
   20190603 102814 worker: USB sources (none attached)
   20190603 102814 worker: NAS sources (none configured)
   20190603 102814 worker: - Miscellaneous
   20190603 102815 worker: Saved MPD vol level (0)
   20190603 102815 worker: Preamp volume level (0)
   20190603 102815 worker: MPD volume level (0) restored
   20190603 102815 worker: ALSA volume level (100%)
   20190603 102815 worker: Auto-play is off
   20190603 102815 worker: Maintenance interval (21600)
   20190603 102815 worker: Screen saver activation (Never)
   20190603 102815 worker: Watchdog started
   20190603 102815 worker: Ready
pi@moode:~ $


Maybe try checking syslog, MPD log, dmesg, etc for errors, and also check your Router logs.
Same setup (5.3@RPi 2B w/Ethernet), radios don't cut at all.