Moode Forum

Full Version: Moode 6.4.1 Autorestart playing issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all,

I set the Autostart playing function to OFF in my Moode player Audio conf (v6.4.1 freshly downloaded and installed) however moode always start playing when starting...
What can I do to unvoide that ?
thanks
Do you set it to OFF and save that.... ?
(02-06-2020, 09:11 AM)DRONE7 Wrote: [ -> ]Do you set it to OFF and save that.... ?

Set to OFF but no save option for that...
I was thinking that parameter was stored in the mpd.conf however if I set that parameter to ON or OFF the mpd.conf doesn't change...
Do you know where those parameters are stored ?
(02-06-2020, 11:07 AM)zebons Wrote: [ -> ]Set to OFF but no save option for that...

It's the [SET] button right next to the toggle.
(02-06-2020, 11:18 AM)vinnn Wrote: [ -> ]
(02-06-2020, 11:07 AM)zebons Wrote: [ -> ]Set to OFF but no save option for that...

It's the [SET] button right next to the toggle.

Off course I clic on the [SET] button after setting to OFF that parameter...
but it doesn't work after a reboot. The player start playing automaticly
Post output from the command below.

Code:
moodeutl -l
(02-06-2020, 11:52 AM)Tim Curtis Wrote: [ -> ]Post output from the command below.

Code:
moodeutl -l
Here is it
Code:
pi@moode:~ $ moodeutl -l
20200206 124826 worker: -- Start
20200206 124826 worker: Successfully daemonized
20200206 124827 worker: Integrity check (passed)
20200206 124827 worker: Session loaded
20200206 124827 worker: Debug logging (off)
20200206 124827 worker: Device raw: (0:sndrpihifiberry|1:empty|i2s:HiFiBerry Amp2)
20200206 124827 worker: Device cfg: (HiFiBerry Amp2|0|0|Digital|0)
20200206 124827 worker: ALSA volume set to (0%)
20200206 124828 worker: -- System
20200206 124831 worker: Host name     (moode)
20200206 124831 worker: moOde release (6.4.1 2020-01-23)
20200206 124831 worker: Raspbian OS   (10.2)
20200206 124831 worker: Linux kernel  (4.19.93-v7+ #1290)
20200206 124831 worker: Platform      (Pi-2B 1GB v1.1)
20200206 124831 worker: Architecture  (armv7l)
20200206 124831 worker: MPD version   (0.21.16)
20200206 124831 worker: CPU governor  (ondemand)
20200206 124831 worker: USB boot not available
20200206 124832 worker: File system expanded
20200206 124832 worker: HDMI port on
20200206 124833 worker: File check (OK)
20200206 124833 worker: -- Network
20200206 124833 worker: eth0 exists
20200206 124833 worker: IP addr (192.168.0.25)
20200206 124833 worker: Netmask (255.255.255.0)
20200206 124833 worker: Gateway (192.168.0.254)
20200206 124834 worker: Pri DNS (fd0f:ee:b0::1)
20200206 124834 worker: Domain  (192.168.0.254)
20200206 124834 worker: wlan0 does not exist
20200206 124834 worker: -- Audio
20200206 124835 worker: ALSA outputs unmuted
20200206 124835 worker: ALSA card number (0)
20200206 124835 worker: Audio output (I2S audio device)
20200206 124835 worker: Audio device (HiFiBerry Amp2)
20200206 124835 worker: Audio formats (S16_LE, S24_LE, S32_LE)
20200206 124835 worker: ALSA mixer name (Digital)
20200206 124835 worker: MPD volume control (software)
20200206 124836 worker: Hdwr volume controller exists
20200206 124836 worker: Max ALSA volume (95%)
20200206 124836 worker: -- Services
20200206 124836 worker: Reset renderer active state
20200206 124836 worker: MPD conf updated
20200206 124837 worker: MPD started
20200206 124839 worker: MPD accepting connections
20200206 124839 worker: Configure MPD outputs
20200206 124839 worker: MPD output 1 ALSA default (off)
20200206 124839 worker: MPD output 2 ALSA crossfeed (off)
20200206 124839 worker: MPD output 3 ALSA parametric eq (off)
20200206 124839 worker: MPD output 4 ALSA graphic eq (on)
20200206 124839 worker: MPD output 5 ALSA polarity inversion (off)
20200206 124839 worker: MPD output 6 ALSA bluetooth (off)
20200206 124839 worker: MPD output 7 HTTP stream (off)
20200206 124839 worker: MPD crossfade (off)
20200206 124839 worker: Audio source (Local)
20200206 124839 worker: Output device (Local)
20200206 124840 worker: Squeezelite renderer started
20200206 124840 worker: GPIO button handler started
20200206 124840 worker: USB auto-mounter (udisks-glue)
20200206 124840 worker: -- Music sources
20200206 124840 worker: USB sources (none attached)
20200206 124841 worker: NAS and UPnP sources (mountall initiated)
20200206 124841 worker: -- Miscellaneous
20200206 124841 worker: Saved MPD vol level (0)
20200206 124841 worker: Preamp volume level (0)
20200206 124842 worker: MPD volume level (45) restored
20200206 124842 worker: ALSA volume level (95%)
20200206 124842 worker: Auto-play (Off)
20200206 124842 worker: LocalUI started
20200206 124842 worker: Auto-shuffle started
20200206 124842 worker: Maintenance interval (3 hrs)
20200206 124842 worker: Screen saver activation (Never)
20200206 124842 worker: Session permissions (OK)
20200206 124842 worker: Watchdog started
20200206 124842 worker: Ready
Auto-play is set to Off but the Music start after a reboot.
and often (not sure for always) after a reboot I get an MPD error message like this one for the last mp3 that was playing when I ask for reboot

Code:
Feb 06 12:38 : exception: Failed to decode /var/lib/mpd/music/NAS/Musique/_HIP HOP-RAP-RnB/Moby/18/Moby-18-14-At Least We Tried.mp3
Feb 06 12:38 : exception: nested: Failed to open '/var/lib/mpd/music/NAS/Musique/_HIP HOP-RAP-RnB/Moby/18/Moby-18-14-At Least We Tried.mp3': No such file or directory
Feb 06 12:38 : player: played "NAS/Musique/_HIP HOP-RAP-RnB/Moby/18/Moby-18-14-At Least We Tried.mp3"
I do another test : If I stop to play musing before asking the reboot, I don't have the MPD error message at reboot but anyway music start playing...
Turn Random Play off if it is on.
(02-06-2020, 12:12 PM)Tim Curtis Wrote: [ -> ]Turn Random Play off if it is on.

It seem's that you are right, if the random play is activated at the stop, the auto-start parameter is not taken into account at boot and music start playing.
I do a test by desactivating the random play before stopping the player and music doesn't play at start.

However it's an issue at my point of view, I love to activate that random function to play my music files and it'd be a constraint to desactivate that before stopping...
Do you have a workaround ?