Moode Forum

Full Version: Duh! Turned on Bluetooth with no bluetooth hardware - how to reboot?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Moode Release: 6.4.2 2020-02-12
Raspberry Pi 2 (no Bluetooth!)

I thought this player was a Pi 3, but it was one of my Pi 2's which has no Bluetooth ....
I turned on Bluetooth and, as the Moode blue info circle warned me, the player does not now reboot - DOH!

How can I turn off Bluetooth again , presumably by taking out the SD card and accessing a file on my computer? (widows or linux - I have dualboot)

Any pointers, if I promise not to do it again? Smile


Your best bet is to boot the Pi3 and turn Bluetooth off.

Unfortunately I have never been able to find a way to detect whether a Bluetooth adapter is present. This would enable moOde to automatically turn off the Bluetooth controller during startup.
You also can edit /boot/config.txt file (by inserting sdcard on your computer) and add:


You should can boot and properly (on moOde UI) turn off bluetooth.

1. I tried booting in another RPi, which I know is a RPi 3 since whilst running Raspbian on it:
cat /proc/device-tree/model
Raspberry Pi 3 Model B Rev 1.2

But Moode was still not showing up in browser on PC with the Moode SD in it

2. Then edited /boot/config.txt via my laptop on SD card:

(this was already in the file ready to be un-commented)

However, on reinserting in the RPi 2 (Raspberry Pi 2 Model B Rev 1.1) it is still not showing up in Laptop browser, although Router showed it was up and I can SSH into it to verify that the edits in the config.txt file 'stuck' ....

Any ideas, please,  before I just reinstall Moode on it?
I have experienced something similar on my Raspberry pi 3B ... I have Bluetooth support turned on under "Sound-Settings" without first turning on bluetooth under "System-Settings".
The result was that Moode was no longer accessible via the browser.
Solution : Fresh install or 
sqlite3 /var/local/www/db/moode-sqlite3.db "update cfg_system set value=0 where param='btsvc';"
sudo reboot