Moode Forum

Full Version: Adding USB SSD Drives (FAT32) is driving my and my buddy nuts
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

- Allo boss DAC
- Pi2 (ARM v7)
- Main use; Spotify Connect and Connected to my network attached storage (USB drive connected to my router)
- Problem : I've a 256GB SSD formatted to FAT32 which I've been trying to add to the Pi directly via USB but to no avail. I've tried with Devmon and Glu ... but for Pi2 its actually Glu but still does not work... I've plugged in the drive to one of the 4 USB ports available on the Pi. 
- What we've done so far : Go to library, create ... chose samba ... scan .. there are a host of options, tried NAS (didn't work), tried EFI (didn't work) .. where do we check for the drive? it doesnt seem to appear anywhere in the UI.

- What we hope from the community - any kind soul that can assist to provide a step by step on what we need to do? the SSD work well playing for a PC or Laptop.

Thanks!


EDIT :

- set the option below in configure >> library to YES (automatically update MPD ...)
- create
- choose as SAMBA
- path select SCAN first .. once done, select pull down menu
- choose your disk!
- change the path manually if you need to
- id put as guest
- pwd leave empty (assuming no pwd on yourdrive)
- name : any name you want
- SAVE
(08-01-2020, 03:32 AM)boostbutt Wrote: [ -> ]Hi All,

- Allo boss DAC
- Pi2 (ARM v7)
- Main use; Spotify Connect and Connected to my network attached storage (USB drive connected to my router)
- Problem : I've a 256GB SSD formatted to FAT32 which I've been trying to add to the Pi directly via USB but to no avail. I've tried with Devmon and Glu ... but for Pi2 its actually Glu but still does not work... I've plugged in the drive to one of the 4 USB ports available on the Pi. 
- What we've done so far : Go to library, create ... chose samba ... scan .. there are a host of options, tried NAS (didn't work), tried EFI (didn't work) .. where do we check for the drive? it doesnt seem to appear anywhere in the UI.

- What we hope from the community - any kind soul that can assist to provide a step by step on what we need to do? the SSD work well playing for a PC or Laptop.

Thanks!


EDIT :

- set the option below in configure >> library to YES (automatically update MPD ...)
- create
- choose as SAMBA
- path select SCAN first .. once done, select pull down menu
- choose your disk!
- change the path manually if you need to
- id put as guest
- pwd leave empty (assuming no pwd on yourdrive)
- name : any name you want
- SAVE

How is the SSD drive powered ? Via the Pi or from a separate power supply ?
If the former then that would give the symptoms you are experiencing..(Whilst the overall current draw from the USB ports may seem to be within spec the start-up current draw will not be ;-)
If your drive is connected to the Pi via USB, then 'Update Library' should be all that's needed for it to load - provided, as @DRONE7 said, it has sufficient power.
If you connect your drive to the router you need to add a NAS source, SCAN, etc.