Moode Forum
[PROBLEM] Moode 5.0 - Bluetooth device won't pair - Printable Version

+- Moode Forum (http://moodeaudio.org/forum)
+-- Forum: moOde audio player (http://moodeaudio.org/forum/forumdisplay.php?fid=3)
+--- Forum: Support (http://moodeaudio.org/forum/forumdisplay.php?fid=7)
+--- Thread: [PROBLEM] Moode 5.0 - Bluetooth device won't pair (/showthread.php?tid=1288)

Pages: 1 2


Moode 5.0 - Bluetooth device won't pair - jonners - 04-21-2019

The Bluetooth SCAN finds my device (Soundcore Mini speaker), but then PAIR fails and the system just hangs. Tried with both my RPi 3b and 3b+. Any ideas please?
 This is the first time I have tried to use Bluetooth in moOde. The device connects with no trouble to my Macbook and Android tablet.


RE: Moode 5.0 - Bluetooth device won't pair - DRONE7 - 04-21-2019

I've had a play with Bluetoothache today too...
System config...turn Bluetooth adaptor on.
Audio config... Renderers.. turn bluetooth and pairing agent on
Main menu... Bluez...MPD audio output change to bluetooth

In the end I found it so problematic....stopped and needed restarting every time any adjustment to moode or device was made...

So I ended up using the HTTP streaming in Moode audio config to stream to my phone and had the phone connect flawlessly to my Bluetooth headphones.
All in all much better range and stability.

Ymmv


RE: Moode 5.0 - Bluetooth device won't pair - Tim Curtis - 04-21-2019

From the ( i ) help below. The pairing agent is for Client --> moOde.

The pairing agent automatically accepts incoming pairing/connect requests from clients and eliminates the need to perform a manual SCAN from the BlueZ screen.

If you are doing moOde --> speaker then the BlueZ SCAN / PAIR / CONNECT must be used.


RE: Moode 5.0 - Bluetooth device won't pair - jonners - 04-21-2019

Yes I want to do moOde --> speaker, so in Audio Config - Renderers I turn Bluetooth on, but leave pairing agent and speaker sharing off.
Then I do BlueZ SCAN and it finds my device but PAIR still fails.
Am I still doing something wrong?


RE: Moode 5.0 - Bluetooth device won't pair - Tim Curtis - 04-21-2019

Not likely. Btw, you can have the pairing agent on. It's not involved in moOde --> speaker pair/connect.

I have this SoundCore model and no problems whatsoever.
https://www.anker.com/products/variant/soundcore-bluetooth-speaker/A3102011

It could be a compatibility issue with the latest BlueZ 2.5 bluetooth stack that moOde 5 uses and your particular SoundCore Speaker model. Other possibilities are interference in the Bluetooth wireless band, signal attenuation due to enclosure or other environmentals, etc. Maybe even timing in moOde SCAN / TRUST / PAIR sequence.

You would need to run the scan, trust, pair sequence manually via ssh to see if its a timing issue.


RE: Moode 5.0 - Bluetooth device won't pair - TheOldPresbyope - 04-21-2019

Just checked and no problem here either with JBL Flip 2 BT speaker.


RE: Moode 5.0 - Bluetooth device won't pair - mayburyds - 04-24-2019

Hi,

I've now managed to get BT connecting and disconnecting successfully with my BT headphones. It was a bit hit and miss to start but seems to have settled down now for some reason.

What I can't do is stop/play/skip tracks backwards and forwards from the headphone controls! Is this functionality not available in moode?

Cheers.


RE: Moode 5.0 - Bluetooth device won't pair - Tim Curtis - 04-24-2019

There is no control channel that I'm aware of in the BlueZ stack, and thus nothing in moOde to provide this functionality.


RE: Moode 5.0 - Bluetooth device won't pair - mayburyds - 04-25-2019

(04-24-2019, 08:02 PM)Tim Curtis Wrote: There is no control channel that I'm aware of in the BlueZ stack, and thus nothing in moOde to provide this functionality.

Thought that would be a pretty basic requirement for BT!

Cheers.


RE: Moode 5.0 - Bluetooth device won't pair - Tim Curtis - 04-26-2019

Of course it is. Just provide a link to the relevant section in the BlueZ spec and I'll be happy to investigate :-)