Moode Forum
DIY DAC I2S rpi4 - Printable Version

+- Moode Forum (http://moodeaudio.org/forum)
+-- Forum: moOde audio player (http://moodeaudio.org/forum/forumdisplay.php?fid=3)
+--- Forum: Support (http://moodeaudio.org/forum/forumdisplay.php?fid=7)
+--- Thread: DIY DAC I2S rpi4 (/showthread.php?tid=1977)



DIY DAC I2S rpi4 - v_erich - 12-11-2019

Hi,
I'm new to moode audio and rpi as a device for my audio system.
I have an rpi4 with an allo KALI reclocker (and later on an allo isolator) and want to drive my DIY AK4497 DAC direct with I2S.
Source are pre-convolved WAV files in 176.4 and 192kHz in 32bit on my NAS.

What is in terms of sound quality the best setup of moode for this?
Which I2S audio device can/should I choose to have it working and (even better) getting full 32bit output over I2S?
I also see in the audio info that my WAV files are decoded to 24bit PCM, why not decoded to 32 bit? Is this not the internal audio format?

Hope I can get help here, my KALI comes in 1-2 days, so it would be great I can hear something these days   Cool

Thanks and best regards,
Erich


RE: DIY DAC I2S rpi4 - Tim Curtis - 12-12-2019

Post a copy of moOde startup log.

Code:
moodeutl -l

or

Menu, Configure, System
Menu, System info


RE: DIY DAC I2S rpi4 - v_erich - 12-12-2019

Code:
pi@moode:~ $ moodeutl -l
20191211 231020 worker: -- Start
20191211 231020 worker: Successfully daemonized
20191211 231020 worker: Integrity check (passed)
20191211 231020 worker: Session loaded
20191211 231020 worker: Debug logging (off)
20191211 231020 worker: Device raw: Card0 (sndrpihifiberry) | Card1 () | I2Sdev (Generic-1 I2S (hifiberry-dac))
20191211 231020 worker: Device cfg: Name (RPi-DAC) | Card (0) | MPDdev (0) | Mixer (Digital) | Alsavol: (none)
20191211 231020 worker: ALSA volume (None)
20191211 231021 worker: -- System
20191211 231024 worker: Host name     (moode)
20191211 231024 worker: moOde release (6.4.0 2019-11-24)
20191211 231024 worker: Raspbian OS   (10.2)
20191211 231024 worker: Linux kernel  (4.19.83-v7l+ #1277)
20191211 231024 worker: Platform      (Unknown Pi-model)
20191211 231024 worker: Architecture  (armv7l)
20191211 231024 worker: MPD version   (0.21.16)
20191211 231024 worker: CPU governor  (performance)
20191211 231024 worker: USB boot not available
20191211 231024 worker: File system expanded
20191211 231025 worker: HDMI port off
20191211 231025 worker: File check (OK)
20191211 231025 worker: -- Network
20191211 231025 worker: eth0 exists
20191211 231025 worker: IP addr (192.168.0.81)
20191211 231025 worker: Netmask (255.255.255.0)
20191211 231025 worker: Gateway (192.168.0.1)
20191211 231026 worker: Pri DNS ()
20191211 231026 worker: Domain  (192.168.0.250)
20191211 231026 worker: wlan0 exists
20191211 231026 worker: wifi country (US)
20191211 231026 worker: wlan0 SSID is blank
20191211 231026 worker: eth0 addr exists, AP mode not started
20191211 231026 worker: wlan0 address not assigned
20191211 231026 worker: -- Audio
20191211 231026 worker: ALSA outputs unmuted
20191211 231026 worker: ALSA card number (0)
20191211 231026 worker: Audio output (I2S audio device)
20191211 231026 worker: Audio device (Generic-1 I2S (hifiberry-dac))
20191211 231026 worker: Audio formats (S16_LE, S24_LE, S32_LE)
20191211 231026 worker: ALSA mixer name (Digital)
20191211 231026 worker: MPD volume control (software)
20191211 231027 worker: Hdwr volume controller not detected
20191211 231027 worker: -- Services
20191211 231027 worker: Reset renderer active state
20191211 231027 worker: MPD conf updated
20191211 231027 worker: MPD started
20191211 231028 worker: MPD accepting connections
20191211 231028 worker: Configure MPD outputs
20191211 231028 worker: MPD output 1 ALSA default (on)
20191211 231028 worker: MPD output 2 ALSA crossfeed (off)
20191211 231028 worker: MPD output 3 ALSA parametric eq (off)
20191211 231028 worker: MPD output 4 ALSA graphic eq (off)
20191211 231028 worker: MPD output 5 ALSA polarity inversion (off)
20191211 231028 worker: MPD output 6 ALSA bluetooth (off)
20191211 231028 worker: MPD output 7 HTTP stream (off)
20191211 231028 worker: MPD crossfade (off)
20191211 231028 worker: Audio source (Local)
20191211 231028 worker: Output device (Local)
20191211 231028 worker: UPnP renderer started
20191211 231028 worker: USB auto-mounter (udisks-glue)
20191211 231028 worker: -- Music sources
20191211 231028 worker: USB sources (none attached)
20191211 231029 worker: NAS and UPnP sources (mountall initiated)
20191211 231029 worker: -- Miscellaneous
20191211 231029 worker: Saved MPD vol level (0)
20191211 231029 worker: Preamp volume level (0)
20191211 231029 worker: MPD volume level (0) restored
20191211 231029 worker: ALSA volume level (None)
20191211 231029 worker: Auto-play (Off)
20191211 231029 worker: Maintenance interval (6 hrs)
20191211 231029 worker: Screen saver activation (Never)
20191211 231029 worker: Session permissions (OK)
20191211 231029 worker: Watchdog started
20191211 231029 worker: Ready
20191211 231029 watchdog: INFO Audio output is (closed)

Hi,
I have connected the KALI today, setup Generic-1 I2S.
LED is toggling between lock and empty.

BR and thanks,
Erich


RE: DIY DAC I2S rpi4 - DRONE7 - 12-12-2019

In the MoOde Audio configuration tab, Devices, Driver options....does it show option settings for Kali enabled as MCLK ?


RE: DIY DAC I2S rpi4 - v_erich - 12-12-2019

Hi,
tried both Generic-1 and Generic-2, in both there are no driver options available in audio tab.

BR
Erich


RE: DIY DAC I2S rpi4 - v_erich - 12-12-2019

Hi all,
now its working (Generic-1), dont't know why - settigngs are the same as before...

Lets see if its running over time ;-)

BR and thanks,
Erich


RE: DIY DAC I2S rpi4 - v_erich - 12-13-2019

If anyone else is having the same problem, I found why:
if the volume is turned to 0 then the LED is toggling between lock and empty on the allo Kali.
Inserted also the allo isolator v1, music still singing :-)

BR
Erich