Moode Forum
[PROBLEM] Unresponsive interface with queue of songs pointing to a network drive - Printable Version

+- Moode Forum (http://moodeaudio.org/forum)
+-- Forum: moOde audio player (http://moodeaudio.org/forum/forumdisplay.php?fid=3)
+--- Forum: Support (http://moodeaudio.org/forum/forumdisplay.php?fid=7)
+--- Thread: [PROBLEM] Unresponsive interface with queue of songs pointing to a network drive (/showthread.php?tid=2160)



Unresponsive interface with queue of songs pointing to a network drive - inthemoode - 02-08-2020

This is a bit hard to describe, but, Moode is running 6.4.1 latest.    I have all my songs on a NAS.  I  had queued a bunch of songs that were on the NAS, so the play queue had a list of songs in it.  I stopped play yesterday and left Moode running, but not paying anything.

This morning, my wife wanted to play some music.  She accessed the Moode web page via her phone.  She started the current song playing successfully, then tried to change/add to some songs of her own choosing.  The interface refused to do anything so I was called.

It seemed to be in some difficulties, sometimes the interface would respond after a long time to a previous click, mostly it did little - like as if something was chewing up all the cpu in the background.  I wanted to reboot, but could not get the menu to respond, so I ssh'd into it and issued a shutdown command.

On restart, it came up with an error that it could not access the song file that was first in the queue, then resumed it's unresponsive, go very slow mode.

I ssh'd into it again, ran "top" and upmpcli and mpd both seemed to be bouncing around at the top of the list.

I managed to free it all up by accessing mpd from a different app (MPDroid) on my phone, and clearing the playlist.  All suddenly returned to normal.


RE: Unresponsive interface with queue of songs pointing to a network drive - vinnn - 02-08-2020

There are a bunch of threads discussing web browser performance in this forum which is very much dependent on the web browser, what is running the web browser and how much is being rendered in html (large album list in tag view or a large playlist in now playing view).
Running top on the Pi won't show you anything to do with the load on a phone, if thousands of tracks was in the playlist then it's most likely the web browser on the phone was stuck rendering the tracklist html in the browser. An MPD client wouldn't suffer from this of course as it's not rendering html in js.


RE: Unresponsive interface with queue of songs pointing to a network drive - inthemoode - 02-08-2020

(02-08-2020, 08:29 AM)vinnn Wrote: There are a bunch of threads discussing web browser performance in this forum which is very much dependent on the web browser, what is running the web browser and how much is being rendered in html (large album list in tag view or a large playlist in now playing view).
Running top on the Pi won't show you anything to do with the load on a phone, if thousands of tracks was in the playlist then it's most likely the web browser on the phone was stuck rendering the tracklist html in the browser. An MPD client wouldn't suffer from this of course as it's not rendering html in js.

I know about this, but that isn't what I am trying to describe.   I know the usual speed of the browser, but this was a condition that Moode got itself into where it was so busy in the background that the web interface was hardly ever responding at all.


RE: Unresponsive interface with queue of songs pointing to a network drive - Tim Curtis - 02-08-2020

What model Pi?

Turn off all the UPnP/DLNA services and see if the problem reoccurs.


RE: Unresponsive interface with queue of songs pointing to a network drive - inthemoode - 02-11-2020

(02-08-2020, 10:38 PM)Tim Curtis Wrote: What model Pi?

Turn off all the UPnP/DLNA services and see if the problem reoccurs.

It's a Pi 4 with firmware up to date.

Yes, I will try turning them off.  Thanks.   Don't know yet how often it will happen though.