Moode Forum
DACBerry ONE Digital input - Printable Version

+- Moode Forum (http://moodeaudio.org/forum)
+-- Forum: moOde audio player (http://moodeaudio.org/forum/forumdisplay.php?fid=3)
+--- Forum: Support (http://moodeaudio.org/forum/forumdisplay.php?fid=7)
+--- Thread: DACBerry ONE Digital input (/showthread.php?tid=2336)



DACBerry ONE Digital input - the_bertrum - 04-05-2020

Hallo Folks,
I've got MoOde running sweetly with analogue output from a DACBerry ONE I2S DAC which uses the IQAudio DAC Plus profile.  I bought this particular DAC because it has an optical digital input which I hope to use to take the sound from my TV and send it to my hifi via the phono out.  The IQAudio profile does not have knowledge of the digital i/o on my card though, so the digital input does appear in the "input select" menu in MoOde.  I'm strugging to work out how these profiles work what ther releationship between profiles, DT-Overlays and the alsa device list is.  I believe I need to get to a situation where I can see the digital input as a device in this output:

Code:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: IQaudIODAC [IQaudIODAC], device 0: IQaudIO DAC HiFi pcm512x-hifi-0 [IQaudIO DAC HiFi pcm512x-hifi-0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I've sent a mail to the manufacutrer to see what they suggest, but since they are in Barcelona, it is possible they are not working right now (and good luck to them).  I thought I'd post here in case the assembled brains can educate me enough to get this set up by myself.  Any help appreciated.

Thanks in advance.