Moode Forum
[PROBLEM] No menues / tabs moode 6.5.2 - Printable Version

+- Moode Forum (http://moodeaudio.org/forum)
+-- Forum: moOde audio player (http://moodeaudio.org/forum/forumdisplay.php?fid=3)
+--- Forum: Support (http://moodeaudio.org/forum/forumdisplay.php?fid=7)
+--- Thread: [PROBLEM] No menues / tabs moode 6.5.2 (/showthread.php?tid=2622)

Pages: 1 2 3


RE: No menues / tabs moode 6.5.2 - TheOldPresbyope - 06-06-2020

(06-05-2020, 11:44 PM)Tim Curtis Wrote: Thinking a bit it would probably be easier if @Ale2.0 posted the autocfg.log file. If there were an issue parsing the moodecfg.txt file it would show up in the log.

Luckily some clever developer decided capturing the log would be a good idea. Take a bow!


RE: No menues / tabs moode 6.5.2 - Ale2.0 - 06-06-2020

(06-05-2020, 11:44 PM)Tim Curtis Wrote: Thinking a bit it would probably be easier if @Ale2.0 posted the autocfg.log file. If there were an issue parsing the moodecfg.txt file it would show up in the log.

Hey again

Interesting to read here. 
As I have flashed already again I will search another SD and send the cfg log file.

Greetings


RE: No menues / tabs moode 6.5.2 - Ale2.0 - 06-06-2020

Hello again

I newly flashed with the cfg, it happened again and now I tried to open the  logfile as you said.

I opened a ssh connection and used nano to open the file.

This is in the cfg:

Code:
GNU nano 3.2

                                                                                                                                                                             
20200504 064049 autocfg: Country: CH                                                                                                                                          
20200504 064049 autocfg: - Network (apd0)                                                                                                                                      
20200504 064050 autocfg: SSID: REVOX Cortex                                                                                                                                    
20200504 064050 autocfg: Password: moodeaudio                                                                                                                                  
20200504 064050 autocfg: PSK: efbe1108c64ae5014d33281c2014deffefd303cff5b84af179b21676e3cc17cc                                                                                
20200504 064050 autocfg: Channel: 6                                                                                                                                            
20200504 064050 autocfg: - Services                                                                                                                                            
20200504 064050 autocfg: Airplay: On                                                                                                                                          
20200504 064050 autocfg: UPnP: On                                                                                                                                              
20200504 064050 autocfg: DLNA: On                                                                                                                                              
20200504 064050 autocfg: - Other                                                                                                                                              
20200504 064050 autocfg: Time zone: Europe/Rome                                                                                                                                
20200504 064050 autocfg: Theme name: Standard                                                                                                                                  
20200504 064050 autocfg: Accent color: Emerald                                                                                                                                
20200504 064050 autocfg: Configuration file deleted                                                                                                                            
20200504 064050 autocfg: Auto-configure complete                                                                                                                              
20200504 064050 autocfg: System rebooted                                                                                                                                      
                                                                                                                                                                             


Seems to be okay?


RE: No menues / tabs moode 6.5.2 - Ale2.0 - 06-21-2020

Hello there! 

Already found out something? 

Would still be interested in using the file to flash ^^

Greetings from here
Ale


RE: No menues / tabs moode 6.5.2 - Ale2.0 - 09-15-2020

(06-06-2020, 12:11 AM)TheOldPresbyope Wrote:
(06-05-2020, 11:44 PM)Tim Curtis Wrote: Thinking a bit it would probably be easier if @Ale2.0 posted the autocfg.log file. If there were an issue parsing the moodecfg.txt file it would show up in the log.

Luckily some clever developer decided capturing the log would be a good idea. Take a bow!


I would really appreciate the function :3

Is there anything new regarding this topic?


RE: No menues / tabs moode 6.5.2 - TheOldPresbyope - 09-15-2020

(09-15-2020, 08:27 PM)Ale2.0 Wrote:
(06-06-2020, 12:11 AM)TheOldPresbyope Wrote:
(06-05-2020, 11:44 PM)Tim Curtis Wrote: Thinking a bit it would probably be easier if @Ale2.0 posted the autocfg.log file. If there were an issue parsing the moodecfg.txt file it would show up in the log.

Luckily some clever developer decided capturing the log would be a good idea. Take a bow!


I would really appreciate the function :3

Is there anything new regarding this topic?

Not sure what function you mean. I was alluding to the code in moOde which captures the autocfg output to the /home/pi/autocfg.log file (and to Tim as 'some clever developer').

Looking back at what you posted in June, I don't notice anything which would suggest why you're getting the symptoms you reported. It sounds vaguely as if MPD isn't starting. You need to post the output from the moOde log.

Meanwhile, there have been several releases of moOde since 6.5.2 and release 7.0 is in testing, so supporting 6.5.2 is low on the list of priorities.

Regards,
Kent


RE: No menues / tabs moode 6.5.2 - Ale2.0 - 09-15-2020

Hello

I mean the function to configure with a config.txt
I see that it has no priority anymore but before I try again I would have liked to know if somebody tried to fix it.
I also know that it does not make sense according to the log but it happened multiple times.

But regarding your information I will wait for 7.00 as I would have to configure everything again anyway.

Thank you and have a nice evening.


RE: No menues / tabs moode 6.5.2 - TheOldPresbyope - 09-15-2020

(09-15-2020, 09:18 PM)Ale2.0 Wrote: Hello

I mean the function to configure with a config.txt
I see that it has no priority anymore but before I try again I would have liked to know if somebody tried to fix it.
I also know that it does not make sense according to the log but it happened multiple times.

But regarding your information I will wait for 7.00 as I would have to configure everything again anyway.

Thank you and have a nice evening.

The function in question is in the php module /var/www/inc/workerlib.php.

Beginning somewhere around line 2678 (I'm looking at 7.0.0 beta code so the starting line number may not be the same in 6.5.2)

Code:
// Auto-configure settings at worker startup
function autoConfig($cfgfile) {
       autoCfgLog('autocfg: Auto-configure initiated');

       //$contents = file_get_contents($cfgfile);
       $contents = str_replace("\r\n", "\n", file_get_contents($cfgfile));
       $autocfg = array();
       $line = strtok($contents, "\n");


The only recent fix to this function that I'm aware of didn't occur until very recently. Quoting from relnotes.txt for the upcoming 7.0.0 release:

Quote:- FIX: Manual entry of SSID not accepting embedded space

Regards,
Kent


RE: No menues / tabs moode 6.5.2 - TookaFace - 09-16-2020

There is a typo in moodecfg.defaut.txt from the repo, that's why it fail:

Code:
themename=Standard
should be:
Code:
themename=Default

In the log you provide, we can see:

Code:
[other]
timezone=Europe/Rome
themename=Standard
accentcolor=Emerald



RE: No menues / tabs moode 6.5.2 - TheOldPresbyope - 09-16-2020

Ah.

ETA - Thanks, @TookaFace for catching this!


That's an old bug which is *not* present in the /var/www/setup.txt instructions to which users are directed from the http://moodeaudio.org home page. Candidly I either never knew or had forgotten that the file you reference even existed and I was blind to that line in the OP's output. 

Mea culpa.

Regards,
Kent