Moode Forum
[PROBLEM] Maybe, Lost net connection while Spotify - Printable Version

+- Moode Forum (http://moodeaudio.org/forum)
+-- Forum: moOde audio player (http://moodeaudio.org/forum/forumdisplay.php?fid=3)
+--- Forum: Support (http://moodeaudio.org/forum/forumdisplay.php?fid=7)
+--- Thread: [PROBLEM] Maybe, Lost net connection while Spotify (/showthread.php?tid=829)



Maybe, Lost net connection while Spotify - HemiRick - 12-25-2018

Lost net connection while Spotify was idle, in order to get Moode to play from the local network again, I had to turn it off in configuration. Everything else I had tried did no good. I had stopped spotify on the puters it was playing on and rebooted the Moode Pi before turning finally turning spotify off in config. 

This seems like a bug maybe, Why didn't Moode know spotify was off on the local puters? Or does Moode talk to spotify over the net in the back round, and having lost this was clueless?

Thanks
Great program otherwise,
Rick


RE: Maybe, Lost net connection while Spotify - Tim Curtis - 12-25-2018

I'm not sure I understand the failure scenario.

Did you have a connection between Spotify client and moOde when the network went down?


RE: Maybe, Lost net connection while Spotify - HemiRick - 12-26-2018

Yes Spotify was connected but not playing


RE: Maybe, Lost net connection while Spotify - Tim Curtis - 12-26-2018

In that case you would need to restart Spotify renderer in moOde because there is no method or watchdog to detect that a network issue has occurred.