Thank you for your donation!


moOde 6.4.0 bug reports
#51
Using a public DNS as primary will cause issues when clients try to resolve hosts on the LAN. it's not a configuration that I can support.
Reply
#52
(12-01-2019, 01:20 PM)sjoerdju Wrote:
(11-30-2019, 08:54 PM)Tim Curtis Wrote:
(11-30-2019, 08:38 PM)sjoerdju Wrote: Hi Tim,

Thnx for the update, everything works fine except the maximum volume setting, it keeps putting it to 100% unfortunately. Double-checked it in alsamixer, still says 100.

Let me know if I can be of any help!

You can confirm the setting by the command below

Code:
pi@rp3:~ $ sqlite3 /var/local/www/db/moode-sqlite3.db "select * from cfg_system where id='34'"
34|alsavolume_max|80

Here's the help text for the feature

Code:
Establishes ALSA volume level that is used to set 0dB when MPD volume control is set to Software or Disabled, or when any of the Audio Renderers are active.

Whats your config?

- MPD volume = Software or Disabled?
- Renderer active?

pi@thequeensb:~ $ sqlite3 /var/local/www/db/moode-sqlite3.db "select * from cfg_system where id='34'"
34|alsavolume_max|87

It goes to 100 when using the Spotify Renderer / Librespot.

- MPD = Hardware (Hifiberry AMP).

Thnx!

Hi,

What is the output from the command below?

Code:
sqlite3 /var/local/www/db/moode-sqlite3.db "select value from cfg_system where param='alsavolume_max' or param='alsavolume' or param='amixname' or param='mpdmixer' or param='rsmafterspot' or param='inpactive'"

-Tim
Reply
#53
(12-01-2019, 03:19 PM)Tim Curtis Wrote: Using a public DNS as primary will cause issues when clients try to resolve hosts on the LAN. it's not a configuration that I can support.

Anyway it was just a quick alternative configuration, I normally use dhcp and, cosmetic problem apart, the configuration is ok with the dns address equal to the router address.

Then what about the initial problem about moodeutl line 83 warning?

Stefano
Reply
#54
I think that was cos of the broken update
http://moodeaudio.org/forum/showthread.p...2#pid14792
Reply
#55
(12-01-2019, 04:19 PM)Tim Curtis Wrote: I think that was cos of the broken update
http://moodeaudio.org/forum/showthread.p...2#pid14792

As explained the problem still occurs after a fresh install, as you can see in the system information report I sent
Reply
#56
Yes, the issue where ALSA volume is blank with that particular USB DAC.

Post the output from the cmd below so I can see what ALSA reports about the DAC's controls and mixer name.

Code:
amixer -c 1
Reply
#57
(12-01-2019, 03:59 PM)Tim Curtis Wrote:
(12-01-2019, 01:20 PM)sjoerdju Wrote:
(11-30-2019, 08:54 PM)Tim Curtis Wrote:
(11-30-2019, 08:38 PM)sjoerdju Wrote: Hi Tim,

Thnx for the update, everything works fine except the maximum volume setting, it keeps putting it to 100% unfortunately. Double-checked it in alsamixer, still says 100.

Let me know if I can be of any help!

You can confirm the setting by the command below

Code:
pi@rp3:~ $ sqlite3 /var/local/www/db/moode-sqlite3.db "select * from cfg_system where id='34'"
34|alsavolume_max|80

Here's the help text for the feature

Code:
Establishes ALSA volume level that is used to set 0dB when MPD volume control is set to Software or Disabled, or when any of the Audio Renderers are active.

Whats your config?

- MPD volume = Software or Disabled?
- Renderer active?

pi@thequeensb:~ $ sqlite3 /var/local/www/db/moode-sqlite3.db "select * from cfg_system where id='34'"
34|alsavolume_max|87

It goes to 100 when using the Spotify Renderer / Librespot.

- MPD = Hardware (Hifiberry AMP).

Thnx!

Hi,

What is the output from the command below?

Code:
sqlite3 /var/local/www/db/moode-sqlite3.db "select value from cfg_system where param='alsavolume_max' or param='alsavolume' or param='amixname' or param='mpdmixer' or param='rsmafterspot' or param='inpactive'"

-Tim

pi@thequeensb:~ $ sqlite3 /var/local/www/db/moode-sqlite3.db "select value from cfg_system where param='alsavolume_max' or param='alsavolume' or param='amixname' or param='mpdmixer' or param='rsmafterspot' or param='inpactive'"
87
0
Master
hardware
No
0

And also (to be complete):

pi@thequeensb:~ $ amixer
Simple mixer control 'Master',0
Capabilities: volume volume-joined
Playback channels: Mono
Capture channels: Mono
Limits: 0 - 248
Mono: 248 [100%]
Simple mixer control 'Channels',0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 248
Front Left: 173 [70%]
Front Right: 173 [70%]

I put the Channels on 70% manually (to reduce the distortion).
Reply
#58
moOde looks like it's working ok wrt setting alsavolume_max field.

IRC from years pat the HifiBerry AMP has a strange hardware volume controller thats not based on a dB scale and this causes issues but I see in the amixer output there are 2 simple mixers, Master and Channels. moOde is picking the first one in the list.

Does the Channels mixer behave like a master volume that adjust both channels simultaneously?

Something like

amixer sset Channels 70%
Reply
#59
I have been running for a couple of days with Roon 1.7 driving MoOde 6.4 on the USB-SIG.  Today I have had two instances of audio stuttering then stopping or just stopping.

One time it was during a local album playback from my NAS. The other time it was switching from local music to a Tidal Track.   

Roon is running on an Intel NUC i7 running Roon ROCK .

Here is the system log a bit later on it the day. 

If there are other logs you want please let me know.

System Information

S Y S T E M   P A R A M E T E R S

moOde release = 6.4.0 2019-11-24
Raspbian OS = 10.2
Linux kernel = 4.19.83-v7+ #1277
Platform = Allo USBridge SIG [Pi-CM3+ Lite 1GB v1.0]
Architecture = armv7l (32-bit)
System uptime = up 3 hours, 20 minutes
Timezone = America/Chicago
Current time = 2019-12-01 18:23:58

Host name = moode
Ethernet address = 192.168.1.169
Ethernet MAC = 00:17:f7:00:a7:d5
WLAN address = unassigned
WLAN MAC = no adapter
WLAN country = US

SoC identifier = bcm2837 
Core count = 4
Kernel timer freq = 100 Hz
SDCard freq = 50 MHz
USB boot = not available
Warranty = OK

Root size = 29G
Root used = 10%
Root available = 26G
Root expand = expanded
Memory free = 492 MB
Memory used = 227 MB
SoC temperature = 45.1°C

CPU governor = ondemand
Onboard WiFi = None
Onboard BT = None
HDMI output = On
Eth addr wait = On
Max USB current = Off
USB (UAC2) fix = Off
Pi-3B+ eth fix = Off
SSH term server = Off

PHP-FPM version = 7.3.11
NGINX version = 1.14.2
SQLite3 version = 3.27.2
Hostapd version = 2.8-devel
WiringPi version = 2.50
RPi.GPIO version = 0.7.0

A U D I O   P A R A M E T E R S

Audio device = USB audio device
Interface = USB
Mixer name = PCM
Hardware volume = None
Max ALSA volume = 100
Audio source = Local
Output device = Local
Resume MPD = No
Volume knob = 0
Volume mute = Unmuted
Saved MPD vol = 0
Preamp volume = 0
ALSA version = 1.1.8-1+rpt1
SoX version = 0.1.2-3

Bluetooth controller = Off
Pairing agent = Off
Airplay receiver = Off
Spotify receiver = Off
Squeezelite = On
UPnP client = Off
DLNA server = Off
GPIO button handler = Off
UPnP browser = On

Auto-shuffle = Off
Autoplay = Off
Rotary encoder = Off
Encoder params = 100 2 3 23 24
Polarity inversion = Off
Crossfeed = Off
Crossfade = Off
Parametric EQ = Off
Graphic EQ = Off
MPD httpd = Off

A P P E A R A N C E   S E T T I N G S

Theme = Fern
Accent color = Emerald
Alpha blend = 1.0
Adaptive background = No
Background image = No
Cover backdrop = No
Cover blur = 20px
Cover scale = 1.25
CoverView auto-display = Never
CoverView style = Animated
Auto-shuffle filter = None
Extra metadata = Yes
Playback history = No

L I B R A R Y   S E T T I N G S

Instant play action = Clear/Play
Show genres column = No
Album grouping = by Artist
Compilation identifier = Various Artists
Recently added = 1 Month
Ignore articles = a,an,the
UTF8 character filter = No
Hi-res thumbs = Auto
Cover search pri = Embedded cover
Pixel ratio = 2

M P D   S E T T I N G S

Version = 0.21.16
Volume control = disabled
ALSA device = hw:1
SoX resampling = disabled
SoX quality = very high
SoX multithreading = off
DSD over PCM (DoP) = yes
Replaygain = off
Replaygain preamp = 0
Volume normalization = No
Audio buffer = 4096 (kb)
Output buffer size = 131072 (kb)

B L U E T O O T H   S E T T I N G S

Bluetooth ver = 5.50
Bluealsa ver = 2.0.0
Speaker sharing = No
Resume MPD = No
PCM buffer time = 500000 (µs)

A I R P L A Y   S E T T I N G S

Version = 3.3.5
Friendly name = Moode Airplay
ALSA device = hw:1
Interpolation = soxr
Output bit depth = S16
Output sample rate = 44100
Session interruption = no
Session timeout = 120 (ms)
Latency offset = 0.0 (secs)
Audio buffer = 0.2 (secs)
Resume MPD = No

S P O T I F Y   S E T T I N G S

Friendly name = Moode Spotify
ALSA device = plughw:1
Bit rate = 160
Initial volume = 0
Volume curve = Logarithmic
Volume normalization = No
Normalization pregain = 0
Resume MPD = No

S Q U E E Z E L I T E   S E T T I N G S

Version = 1.8.7-1052 "DSD/SRC enabled"
Friendly name = Moode
ALSA device = hw:1
ALSA params = 80:4::1
Output buffers = 40000:100000
Task priority = 45
Codec list = flac,pcm,mp3,ogg,aac,alac,dsd
Other options = -W -D 500 -R E -S /var/local
Resume MPD = No

L O C A L   D I S P L A Y   S E T T I N G S

Local UI display = Off
Mouse cursor = On
Screen blank = 600 Secs
Wake display on play = Off
Brightness = 255
Pixel aspect ratio = Default
Rotate screen = 0 Deg

M O O D E   S T A R T U P   L O G

20191201 150322 worker: -- Start
20191201 150322 worker: Successfully daemonized
20191201 150322 worker: Integrity check (passed)
20191201 150322 worker: Session loaded
20191201 150322 worker: Debug logging (off)
20191201 150322 worker: Device raw: Card0 (ALSA) | Card1 (Control) | I2Sdev (none)
20191201 150322 worker: Device cfg: Name (USB audio device) | Card (1) | MPDdev (1) | Mixer (PCM) | Alsavol: (none)
20191201 150322 worker: ALSA volume (None)
20191201 150322 worker: -- System
20191201 150324 worker: Host name     (moode)
20191201 150324 worker: moOde release (6.4.0 2019-11-24)
20191201 150324 worker: Raspbian OS   (10.2)
20191201 150324 worker: Linux kernel  (4.19.83-v7+ #1277)
20191201 150324 worker: Platform      (Allo USBridge SIG [Pi-CM3+ Lite 1GB v1.0])
20191201 150324 worker: Architecture  (armv7l)
20191201 150324 worker: MPD version   (0.21.16)
20191201 150324 worker: CPU governor  (ondemand)
20191201 150324 worker: USB boot not available
20191201 150324 worker: File system expanded
20191201 150324 worker: HDMI port on
20191201 150325 worker: File check (OK)
20191201 150325 worker: -- Network
20191201 150325 worker: eth0 exists
20191201 150325 worker: IP addr (192.168.1.169)
20191201 150325 worker: Netmask (255.255.255.0)
20191201 150326 worker: Gateway (192.168.1.1)
20191201 150326 worker: Pri DNS (192.168.1.1)
20191201 150326 worker: Domain  (localdomain)
20191201 150326 worker: wlan0 does not exist
20191201 150326 worker: -- Audio
20191201 150326 worker: ALSA outputs unmuted
20191201 150326 worker: ALSA card number (1)
20191201 150326 worker: Audio output (USB audio device)
20191201 150327 worker: Audio formats (Unable to determine formats)
20191201 150327 worker: ALSA mixer name (PCM)
20191201 150327 worker: MPD volume control (disabled)
20191201 150327 worker: Hdwr volume controller not detected
20191201 150327 worker: -- Services
20191201 150327 worker: Reset renderer active state
20191201 150328 worker: MPD conf updated
20191201 150328 worker: MPD started
20191201 150328 worker: MPD accepting connections
20191201 150328 worker: Configure MPD outputs
20191201 150329 worker: MPD output 1 ALSA default (on)
20191201 150329 worker: MPD output 2 ALSA crossfeed (off)
20191201 150329 worker: MPD output 3 ALSA parametric eq (off)
20191201 150329 worker: MPD output 4 ALSA graphic eq (off)
20191201 150329 worker: MPD output 5 ALSA polarity inversion (off)
20191201 150329 worker: MPD output 6 ALSA bluetooth (off)
20191201 150329 worker: MPD output 7 HTTP stream (off)
20191201 150329 worker: MPD crossfade (off)
20191201 150329 worker: Audio source (Local)
20191201 150329 worker: Output device (Local)
20191201 150329 worker: Squeezelite renderer started
20191201 150329 worker: UPnP browser started
20191201 150329 worker: USB auto-mounter (udisks-glue)
20191201 150329 worker: -- Music sources
20191201 150329 worker: USB sources (none attached)
20191201 150331 worker: NAS and UPnP sources (mountall initiated)
20191201 150331 worker: -- Miscellaneous
20191201 150331 worker: Saved MPD vol level (0)
20191201 150331 worker: Preamp volume level (0)
20191201 150331 worker: MPD volume level (0) restored
20191201 150331 worker: ALSA volume level (None)
20191201 150331 worker: Auto-play (Off)
20191201 150331 worker: Maintenance interval (6 hrs)
20191201 150331 worker: Screen saver activation (Never)
20191201 150331 worker: Session permissions (OK)
20191201 150331 worker: Watchdog started
20191201 150331 worker: Ready
20191201 150331 watchdog: INFO Audio output is (in use)
20191201 160050 worker: Job slcfgupdate
20191201 160051 watchdog: INFO Audio output is (closed)
20191201 160058 watchdog: INFO Audio output is (in use)
20191201 182239 worker: Job slsvc
20191201 182244 watchdog: INFO Audio output is (closed)
20191201 182339 worker: Job slsvc
20191201 182346 watchdog: INFO Audio output is (in use)


Close
Reply
#60
I don't see anything suspicious in the log. This type of issue that only occurs infrequently along with the particular configuration u are using where there are multiple computers, players and renderers can be very difficult to troubleshoot. The logs rarely provide a clue to underlying cause of infrequent audio glitches.

Is it Roon/ROCK, the NUC, the network, the NAS, the file, the Music Service stream, the SIG, moOde, Squeezelite etc. ??

-Tim
Reply


Forum Jump: