Thank you for your donation!


Official moOde 6.5.1 support thread
#51
Cool tubeyness :-)
#52
(04-29-2020, 04:43 PM)Tim Curtis Wrote:
(04-29-2020, 04:22 PM)ICLlP Wrote: Fresh install of 6.5.1 yesterday. Library/Album view: only a handful of albums show and the alphabetical index on the right hand side is not functioning.

Check the MPD log to verify that all your albums wee successfully indexed
cat /var/log/mpd/log

Then on the Library Config page, Clear the library tag cache. It will be regenerated the next time you open Library Tag or Album view.
Thanks Tim. Sorted!
#53
When i disconnect Spotify renderer from moOde UI (the disconnect button), MPD does not resume, even if the option Resume MPD is set to YES for Spotify renderer, if i disconnect (or stop the music) from the app then MPD resume, i dont know if its normal behaviour ? It was already like that in previous versions.

When Bluetooth renderer is active, i can click on Bluetooth Active to go to the BlueZ settings, but when i do that, it stay on Bluez settings 1 or 2 sec then go back to the Bluetooth Active screen automaticelly without doing anything (i dont remember it was like that before), if i quikly disconnect then i have the same behavior as Spotify, mpd doesnt resume, if i disconnect from my phone, mpd resume.
#54
(04-29-2020, 04:01 PM)maartin Wrote:
(04-29-2020, 12:01 PM)maartin Wrote:
(04-29-2020, 11:14 AM)Tim Curtis Wrote: The thumbnail generator (thmcache) simply logs any exceptions it encounters and then resumes scanning the directory structure for album covers.

When you say "stops scanning the music library" do you mean you are not seeing all the album cover images or do you mean some of your albums are not indexed by MPD and do not show up in any of the Library views?

I tried to express that the scanning stops at some point. I had the scan running several times but there are only a few songs in the library. I think it is looping, until i stop it.

I am going to repeat the scanning. Where do i find the log that you might want to see?



AtB

maartin

Update:

I am checking /var/log/mpd/log regularly while running a scan. It seems ok with updating all files on NAS.

Only thing i changed is to delete all arguments in Library >Advanced >Mount Flags

So maybe my Network not networking properly.

I will wait now until mpd has run trough my library.

Thanks and
AtB
maartin

Hello Maartin,
Hi Maartin,
I'm having similar problems: what does it meens : "The only thing I changed is to delete all the topics in Library> Advanced> Mount Flags"?
I am trying to clear the logs continuously and it seems a bit better ... my library has over 30,000 albums !!! and get many "warnings" for the file fields.
Thank you and greetings,
Francesco
#55
(04-30-2020, 09:01 AM)TookaFace Wrote: When i disconnect Spotify renderer from moOde UI (the disconnect button), MPD does not resume, even if the option Resume MPD is set to YES for Spotify renderer, if i disconnect (or stop the music) from the app then MPD resume, i dont know if its normal behaviour ? It was already like that in previous versions.

When Bluetooth renderer is active, i can click on Bluetooth Active to go to the BlueZ settings, but when i do that, it stay on Bluez settings 1 or 2 sec then go back to the Bluetooth Active screen automaticelly without doing anything (i dont remember it was like that before), if i quikly disconnect then i have the same behavior as Spotify, mpd doesnt resume, if i disconnect from my phone, mpd resume.

I can repro.

When disconnecting via the disconnect button in moOde, MPD is not resumed. I'll need to look at the code to see why this is the case

The behavior where the Bluetooth Active screen keeps overlaying BlueZ config is a bug.
#56
Upgrading from 6.4.2 to 6.5.1 I noticed that I can see less albums at once in the album view.

The difference on my systems in available rows x columns thumbnails:
         tablet     pc
6.4.2   3.0x7     3.6x8
6.5.1   2.5x6     2.8x7

Is there a way how you can influence the scaling in 6.5.x ?

Thanks,
Marcel

ps found that changing panel.min.css does the trick (from thumbcols:16vw  to thumbcols:12vw), but not sure if that does have other unwanted side effects ?
#57
(04-30-2020, 11:22 AM)fdealexa Wrote:
(04-29-2020, 04:01 PM)maartin Wrote:
(04-29-2020, 12:01 PM)maartin Wrote:
(04-29-2020, 11:14 AM)Tim Curtis Wrote: The thumbnail generator (thmcache) simply logs any exceptions it encounters and then resumes scanning the directory structure for album covers.

When you say "stops scanning the music library" do you mean you are not seeing all the album cover images or do you mean some of your albums are not indexed by MPD and do not show up in any of the Library views?

I tried to express that the scanning stops at some point. I had the scan running several times but there are only a few songs in the library. I think it is looping, until i stop it.

I am going to repeat the scanning. Where do i find the log that you might want to see?



AtB

maartin

Update:

I am checking /var/log/mpd/log regularly while running a scan. It seems ok with updating all files on NAS.

Only thing i changed is to delete all arguments in Library >Advanced >Mount Flags

So maybe my Network not networking properly.

I will wait now until mpd has run trough my library.

Thanks and
AtB
maartin

Hello Maartin,
Hi Maartin,
I'm having similar problems: what does it meens : "The only thing I changed is to delete all the topics in Library> Advanced> Mount Flags"?
I am trying to clear the logs continuously and it seems a bit better ... my library has over 30,000 albums !!! and get many "warnings" for the file fields.
Thank you and greetings,
Francesco

You will find Mount Flags here:
 Moode-Gui > M (right upper corner) >Configure>Library>Mounted Source > Advanced> Mount Flags

My Library update run all night, I do not know when it had been ready, but the next morning it seemed fine. It is not that large (~2000 Albs), It took far more time then on 6.4.2 to generate.
When it had been ready I did clear the Library Tag Cache:

Moode-Gui > M (right upper corner) >Configure>Library (Config) > Music Database > Clear (Library Tag Cache)

And now all seems well.

Hope it helps.

All the Best
maartin
#58
(04-30-2020, 03:53 AM)duracell80 Wrote:
(04-28-2020, 08:17 PM)Tim Curtis Wrote: lol, moOde has no guarantees at all, none!, but our dysfunctional crew of hackers try to make some decent software to play music and help where we can :-)

Love that, I need part of that printing out for work Smile

LOVE the transparency and full screen modal for settings menu. Kinda disappointing to see the menu down chevron gone. It doesn't look like a menu now, maybe doing it as a "hamburger" would make it look more of a menu again? And the power off / reboot buttons being red rather than green throws me off a little but I love how huge they are.

The glow around the rings is very cool. Some OCD feedback here it's very minor. On the Raspberry Pi 7" Touch Screen the glow is cut off slightly by the surround container. Maybe some padding to move the ring more center?



Could use some padding in the bottom playbar to move the text and the controls further away from the edges and that little thick line was really slick in the old bar as a reminder on how to get back to the full player. The bottom playbar has a few minor issues on the time/countdown when a playlist item has a known duration.

New bar


Old bar


Here's possibly a playlist to plop into the RADIO and Playlist folders to help reproduce the playback time/countdown issue I saw. This doesn't happen with the old bar.





Code:
#EXTM3U
#EXTINF:2212,Sky News Daily - 04/29/2020 - Covid-19 crisis in care homes as PM becomes a dad again | 29 April 2020
https://api.spreaker.com/download/episode/26369515/podcast_final_290420_daily_boosted.mp3

#EXTINF:2586,Sky News Daily - 04/28/2020 - Protecting those in the NHS & social care: have we done enough? | 28 April 2020
https://api.spreaker.com/download/episode/26295082/podcast_final_280420_daily_boosted.mp3

#EXTINF:2114,Sky News Daily - 04/27/2020 - Covid-19 crisis: PM asks for our patience to avoid 'a new wave of death' | 27 April 2020
https://api.spreaker.com/download/episode/26218708/podcast_final_270420_daily_boosted.mp3

#EXTINF:1941,Sky News Daily - 04/24/2020 - UK Covid-19 crisis: Are we being treated like children? | 24 April 2020
https://api.spreaker.com/download/episode/26024138/podcast_final_240420_boosted2.mp3

I am able to repro with the first url.  The code thinks its a song file and not a radio station, prolly cos its only checking for the string "http" to differentiate between radio and song file. I'll investigate.
#59
After examining the code it turns out to be a case which has not been coded for yet.

Radio stations i.e. streaming sources always have the MPD status variable "time" equal to 0 but in this case the streaming source has "time" set to a value which causes a particular function to format the Playbar for a song file.
#60
Check for software update on 6.4.2 always said "Software is up to date".

Intalling 6.5.1 fresh, on my raspberry pi 1, there is no spotify renderer anymore :-( 
However, on my raspberry pi 2, it is there.


Forum Jump: