Thank you for your donation!


Solved: stupid noob questions - how to make ssh-modifications work permanent??
#1
Hi everybody.

I'm running moOde 4.4 with an Allo Boss Player and I'm impressed by the quality of sound and the possibilities of this player.
I have tried Volumio and Rune, but Moodeaudio is by far the best, most intuitive  and most stable player that I've tested so far.
Thank you for constantly make moOde better and better (started with 4.0)!!

But when it comes to customize the player, it painfully gets obvious, that I'm absolutely stupid in "computerthings".
Especially with Linux (shame on me...)

Maybe someone of the experienced users here can explain to me one step at a time (for a computer cave man like me!!),
how I can realize the following modifications, that would make moOde the worlds greatest audioplayer for my usage:


1) I want to make ashuffle exclude a specified genre.

I have two music directories on 2 seperate USB-devices connected to the Raspi:

directory A > 1759 files (FLAC and mp3) > tagged with " SLOW " in the genre column.
directory B > 9738 files (FLAC and mp3) > tagged with genre " FAST "


To exclude genre "SLOW" from being "consumed" I tried this:

- run PuTTYPortable.exe on my win7
- connect to Raspi via wifi
- login as: pi , password: moodeaudio

> login so far, so good

pi@moode: ~

> here I type: "ashuffle --exclude genre FAST"  > press 'enter'
> moode answers: "Picking random songs out of a pool of 1759 files"

1759 is exactly the amount of files in the "SLOW" directory, that I want to listen to.
But moode just doesn't want to do, what it said to me.
Ashuffle still picks files from both "genres".

What did I miss? How can I save the changes?!

Same behavior, if I try to exclude SLOW.
Moodes answer is: "Picking random songs out of a pool of 9738 files"
> but the player still consumes from both of the directories.

How can I make moode / ashuffle to do what I want?!

---------------------------------------------------------------------

2) I want to modify the file buffer in ashuffle to make crossfade work properly (new feature in 4.4)

PuTTYPortable.exe on Win7

pi@moode: ~

I type: ashuffle --queue_buffer 2 > enter
moode answers: "Picking random songs out of a pool of 11497."

From now on moode always leaves 2 files in the playlist as a buffer for crossfade.
That is exactly what I want and crossfade works fine as expected.

BUT:

When I close PuTTY, the buffer modification I've made gets instantly lost. 
How can I make this option to work permanently? Even after a reboot?!


Sorry for those ridiculous "noob" questions.
I'm clearly not a computer guy and I don't know where and how to start to learn some Linux basics.. Huh

I just want to implement those two essential modifications in my moOde.
But that seems impossible for me without the help of yours Smile
Would definitely be worth a donation to the moOd forum for me, if we can get those 2 things running.

Thank you.
Reply
#2
Hi Gitarrero,

Foa, there are in my opinion no stupid questions, only stupid answers…

In the latest version of moOde, you don't need the use of Putty anymore to do exactly what you want.

After switching on the ashuffle option under "Configure - Audio", just go in the menu to "Customize", and under "General Settings" at the top of the appearing window, type in next to Auto-Shuffle Filter something like "Genre Slow" (without the parenthesis). That ought to play a randow selection of your slow-selection.
Once that is done, select the "random" button on the playback window

Johan
 Angry
Reply
#3
Hi Johan,
that was a quick and a non-stupid answer :-)

Does exactly what I want! Thank you!!
Now I can use the smaller directory as a base repository being constantly consumed by ashuffle
and I can add single files from the big directory to the playlist, if i like to.

And now - I wonder why - it seems, that the shuffle_buffer is also ok. How could that be?!?!
Without any changes there is always one file left in the playlist, so that the crossfader works fine!
Strange!! But perfect for my needs.

That was easy!
Reply
#4
For once I can give a decent answer ;-)

now, please change the "Problem" in the title of the tag to "Solved", that way the forum peeps are also happy...

Johan
 Angry
Reply
#5
Hi @gitarrero,

Don't forget to read the release notes :-)

Code:
########################################################
//
// 4.4 2018-12-18 update
//
########################################################

New features

- NEW: CoverView backdrop styles
- NEW: Pure Black theme
- NEW: Auto-shuffle Crossfade support
- NEW: Auto-shuffle tag filter

Radio stations

- UPD: Amys FM Spirit of Soul (320K)
- UPD: Buddha Radio

Updates

- UPD: Add Raspbian version to ssh header
- UPD: Add icon for upmpdcli
- UPD: Zero out ALSA volume at top of worker
- UPD: Improve help text on System config
- UPD: Bump auto-shuffle to v1.1.0

Bug fixes

- FIX: Duplicate symlink for Zend opcache
- FIX: Cover not changing for mp3 format files
- FIX: Extra metadata somtimes not updating
- FIX: Adv search results add whole collection
Reply
#6
Hi Tim,

you are right!
But reading is just one side of the coin...understanding the written correctly is often another piece of cake ;-)

But I can see now what you mean Smile
Thank you for your excellent and steady work on moOde.

But I have another question:

I played around with some tags.
In moOde I can search for tags like "Composer", "Performer", "Release Date"  etc.

If I modify these tags on some files in foobar2000 and try a search on it in moOde, it seems that not all of them got found correctly.

For example:

I modify the tags of two files in foobar:

File A - Composer = "TEST"
File B - Performer = "TEST"

After an update of the playlist I search for "TEST" within the relevant search fields in moOde.
But only File A gets found, where the Composer-Tag is set to "TEST".
Performer doesn't get found.

The patterns in foobar are %COMPOSER% and %PERFORMER%.

What is the problem here?

Chris
Reply
#7
Did u update MPD database after making the tag changes?
Reply
#8
Yes I did.

I tried update and regenerate MPD, but just the Composer tag gets found.
Reply
#9
To see whether MPD picked up the tags try the command below while the song is playing. If you don't see the tags in the currentsong dump then MPD did not find them in the song file during the update process. Possibly because foobar did not format the tag in a way that MPD understands ???

Code:
telnet localhost 6600
currentsong

I assume you are using the Advanced search in the Music tab, Folder view.
Reply
#10
(12-30-2018, 06:05 PM)Tim Curtis Wrote: To see whether MPD picked up the tags try the command below while the song is playing. If you don't see the tags in the currentsong dump then MPD did not find them in the song file during the update process. Possibly because foobar did not format the tag in a way that MPD understands ???

Code:
telnet localhost 6600
currentsong

I assume you are using the Advanced search in the Music tab, Folder view.

Tim,

I can confirm what gitarrero says. There is no "Performer" in the list. Also the "name" is not in the list. I replied to the thread where Kent replied to this (here).

Johan
 Angry
Reply


Forum Jump: