Thank you for your donation!


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
System optimizations?
#21
(06-06-2018, 12:53 PM)moodenigo Wrote: The only tweaks I have applied are the following:

- added in /boot/cmdline.txtisolcpus=2,3
- changed options in /lib/systemd/system/mpd.service
    CPUSchedulingPolicy=fifo
    CPUSchedulingPriority=70
    Nice=-15
    ExecStart=/usr/bin/taskset -c 2,3 /usr/local/bin/mpd --no-daemon $MPDCONF

I did not change anything else. This made some difference!  In fact, because of the fact that mpd and its subprocesses run on two reserved cores, and nothing else runs on those cores, you should get all the advantages of LL and RT kernels.

  Roberto

Its all sounding very nice now Big Grin

Has anyone been game to try the whole list of tweaks from the DIY forum as swizzle has pointed out ?
http://www.diyaudio.com/forums/pc-based/...ost5398891
Reply
#22
I wouldn’t underclock your Pi to 333 MHz as in that post, you should probably stick with Archimago’s settings for /boot/config.txt unless you really know what you’re doing.
Reply
#23
hello there,
i'e applied the modifications as described below posted on DIYAUDIO by SINSKI and the sound is axcellent , tahnk you very much!
one little point is when i'm playing DSF files, i sometimes have a "buffer time" , could it be due to the low frequency of the CPU ?
which parameters could i try to see if it is better, but still having the same harmony in the values?
thanks in advance!


Originally Posted by sinski View Post
So, now i did some more tests and i am trying to put all information about sound quality tweaking in one place.

1. This is a must - wifi off, bt off, hdmi off, volume control off, eq off, resampling off.

2. added in /boot/config.txt :

force_turbo=1
avoid_pwm_pll=1
arm_freq=333
over_voltage=-7
core_freq=166
h264_freq=166
isp_freq=166
v3d_freq=166
gpu_freq=166
sdram_freq=166
sdram_schmoo=0x021e882c
over_voltage_sdram_p=5
over_voltage_sdram_i=3
over_voltage_sdram_c=-13
gpu_mem=16


3. added in /boot/cmdline.txt:

dwc_otg.microframe_schedule=0 dle=0 dwc_otg.nak_holdoff_enable=1 dwc_otg.fiq_fix_enable=0 dwc_otg.lpm_enable=0 smsc95xx.turbo_mode=N isolcpus=2,3

isolcpus is isolating two cpus only for mpd and works only on quadcore pi's

4. changed options in /lib/systemd/system/mpd.service, original value is uncommented:

#CPUSchedulingPolicy=other
CPUSchedulingPolicy=fifo

tried different, for me fifo sounds best.

#CPUSchedulingPriority=43
CPUSchedulingPriority=70

tried higher settings, but 70 is a good compromise

#Nice=-10
Nice=-15

also tried higher values, but -15 is a good compromise

#ExecStart=/usr/local/bin/mpd --no-daemon $MPDCONF
ExecStart=/usr/bin/taskset -c 2,3 /usr/local/bin/mpd --no-daemon $MPDCONF

this one is starting mpd using isolated cpus and no other processes are using those cpus.

My streaming is sounding as good, as never before and now it is clear for me, that underclocking cpus and ram is really great.

Thanks to anybody, who found out, how to "audiophilise" and "de-digitituslise" moOde

Maybe some of those tweaks (which are not making system unstable) can be implemented in moOde?
Reply
#24
anybody?
Reply
#25
Hi,

I leave these OS modifications up to individual user because my past experience when I included some system and OS level settings in moOde was that they created a huge additional support burden but were of questionable benefit.

-Tim
Reply
#26
@jayce996

The archimago settings linked previously are what I would stick with for config.txt. As I said before
333Mhz is too low for the clock speed. The thing with mpd and isolated cores, maybe? I didn’t notice it making any difference when I tried it but I don’t use a dac hat or do any upsampling, and anyway I can’t really run tweaks like that while helping out on the project because I don’t want to introduce any extraneous variables.
Reply
#27
(09-04-2018, 08:49 AM)jayce996 Wrote: hello there,
i'e applied the modifications as described below posted on DIYAUDIO by SINSKI and the sound is axcellent , tahnk you very much!
one little point is when i'm playing DSF files, i sometimes have a "buffer time" , could it be due to the low frequency of the CPU ?
which parameters could i try to see if it is better, but still having the same harmony in the values?
thanks in advance!


Originally Posted by sinski  View Post
So, now i did some more tests and i am trying to put all information about sound quality tweaking in one place.

1. This is a must - wifi off, bt off, hdmi off, volume control off, eq off, resampling off.

2. added in /boot/config.txt :

force_turbo=1
avoid_pwm_pll=1
arm_freq=333
over_voltage=-7
core_freq=166
h264_freq=166
isp_freq=166
v3d_freq=166
gpu_freq=166
sdram_freq=166
sdram_schmoo=0x021e882c
over_voltage_sdram_p=5
over_voltage_sdram_i=3
over_voltage_sdram_c=-13
gpu_mem=16


3. added in /boot/cmdline.txt:

dwc_otg.microframe_schedule=0 dle=0 dwc_otg.nak_holdoff_enable=1 dwc_otg.fiq_fix_enable=0 dwc_otg.lpm_enable=0 smsc95xx.turbo_mode=N isolcpus=2,3

isolcpus is isolating two cpus only for mpd and works only on quadcore pi's

4. changed options in /lib/systemd/system/mpd.service, original value is uncommented:

#CPUSchedulingPolicy=other
CPUSchedulingPolicy=fifo

tried different, for me fifo sounds best.

#CPUSchedulingPriority=43
CPUSchedulingPriority=70

tried higher settings, but 70 is a good compromise

#Nice=-10
Nice=-15

also tried higher values, but -15 is a good compromise

#ExecStart=/usr/local/bin/mpd --no-daemon $MPDCONF
ExecStart=/usr/bin/taskset -c 2,3 /usr/local/bin/mpd --no-daemon $MPDCONF

this one is starting mpd using isolated cpus and no other processes are using those cpus.

My streaming is sounding as good, as never before and now it is clear for me, that underclocking cpus and ram is really great.

Thanks to anybody, who found out, how to "audiophilise" and "de-digitituslise" moOde

Maybe some of those tweaks (which are not making system unstable) can be implemented in moOde?

I have same expreince, the .dsf file play jerky/jagged.
I think it's a cpu problem, can't process the highest bit-/sample-rate file, perhaps. (?)
Reply
#28
thank you Tim & Swizzle, i completely understand that the tweaks are generating additionnal troubles.
as i don't know to tweak it for my dsd playback, i'll revert all these values:

avoid_pwm_pll=1
arm_freq=333
over_voltage=-7
core_freq=166
h264_freq=166
isp_freq=166
v3d_freq=166
gpu_freq=166
sdram_freq=166
sdram_schmoo=0x021e882c
over_voltage_sdram_p=5
over_voltage_sdram_i=3
over_voltage_sdram_c=-13
gpu_mem=16

thanks anyway!

last question, can i have the following renderers activated? as when i have activated the Squeezebox renderer, i wasn't able to airplay music after playing a song from my squeeze player.
thanks !!!
Reply
#29
Squeezelite has to be turned off via the power button on LMS. Then it will release the audio channel and moOde volume setting will be restored.
Reply
#30
Hello, I'm afraid
/var/lib/systemd only:
Backlight
catalog
coredump
deb-systemed-helper-enebled.
rfkill
i have no folder system/mpd.service
Have moode 3.7
ask for help
greeting ricky

[url=[Image: d35dc5-1537202154.jpg]][Image: d35dc5-1537202154.jpg][/url]
Reply


Forum Jump: