Thank you for your donation!


New feature v 5 HTTP streaming
#31
Hi Folks, Http streaming is a great option. First of all thanks to the great developer.

Now I can cast the local music to my chromecast devices also. this enhancey my multiroom capability extremely.
But now the question: it is not synchronized with the local pi. It would be an great option to tweak the time delays to get it nearly synchronized. Is this somehow possible?

Best Regards
Paul
Reply
#32
Not with HTTP streaming but I've begun to work out a design for an MPD/ALSA based sync audio solution that would sync local MPD playback with remote endpoints. Prolly needs another dev to do the actual coding.
Reply
#33
Hi,
unfortunatelly I can't get HTTP streaming to work im 6.4.1. I activated it in the settings but opening http://<ip>:8000 gives me a ERR_CONNECTION_REFUSED in my browser.
Do you have any hints for me? Thanks!
Reply
#34
(02-08-2020, 07:09 AM)audiocore Wrote: Hi,
unfortunatelly I can't get HTTP streaming to work im 6.4.1. I activated it in the settings but opening http://<ip>:8000 gives me a ERR_CONNECTION_REFUSED in my browser.
Do you have any hints for me? Thanks!

try <ip>:8000
ie..no 'http://'

otherwise...what browser, what o/s... what host o/s..what firewall?? have you opened the port:8000 ?? more info appreciated Smile
Works here Ootb using Ubuntu (Linux) Desktop and Firefox
Reply
#35
* Enable HTTP streaming in [Configuration] > [Audio] > [HTTP Streaming] (note the port you have set).
* Connect from a browser at http://{hostname or ip):{port}

If you're using an Android device as your controller try the MPD client app M.A.L.P. M.A.L.P controls MPD directly and can stream from MPD in-app, no browser required.
Reply
#36
Hi Drone an vinnn,

thank you for your answers. I tried both, with http and without.
Host OS is Android/W10/Linux. Browser is Chrome,...
Makes no difference. I got an additional Server running on moodeaudio on port 9090, which is running flawlessly. Port should be open on raspberry pi?
Reply
#37
A quick test using stock 6.4.1 and no issues on my end with HTTP server. Both host and UP address work perfectly. One client was another Pi. I created two radio stations with the URL's below. The other client was an iMac + iTunes.

http://rp6:8000
http://192.168.1.157:8000

You could try the netstat command on the pi running the http server to see if there is anything suspicious.
Reply
#38
Ok this is strange. I set it up new (activated HTTP streaming) and now it is running Smile
Thanks for your help!
Reply
#39
SOLVED-

SOLUTION: I can´t have audio resampling set to 24/192- had to change to 16/44 - maybe if I disable audio resampling the delay changes.

PS- this is GREAT!!

Hello all!

I have problem with this nice feature, cant get it to work.

Rpi3B+
Iqaudio DAC+
Moode version: 6.4.2 2020-02-12.

http-streaming: on , using default port.
Tried access in several browser and players: both with http:// and without
Firefox,chrome,duckduckgo and M.A.L.P @android

Firefox and VLC @ windows 10 PC.
every browser says connection failed.

BUT! Fing finds the port
I can accces moode gui from every browser.

So where do I start to look, I have looked in my router/modem its 4g mobile broadband, finds nothing about ports.
I have rebooted moode and PI.

So what next step should I take, anyone with any solution?
RPi3 v1.2 -> IQaudio Dac+ -> Luxman L430 -> Sonab Oa12
Reply
#40
So Fing finds the ip and port...something like 192.168.1.x:8000 but putting that into the address bar of all your browsers fails..?
Does sound like a network/router problem...
Reply


Forum Jump: