Thank you for your donation!


Problem: Dac USB M2Tech
#11
pi@moode:~ $ lsusb
Bus 001 Device 004: ID 249c:930f M2Tech s.r.l.
Bus 001 Device 006: ID 0bc2:61b6 Seagate RSS LLC
Bus 001 Device 005: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@moode:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: UAC2 [hiFaceDAC UAC2], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
Reply
#12
Looks ok.

To troubleshoot I would suggests starting from the base configuration.

1. Unplug USB DAC and any other USB audio device
2. Open Audio config and  SET I2S audio device to "None"
3. Reboot
4. Open MPD config and verify that "On-board audio device" appears in the Audio device dropdown.
5. Save (or Apply) the MPD config
6. Open the Playback screen and verify that either a radio station or song file can be played. You don't have to connect anything to the built-in Raspberry Pi audio out, just verify that the Playback screen indicates the item is playing.

If above was successful then continue

1. Plug in your USB DAC
2. Open MPD config and verify that both "On-board audio device" and USB audio device" appear in the Audio device dropdown.

If above was successful

1. Select "USB audio device"
2. Save (or Apply) the MPD configuration
Reply
#13
Hi, I followed the instructions as indicated.

Step 4. "On-board audio device" and USB audio device "appear in the Playback screen, under" customize "→" Customization settings "and not in MPD config.



In MPD config “Audio device”: -Nothing selected-
Reply
#14
That result would suggest some breakage.

With the USB audio device plugged in what is output from the following commands?
Code:
cat /proc/asound/card0/id
cat /proc/asound/card1/id
sqlite3 /var/local/www/db/moode-sqlite3.db "select * from cfg_mpd where param='device'"

-Tim
Reply
#15
pi@moode:~ $ cat /proc/asound/card0/id
cat: /proc/asound/card0/idcat: No such file or directory                                                                                                                                      
cat: /proc/asound/card0/id: No such file or directory                                                                                                                                        
pi@moode:~ $ cat /proc/asound/card1/id
UAC2                                                                                                                                                                                          
pi@moode:~ $ sqlite3 /var/local/www/db/moode-sqlite3.db "select * from cfg_mpd where param='device'"
19|device|0|0                                                                                                                                                                                
pi@moode:~ $
Reply
#16
Hi,

The result below suggests your configuration may be broken.

Code:
pi@moode:~ $ cat /proc/asound/card0/id
cat: /proc/asound/card0/idcat: No such file or directory                                                                                                

The result of that command should return the string "ALSA" on a system with only a single USB audio device plugged in. It represents the id of the on-board Raspberry Pi audio device and it's enabled via the "dtparam=audio=on" line in /boot/config.txt. Below is an example from one of my test systems with a USB DAC plugged in.

Code:
pi@rp5:~ $ cat /proc/asound/card0/id
ALSA

pi@rp5:~ $ cat /proc/asound/card1/id
DAC

pi@rp5:~ $ cat /boot/config.txt
disable_splash=1
hdmi_drive=2
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=audio=on
#dtoverlay=pi3-disable-wifi
#dtoverlay=pi3-disable-bt
pi@rp5:~ $
Reply
#17
Hi, now with MoOde 5.0 the USB device is recognized !! A great job. Thanks for all. Luigi
Reply


Forum Jump: