Thank you for your donation!


Problem: issues setting up NFS mount
#1
**note** fresh install of 4.4

'm really feeling like a clown for having to post this, and i'm sure i'm just missing something really simple, but I cant seem to get a NFS mount to work for a source. (at all)

I'm guessing I have the wrong syntax or something, because the NFS mount works via the CLI when I ssh into the box. I've tried the following....

[Image: kH7aSPr.png]

Which results in a red check mark and the following error

20190412 232332 worker: Job sourcecfg

20190412 232332 wrk_sourcemount(): Mount error: (mount.nfs: mount point /mnt/NAS/FS does not exist)
20190412 232335 worker: Job updmpddb

I enabled debug logging, and it seems like I get less logging from mount process???


Using a normal NFS mount via the CLI seems to work just fine though...

sudo mount -t nfs 192.168.0.110:/mnt/bulk/media/music /mnt/test
Reply
#2
Its odd that with debug logging enabled there is no record of the mount string in the log given the presence of the code below in the sourceMount() function in /var/www/inc/playerlib.php


Code:
$sysoutput = sysCmd($mountstr);
debugLog('sourceMount(): mountstr=(' . $mountstr . ')');
debugLog('sourceMount(): sysoutput=(' . implode("\n", $sysoutput) . ')');


To troubleshoot I'd first make sure that /mnt/NAS dir exists. There is no code in moOde that deletes it and its part of the platform build so it should definitely be there.

-Tim
Reply
#3
(04-13-2019, 06:34 PM)Tim Curtis Wrote: Its odd that with debug logging enabled there is no record of the mount string in the log given the presence of the code below in the sourceMount() function in /var/www/inc/playerlib.php


Code:
$sysoutput = sysCmd($mountstr);
debugLog('sourceMount(): mountstr=(' . $mountstr . ')');
debugLog('sourceMount(): sysoutput=(' . implode("\n", $sysoutput) . ')');


To troubleshoot I'd first make sure that /mnt/NAS dir exists. There is no code in moOde that deletes it and its part of the platform build so it should definitely be there.

-Tim


/MNT/NAS is definitely not there... I'll create it and see what I get.

Strange though if its part of the iso. All I did was use etcher to write it to SD and booted it up. I didnt do any trickery
Reply
#4
haha now it works after the creations of the NAS folder.

crazy.

I'll image another SD card later to see if i can replicate that missing NAS folder condition.
Reply
#5
Hi,

Thanks for confirming that /mnt/NAS was not there. I think this must be a bug because the dir is present on the ISO and there is no code in moOde that explicitly deletes it. I'll need to examine the code and see if I can noodle it out or possibly repro.

If u get a repro, please post the steps :-)
Reply
#6
Confirmed that this is a bug. Fixed in moOde 5 :-)
Reply
#7
(04-13-2019, 10:19 PM)Tim Curtis Wrote: Confirmed that this is a bug. Fixed in moOde 5 :-)

haha nice man.

Glad I could help out. Just waiting on my cable shipment from BlueJeans to put this thing to use. thanks for your time and effort to this project.
Reply


Forum Jump: