Thank you for your donation!


Problem: Seeed 2-Mics Hat sound wont work
#1
Hi Guys, I'm just a noob to this so be nice...

I have successfully installed the Seed 2-Mics Hat to a Raspberry Pi Zero with MoOde Audio image.
I'm able to test and play sound from terminal, but don't know how to change MoOde's audio settings to output to this board.

The hardware is as below:

 aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 6/7
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: seeed2micvoicec [seeed-2mic-voicecard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Reply
#2
What does the manufacturer specify for configuring the device?
Reply
#3
PROBLEM SOLVED!

I changed the MPD Config to USB Audio.
Reply
#4
(04-14-2019, 11:30 PM)adzy80 Wrote: PROBLEM SOLVED!

I changed the MPD Config to USB Audio.

That's interesting.

The Seeed 2-Mics Hat is not a USB device.

Presumably, this solution configures MPD to connect to an ALSA "card:device" combination which happens to correspond to the custom Seeed driver via the ALSA configuration information loaded along with the driver during the Seeed software install.

Kinda mysterious without knowing more details of what's going on behind the scenes.

Regards,
Kent
Reply


Forum Jump: