Thank you for your donation!


Solved: Sound from onboard audio (moOde 5)
#1
Tongue 
Hey,
Sound from onboard audio is bad since moOde 5 (cracking).

The problem happens because of period_time "256000000" option in mpd.conf.

If i remove this, and restart mpd, then sound is normal.

It should also fix the sound from HDMI.
Reply
#2
When you select 0.25X, for Hardware period time, and save, 0.0025X value is shown in moOde mpd options.
Same, when you select 0.0025X and save, then default value is shown.
Reply
#3
(04-25-2019, 07:43 AM)TookaFace Wrote: Hey,
Sound from onboard audio is bad since moOde 5 (cracking).

The problem happens because of period_time "256000000" option in mpd.conf.

If i remove this, and restart mpd, then sound is normal.

It should also fix the sound from HDMI.

Perfect Solution for my problem in this forum thread -> http://moodeaudio.org/forum/showthread.p...89#pid9789 

Thank you very much!
Reply
#4
Hi,

Was your solution to revert the kernel, remove the option from mpd.conf or both?
Reply
#5
(04-27-2019, 09:25 PM)Tim Curtis Wrote: Hi,

Was your solution to revert the kernel, remove the option from mpd.conf or both?

I have tried several things, but i'm not a unix insider .....

kernel (4.14.98). MPD 20.20  with "period_time 256000000 option in /etc/mpd.conf" patch -> not ok
kernel (4.14.98). MPD 20.20  without "period_time 256000000 option in /etc/mpd.conf" patch -> ok

After try to switchback to kernel 4.19.34 with your code it shows allways kernel 4.14.98 -> see printscreen
in the momment i'm on kernel 4.14.98 
... and after every reboot i have to patch /etc/mpd.conf again ...


   




 
Reply
#6
Very odd that there is no terminal output whatsoever from rpi-update. It either installs the new kernel and prints a bunch of status lines or if you are already at that particular kernel version it prints a few lines and ends with "*** Your firmware is already up to date" Maybe there is some breakage in your system.

In any case I ran a quick test with On-board audio + 4.19.34 kernel + MPD 0.20.20 + the output block below in mpd.conf and no issues or audio distortion :-) This is on stock moOde with no DSP enabled.

Code:
audio_output {
type "alsa"
name "ALSA default"
device "hw:0,0"
mixer_type "hardware"
mixer_control "PCM"
mixer_device "hw:0"
mixer_index "0"
dop "no"
}
Reply
#7
Yes, with that audio_ouput i dont have problem either, but my audio_ouput looks like that when i save from moOde mpd option:


Code:
audio_output {
type "alsa"
name "ALSA default"
device "hw:0,0"
mixer_type "software"
dop "no"
auto_resample "yes"
auto_channels "yes"
auto_format "yes"
buffer_time "500000"
period_time "256000000"

I also tried 4.14 kernel, but i still have sound problem with my mpd.conf (with period_time "256000000") with on-board audio.
Reply
#8
The upcoming update for 5.1 reverts to letting MPD deal internally with buffer time/period and ALSA auto-conversion. Those .conf settings and MPD config input fields have been removed :-) I have no idea why their presence in mpd.conf causes audio distortion with on-board and HDMI. Probably a bug in MPD...
Reply
#9
Ha nice Smile

Yeah weird, i didn't notice any problems with DAC.
Reply
#10
Hi,

i have exactly the same problem with moode 5.1 using onboard audio on HDMI. If i use onboard audio with analogue output, everything working fine. I just installed 5.0, upgraded to 5.1 without any changes. I tried to change the kernel as recommended above, but it couldn't help. I'm not an unix guru. :-|
Reply


Forum Jump: