Thank you for your donation!

Solved: Unable to delete radio station

I am running Moode 5.1 on a Pi3b. I have deleted all included radio stations. This worked so far for nearly all stations. Only two stations  could not be deleted. If have tried to remove the two stations serveral times. I tried differnet browsers and also different clients (two PCs one Tab)

I have also tried to remove the remaining two stations from the cfg_radio table in the sqlite db. But no success.  A restart of Moode as well as a re-gen of the mpd database after deleting the two rows of the table  did not solve the issue.

Any idea how to get rid of the two entries?

Make sure you don't delete row 499 in cfg_radio or user added stations will not be preserved during an update.

Check /var/lib/mpd/music/RADIO. It contains the /pls files. Also check mpd log to see f there is an indication of what's going on.
Thanks Tim,

I have deleted the two remaining radio stations in/var/lib/mpd/music/RADIO. After an update of the MPD Database the two stations are gone now. The MPD log does not contain any entries. So unfortunately I can not give you any more error details.

Problem solved! Thanks for your help!

I am having the same issue. It stations with an apostrophe. I was also not able to add a station with an apostrophe (Oui FM 60's). Assume it is a SQL issue.
Likely the string needs escaping...
I was able to slip this fix into the upcoming 5.1 -> 5.2 update :-)

Goal is to release this week including a full ISO image for moOde 5.2.
Perfect - Thanks a lot Tim

Forum Jump: