Thank you for your donation!


Newbie to Moode - Help with HiFace config
#1
Hi all,

I'm a total newbie to Moode (but used to the RPi & Raspbian) and really enjoying the ability to play my music with it.

I do have a question: I'm using an M2Tech Hiface evo digital to digital converter.
This unit connects to my Pi via USB and outputs an SPDIF signal that goes to my DAC.

If I run the command "aplay -l" it shows up as follows:
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
 Subdevices: 7/7
 Subdevice #0: subdevice #0
 Subdevice #1: subdevice #1
 Subdevice #2: subdevice #2
 Subdevice #3: subdevice #3
 Subdevice #4: subdevice #4
 Subdevice #5: subdevice #5
 Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 1: hiFace [hiFace], device 0: USB-SPDIF Audio [USB-SPDIF Audio]
 Subdevices: 1/1
 Subdevice #0: subdevice #0

So far so good it seems...
When i go to the Moode config page, it doesn't show up as an audio device though, so i can't select it as my output device.

The only way i can get the HiFace to work is if i select "local device" in Moode config and add the following lines to mpd.conf and then restart the mpd service.

Code:
audio_output {
   type "alsa"
   name "HiFace Evo"
   device "hw:1,0"
}

The downside of doing this is that mpd.conf is overwritten on every change, and also every time the Pi boots.

I've tried creating a file /etc/asound.conf with the following content.
Code:
defaults.pcm.card 1
defaults.ctl.card 1
 
The idea was to make the HiFace the default output device in ALSA, but that didn't work.

I do have a working setup, but it's just a bit hacky to mess with mpd.conf myself and have it overwritten on every boot.

Is there anything I'm missing? Is the HiFace unit just a bit weird in the setup it needs? Can this be done in a better way than i'm doing now?

Many thanks for your thoughts!

PS. I'm running moOde 5.2 2019-05-07 on a Pi-3B+ Kernel 4.19.40-v7+
Reply
#2
The Setup guide has a section that explains how to configure a USB audio device.
https://github.com/moode-player/moode/bl.../setup.txt

First though you need to undo your modifications.
Reply
#3
Sorry, I should have mentioned that I've followed the guide to configure a USB device to the letter.
When done, there was no audio going to my Hiface.

I just went over absolutely everything again and found the issue!
Please don't laugh (too hard) when my solution was.....to turn up the volume, doh!

Following the setup guide it mentions to leave the volume control at "software".
By default, after a fresh install, the volume in Moode is 0 (zero) and it really benefits the listening experience to turn it up a bit ;-)
Reply
#4
lol, I've been there.

If your audio device supports Hardware volume then "Hardware" will also appear in the dropdown on the MPD config page.
Reply
#5
I've now put volume control at Disabled (0 dB output) and i'm using the volume control on my amp (which i prefer)
All works really well now, i'm very pleased at how it all works :-)

I just gave Airplay a go and I did notice that the volume when using airplay is significantly lower compared to just playing something from Moode directly.
When using airplay I can open up the volume on my amp completely and have the output sounding not much louder than a normal conversation.
When i open up the volume on a track I play via Moode directly then the neighbors would be at my door quite quickly.

Not sure where this big difference in volume is coming from (PS, I've un-done all my 'fixes' i tried earlier)
Reply
#6
Oh man....I have to stop posting here.
Volume control on the iPhone was waaaaaaaaay low.

Note to self: TURN UP THE VOLUME!!!
Reply


Forum Jump: