Thank you for your donation!


Solved: moOde AP not found
#1
Yesterday I did a firmware update to Orbi wifi and then downloaded 5.2. I booted up the pi but the moOde AP network was not found. Thinking it might be an issue with the firmware update I downloaded volumio, just a test mind you and the volumio AP network was found.

I assume moOde 5.2 was meant to boot up in AP, is that correct? 

Thanks

Fix for 5.2 released 5/14/2019. My thanks to the "fixer".
Reply
#2
(05-13-2019, 06:09 PM)Onionhead Wrote: Yesterday I did a firmware update to Orbi wifi and then downloaded 5.2. I booted up the pi but the moOde AP network was not found. Thinking it might be an issue with the firmware update I downloaded volumio, just a test mind you and the volumio AP network was found.

I assume moOde 5.2 was meant to boot up in AP, is that correct? 

Thanks

Seconding this - I wanted to do a fresh install of 5.2 but ended up having to do 5.0 > 5.1 > 5.2 as the AP wasn't coming up.
Reply
#3
(05-13-2019, 09:02 PM)Pieter Wrote:
(05-13-2019, 06:09 PM)Onionhead Wrote: Yesterday I did a firmware update to Orbi wifi and then downloaded 5.2. I booted up the pi but the moOde AP network was not found. Thinking it might be an issue with the firmware update I downloaded volumio, just a test mind you and the volumio AP network was found.

I assume moOde 5.2 was meant to boot up in AP, is that correct? 

Thanks

Seconding this - I wanted to do a fresh install of 5.2 but ended up having to do 5.0 > 5.1 > 5.2 as the AP wasn't coming up.

Not where I can investigate at the moment but this sounds like it might be another regression like one we resolved earlier, caused by changes in the kernel. Then again it could be a simple error in preparing the 5.2 image.

Regards,
Kent
Reply
#4
(05-13-2019, 09:02 PM)Pieter Wrote:
(05-13-2019, 06:09 PM)Onionhead Wrote: Yesterday I did a firmware update to Orbi wifi and then downloaded 5.2. I booted up the pi but the moOde AP network was not found. Thinking it might be an issue with the firmware update I downloaded volumio, just a test mind you and the volumio AP network was found.

I assume moOde 5.2 was meant to boot up in AP, is that correct? 

Thanks

Seconding this - I wanted to do a fresh install of 5.2 but ended up having to do 5.0 > 5.1 > 5.2 as the AP wasn't coming up.

The symptom suggests a regression. I'm not able to test ATM but are u saying that the 5.0 image does not exhibit this issue?

-Tim
Reply
#5
I did fresh install of the 5.2 fresh izip file on moOde web site.  Went this route as my NAS would not play nice with 5.0 or 5.1 ( mpdignore I/O error ) the AP worked just fine in 5.0 or  5.1. 

Thanks
Reply
#6
It appears to be a regression but not in the kernel. It looks like the install package for hostapd has changed because after building the new 5.2 image the hostapd service file is marked "masked". I've always seen to marked as "enabled". The moOde build sets it to "disabled" because it only needs to be started manually when AP mode is activated. The masked attribute is a stronger version of disabled and it will prevent the service from being started manually.

So the fix may be like below but this needs to be verified. If confirmed I'll update the builder and add this to an upcoming 5.2 update :-)

Code:
sudo systemctl unmask hostapd

To list the service that are masked
Code:
sudo systemctl list-unit-files | grep masked
Reply
#7
@Tim Curtis

Interesting.

AFAICT, all the systemctl unmask command does is remove the symbolic link


Code:
/etc/systemd/system
...
lrwxrwxrwx 1 root root    9 May  9 19:16 hostapd.service -> /dev/null


As a test, I burned a fresh uSD card from the r52 image, mounted the second partition (rootfs) to my Linux laptop, and deleted this file. Booted the card in an RPi3B+ and the AP came up. I can open the moOde UI and do the usual configuring.

Regards,
Kent
Reply
#8
Is this a success case same as below?

systemctl unmask hostapd
Reply
#9
@Tim Curtis

Sorry for sporatic responses. (We're trying to empty all our kitchen cabinets before the contractor arrives tomorrow morning!)

AFAICT the following two approaches are equivalent

1) fresh r5.2 on uSD card. Plug it into an RPi. Boot without Ethernet. No AP appears. Plug in Ethernet and ssh in. Run

Code:
sudo systemctl unmask hostapd

At this point without thinking I rebooted and unplugged Ethernet while reboot in progress but I believe result would have been same if I had simply unplugged Ethernet---r5.2 came up in AP mode. The symbolic link in /etc/systemd/system is no longer present.

2) fresh r5.2 on uSD card. Mount second partition on some other host (in my case a Linux laptop). Remove the link I pointed out. 

Code:
kreed@T520:/media/kreed/rootfs/etc/systemd/system $ sudo rm hostapd.service


Unmount partition and plug uSD card into an RPi. Boot without Ethernet. AP appears.

Either way, you are correct that the service was masked in the installation process. I don't yet know why.

Regards,
Kent
Reply


Forum Jump: