Thank you for your donation!


5.2 not working with allo Digione
#1
ok, I resisted posting but I’m having no luck with 5.2.

I did a in place update from 5.1 and the digione stopped outputting a signal.

So I burned a new 5.2 image, still not working. 

Just in case I want back to the 4.4 and Its working no problem.  

I burned a 5.0 and it works also.

Thanks,

Code:
S Y S T E M    P A R A M E T E R S  

Date and time = 2019-05-15 17:19:36
System uptime = up 9 minutes
Timezone = America/Chicago
Release = moOde 5.2 2019-05-07
Update = None

Host name = moode
ETH0  IP = 10.0.0.135
ETH0  MAC = b8:27:eb:ca:32:99
WLAN0 IP = unassigned
WLAN0 MAC = no adapter
WiFi country = US

HDWR REV = Pi-3B 1GB v1.2
SoC = BCM2835
CORES = 4
ARCH = armv7l
RASPBIAN = 9.9
KERNEL = 4.19.40-v7+
KTIMER FREQ = 100 Hz
USB BOOT = not enabled
Warranty = OK

ROOT size = 2.9G
ROOT used = 78%
ROOT avail = 629M
FS expand = not expanded
MEM free = 696 MB
MEM used = 62 MB
Temperature = 45.1°C

CPU GOV = performance
P3-WIFI = Off
P3-BT = Off
HDMI = Off
ETH0 CHECK = On
MAX USB CUR = Off
UAC2 FIX = Off
ETHPORT FIX = Off
SSH server = Off

LED0 = on
LED1 = on
SD CARD = 50 MHz

C O R E    S E R V I C E S  

PHP-FPM = 7.0.33
NGINX = 1.10.3
SQLite = 3.16.2
HOSTAPD = 2.6
WIRINGPI = 2.50

A P P E A R A N C E   S E T T I N G S  

Theme = Default
Accent color = Emerald
Alpha blend = 1.0
Adaptive background = No
Background image = No
Cover backdrop = No
Cover blur = 20px
Cover scale = 1.25
CoverView auto-display = Never
CoverView style = Animated
Auto-shuffle filter = None
Extra metadata = Yes
Playback history = No

L I B R A R Y   S E T T I N G S  

Artist list order = Artist
Ignore articles = a,an,the
Compilation rollup = No
Compilation excludes = greatest hits
UTF8 character filter = No
Cover search pri = Embedded cover
Hi-res covers = Auto
Pixel ratio = 2

A U D I O    P A R A M E T E R S  

Audio device = On-board audio device
Interface = I2S
Hardware volume = None
Mixer name = Digital
Audio source = Local
Output device = Local
Resume MPD aft src chg = No
Volume knob = 0
Volume mute = Unmuted
ALSA version = 1.1.3-5+rpt4
SoX version = 0.1.2-2

Bluetooth controller = Off
Bluetooth pairing agent = Off
Airplay receiver = Off
Spotify receiver = Off
Squeezelite = Off
UPnP client = On
DLNA server = Off
GPIO button handler = Off

Rotary encoder = Off
Encoder params = 100 2 3 4 5
Crossfeed = Off
Parametric EQ = Off
Graphic EQ = Off
Polarity inversion = Off
Auto-shuffle = Off
Autoplay = Off
MPD crossfade = Off
MPD httpd = Off

M P D    S E T T I N G S  

Version = 0.20.23
Volume control = software
ALSA device = hw:0
SoX resampling = disabled
SoX quality = very high
SoX multithreading = off
DSD over PCM (DoP) = no
Replaygain = off
Replaygain preamp = 0
Volume normalization = No
Audio buffer (kb) = 4096
Output buffer size (kb) = 131072
ALSA auto-resample = yes
ALSA auto-channels = yes
ALSA auto-format = yes
Hardware buffer time = 500000
Hardware period time = 256000000

B L U E T O O T H    S E T T I N G S  

Bluetooth ver = 5.50
Bluealsa ver = 1.3.1
Speaker sharing = No
Resume MPD = No

A I R P L A Y    S E T T I N G S  

Version = 3.3rc6
Friendly name = Moode Airplay
ALSA device = hw:0
Interpolation = soxr
Output bit depth = S16
Output sample rate = 44100
Session interruption = no
Session timeout (ms) = 120
Audio buffer (secs) = 0.0
Resume MPD = No

S P O T I F Y    S E T T I N G S  

Friendly name = Moode Spotify
ALSA device = plughw:0
Bit rate = 160
Initial volume = 0
Volume curve = Logarithmic
Volume normalization = No
Normalization pregain = 0
Resume MPD = No

S Q U E E Z E L I T E    S E T T I N G S  

Version = 1.8.7-1052 "DSD/SRC enabled"
Friendly name = Moode
ALSA device = hw:0
ALSA params = 80:4::1
Output buffers = 40000:100000
Task priority = 45
Codec list = flac,pcm,mp3,ogg,aac,alac,dsd
Other options = -W -D 500 -R E -S /var/loca
Resume MPD = No

M O O D E    L O G  

  20190515 171040 worker: - Start
  20190515 171040 worker: Successfully daemonized
  20190515 171040 worker: Integrity check (passed)
  20190515 171041 worker: ALSA volume (None)
  20190515 171041 worker: Session loaded
  20190515 171041 worker: Debug logging (off)
  20190515 171041 worker: - Platform
  20190515 171042 worker: Rel  (Moode 5.2 2019-05-07)
  20190515 171042 worker: Upd  (None)
  20190515 171042 worker: Rasp (9.9)
  20190515 171042 worker: Kern (4.19.40-v7+)
  20190515 171042 worker: MPD  (0.20.23)
  20190515 171042 worker: Host (moode)
  20190515 171042 worker: Hdwr (Pi-3B 1GB v1.2)
  20190515 171042 worker: Arch (armv7l)
  20190515 171042 worker: Gov  (performance)
  20190515 171042 worker: USB boot not enabled yet
  20190515 171042 worker: File system not expanded yet
  20190515 171042 worker: HDMI port off
  20190515 171043 worker: File check ok
  20190515 171043 worker: - Network
  20190515 171043 worker: eth0 exists
  20190515 171043 worker: eth0 (10.0.0.135)
  20190515 171043 worker: wlan0 does not exist
  20190515 171043 worker: - Audio
  20190515 171043 worker: ALSA outputs unmuted
  20190515 171043 worker: ALSA card number (0)
  20190515 171043 worker: Audio output (I2S audio device)
  20190515 171043 worker: Audio device (Allo DigiOne)
  20190515 171043 worker: ALSA mixer name (Digital)
  20190515 171043 worker: MPD volume control (software)
  20190515 171043 worker: Hdwr volume controller not detected
  20190515 171043 worker: - Services
  20190515 171043 worker: Reset renderer active state
  20190515 171043 worker: MPD conf updated
  20190515 171043 worker: MPD started
  20190515 171044 worker: MPD accepting connections
  20190515 171044 worker: Configure MPD outputs
  20190515 171044 worker: MPD output 1 ALSA default (on)
  20190515 171044 worker: MPD output 2 ALSA crossfeed (off)
  20190515 171044 worker: MPD output 3 ALSA parametric eq (off)
  20190515 171044 worker: MPD output 4 ALSA graphic eq (off)
  20190515 171044 worker: MPD output 5 ALSA polarity inversion (off)
  20190515 171044 worker: MPD output 6 ALSA bluetooth (off)
  20190515 171044 worker: MPD output 7 HTTP stream (off)
  20190515 171044 worker: MPD crossfade (off)
  20190515 171044 worker: Audio source (Local)
  20190515 171044 worker: Output device (Local)
  20190515 171044 worker: UPnP renderer started
  20190515 171044 worker: - Music sources
  20190515 171044 worker: USB sources (none attached)
  20190515 171044 worker: NAS sources (none configured)
  20190515 171044 worker: - Miscellaneous
  20190515 171044 worker: MPD volume level (0) restored
  20190515 171044 worker: ALSA volume level (None)
  20190515 171044 worker: Auto-play is off
  20190515 171044 worker: Maintenance interval (21600)
  20190515 171044 worker: Screen saver activation (Never)
  20190515 171044 worker: Watchdog started
  20190515 171044 worker: Ready
  20190515 171132 worker: Job i2sdevice
  20190515 171159 worker: Job mpdcfg
  20190515 171303 worker: Job i2sdevice
Reply
#2
from the output above.

You have volume as software and set to 0  ?
Audio device is set to onboard-audio ?
Reply
#3
(05-15-2019, 10:22 PM)Botte Wrote: ok, I resisted posting but I’m having no luck with 5.2.

I did a in place update from 5.1 and the digione stopped outputting a signal.

So I burned a new 5.2 image, still not working. 

Just in case I want back to the 4.4 and Its working no problem.  

I burned a 5.0 and it works also.

Thanks,

Code:
S Y S T E M    P A R A M E T E R S  

Date and time = 2019-05-15 17:19:36
System uptime = up 9 minutes
Timezone = America/Chicago
Release = moOde 5.2 2019-05-07
Update = None

Host name = moode
ETH0  IP = 10.0.0.135
ETH0  MAC = b8:27:eb:ca:32:99
WLAN0 IP = unassigned
WLAN0 MAC = no adapter
WiFi country = US

HDWR REV = Pi-3B 1GB v1.2
SoC = BCM2835
CORES = 4
ARCH = armv7l
RASPBIAN = 9.9
KERNEL = 4.19.40-v7+
KTIMER FREQ = 100 Hz
USB BOOT = not enabled
Warranty = OK

ROOT size = 2.9G
ROOT used = 78%
ROOT avail = 629M
FS expand = not expanded
MEM free = 696 MB
MEM used = 62 MB
Temperature = 45.1°C

CPU GOV = performance
P3-WIFI = Off
P3-BT = Off
HDMI = Off
ETH0 CHECK = On
MAX USB CUR = Off
UAC2 FIX = Off
ETHPORT FIX = Off
SSH server = Off

LED0 = on
LED1 = on
SD CARD = 50 MHz

C O R E    S E R V I C E S  

PHP-FPM = 7.0.33
NGINX = 1.10.3
SQLite = 3.16.2
HOSTAPD = 2.6
WIRINGPI = 2.50

A P P E A R A N C E   S E T T I N G S  

Theme = Default
Accent color = Emerald
Alpha blend = 1.0
Adaptive background = No
Background image = No
Cover backdrop = No
Cover blur = 20px
Cover scale = 1.25
CoverView auto-display = Never
CoverView style = Animated
Auto-shuffle filter = None
Extra metadata = Yes
Playback history = No

L I B R A R Y   S E T T I N G S  

Artist list order = Artist
Ignore articles = a,an,the
Compilation rollup = No
Compilation excludes = greatest hits
UTF8 character filter = No
Cover search pri = Embedded cover
Hi-res covers = Auto
Pixel ratio = 2

A U D I O    P A R A M E T E R S  

Audio device = On-board audio device
Interface = I2S
Hardware volume = None
Mixer name = Digital
Audio source = Local
Output device = Local
Resume MPD aft src chg = No
Volume knob = 0
Volume mute = Unmuted
ALSA version = 1.1.3-5+rpt4
SoX version = 0.1.2-2

Bluetooth controller = Off
Bluetooth pairing agent = Off
Airplay receiver = Off
Spotify receiver = Off
Squeezelite = Off
UPnP client = On
DLNA server = Off
GPIO button handler = Off

Rotary encoder = Off
Encoder params = 100 2 3 4 5
Crossfeed = Off
Parametric EQ = Off
Graphic EQ = Off
Polarity inversion = Off
Auto-shuffle = Off
Autoplay = Off
MPD crossfade = Off
MPD httpd = Off

M P D    S E T T I N G S  

Version = 0.20.23
Volume control = software
ALSA device = hw:0
SoX resampling = disabled
SoX quality = very high
SoX multithreading = off
DSD over PCM (DoP) = no
Replaygain = off
Replaygain preamp = 0
Volume normalization = No
Audio buffer (kb) = 4096
Output buffer size (kb) = 131072
ALSA auto-resample = yes
ALSA auto-channels = yes
ALSA auto-format = yes
Hardware buffer time = 500000
Hardware period time = 256000000

B L U E T O O T H    S E T T I N G S  

Bluetooth ver = 5.50
Bluealsa ver = 1.3.1
Speaker sharing = No
Resume MPD = No

A I R P L A Y    S E T T I N G S  

Version = 3.3rc6
Friendly name = Moode Airplay
ALSA device = hw:0
Interpolation = soxr
Output bit depth = S16
Output sample rate = 44100
Session interruption = no
Session timeout (ms) = 120
Audio buffer (secs) = 0.0
Resume MPD = No

S P O T I F Y    S E T T I N G S  

Friendly name = Moode Spotify
ALSA device = plughw:0
Bit rate = 160
Initial volume = 0
Volume curve = Logarithmic
Volume normalization = No
Normalization pregain = 0
Resume MPD = No

S Q U E E Z E L I T E    S E T T I N G S  

Version = 1.8.7-1052 "DSD/SRC enabled"
Friendly name = Moode
ALSA device = hw:0
ALSA params = 80:4::1
Output buffers = 40000:100000
Task priority = 45
Codec list = flac,pcm,mp3,ogg,aac,alac,dsd
Other options = -W -D 500 -R E -S /var/loca
Resume MPD = No

M O O D E    L O G  

  20190515 171040 worker: - Start
  20190515 171040 worker: Successfully daemonized
  20190515 171040 worker: Integrity check (passed)
  20190515 171041 worker: ALSA volume (None)
  20190515 171041 worker: Session loaded
  20190515 171041 worker: Debug logging (off)
  20190515 171041 worker: - Platform
  20190515 171042 worker: Rel  (Moode 5.2 2019-05-07)
  20190515 171042 worker: Upd  (None)
  20190515 171042 worker: Rasp (9.9)
  20190515 171042 worker: Kern (4.19.40-v7+)
  20190515 171042 worker: MPD  (0.20.23)
  20190515 171042 worker: Host (moode)
  20190515 171042 worker: Hdwr (Pi-3B 1GB v1.2)
  20190515 171042 worker: Arch (armv7l)
  20190515 171042 worker: Gov  (performance)
  20190515 171042 worker: USB boot not enabled yet
  20190515 171042 worker: File system not expanded yet
  20190515 171042 worker: HDMI port off
  20190515 171043 worker: File check ok
  20190515 171043 worker: - Network
  20190515 171043 worker: eth0 exists
  20190515 171043 worker: eth0 (10.0.0.135)
  20190515 171043 worker: wlan0 does not exist
  20190515 171043 worker: - Audio
  20190515 171043 worker: ALSA outputs unmuted
  20190515 171043 worker: ALSA card number (0)
  20190515 171043 worker: Audio output (I2S audio device)
  20190515 171043 worker: Audio device (Allo DigiOne)
  20190515 171043 worker: ALSA mixer name (Digital)
  20190515 171043 worker: MPD volume control (software)
  20190515 171043 worker: Hdwr volume controller not detected
  20190515 171043 worker: - Services
  20190515 171043 worker: Reset renderer active state
  20190515 171043 worker: MPD conf updated
  20190515 171043 worker: MPD started
  20190515 171044 worker: MPD accepting connections
  20190515 171044 worker: Configure MPD outputs
  20190515 171044 worker: MPD output 1 ALSA default (on)
  20190515 171044 worker: MPD output 2 ALSA crossfeed (off)
  20190515 171044 worker: MPD output 3 ALSA parametric eq (off)
  20190515 171044 worker: MPD output 4 ALSA graphic eq (off)
  20190515 171044 worker: MPD output 5 ALSA polarity inversion (off)
  20190515 171044 worker: MPD output 6 ALSA bluetooth (off)
  20190515 171044 worker: MPD output 7 HTTP stream (off)
  20190515 171044 worker: MPD crossfade (off)
  20190515 171044 worker: Audio source (Local)
  20190515 171044 worker: Output device (Local)
  20190515 171044 worker: UPnP renderer started
  20190515 171044 worker: - Music sources
  20190515 171044 worker: USB sources (none attached)
  20190515 171044 worker: NAS sources (none configured)
  20190515 171044 worker: - Miscellaneous
  20190515 171044 worker: MPD volume level (0) restored
  20190515 171044 worker: ALSA volume level (None)
  20190515 171044 worker: Auto-play is off
  20190515 171044 worker: Maintenance interval (21600)
  20190515 171044 worker: Screen saver activation (Never)
  20190515 171044 worker: Watchdog started
  20190515 171044 worker: Ready
  20190515 171132 worker: Job i2sdevice
  20190515 171159 worker: Job mpdcfg
  20190515 171303 worker: Job i2sdevice

Hi,

As @DRONE7 observed there are some inconsistencies in the log as indicated below.

A U D I O    P A R A M E T E R S  

Audio device = On-board audio device
Interface = I2S
Hardware volume = None
Mixer name = Digital

Below is what it should like on a fresh install with no audio device configured.

A U D I O    P A R A M E T E R S  

Audio device = On-board audio device
Interface = SoC
Hardware volume = Controller detected
Mixer name = PCM

I would first verify that you see the above after setting I2S audio device to "None" in Audio Config, then rebooting.

-Tim
Reply
#4
I changed it to none and it looked like you said. Then I changed it back to didione and no go.

I do se other things not correct. This is strange I have not had any issues with 5he other builds.

Code:
 S Y S T E M    P A R A M E T E R S  

    Date and time    = 2019-05-15 20:35:59
    System uptime    = up 3 minutes
    Timezone    = America/Chicago
    Release        = moOde 5.2 2019-05-07
    Update        = None    

    Host name    = moode
    ETH0  IP    = 10.0.0.135
    ETH0  MAC    = b8:27:eb:ca:32:99
    WLAN0 IP    = unassigned
    WLAN0 MAC    = no adapter
    WiFi country    = US

    HDWR REV    = Pi-3B 1GB v1.2
    SoC         = BCM2835
    CORES        = 4
    ARCH        = armv7l
    RASPBIAN    = 9.9
    KERNEL        = 4.19.40-v7+
    KTIMER FREQ    = 100 Hz
    USB BOOT    = not enabled
    Warranty    = OK

    ROOT size    = 2.9G
    ROOT used     = 78%
    ROOT avail    = 628M
    FS expand    = not expanded
    MEM free     = 698 MB
    MEM used     = 61 MB
    Temperature     = 46.2°C

    CPU GOV        = performance
    P3-WIFI        = Off
    P3-BT        = Off
    HDMI        = Off
    ETH0 CHECK    = On
    MAX USB CUR    = Off
    UAC2 FIX    = Off
    ETHPORT FIX    = Off
    SSH server    = Off

    LED0        = on
    LED1        = on
    SD CARD        = 50 MHz

      C O R E    S E R V I C E S  

    PHP-FPM        = 7.0.33
    NGINX        = 1.10.3
    SQLite        = 3.16.2
    HOSTAPD        = 2.6
    WIRINGPI    = 2.50

      A P P E A R A N C E   S E T T I N G S  

    Theme            = Default
    Accent color        = Emerald
    Alpha blend        = 1.0
    Adaptive background    = No
    Background image    = No
    Cover backdrop        = No
    Cover blur        = 20px
    Cover scale        = 1.25
    CoverView auto-display    = Never
    CoverView style        = Animated
    Auto-shuffle filter    = None
    Extra metadata        = Yes
    Playback history    = No

      L I B R A R Y   S E T T I N G S  

    Artist list order    = Artist
    Ignore articles        = a,an,the
    Compilation rollup    = No
    Compilation excludes    = greatest hits
    UTF8 character filter    = No
    Cover search pri    = Embedded cover
    Hi-res covers        = Auto
    Pixel ratio        = 2

      A U D I O    P A R A M E T E R S  

    Audio device        = Allo DigiOne
    Interface        = I2S
    Hardware volume        = None
    Mixer name        = Digital
    Audio source        = Local
    Output device        = Local
    Resume MPD aft src chg    = No
    Volume knob        = 0
    Volume mute        = Unmuted
    ALSA version        = 1.1.3-5+rpt4
    SoX version        = 0.1.2-2

    Bluetooth controller    = Off
    Bluetooth pairing agent    = Off
    Airplay receiver    = Off
    Spotify receiver    = Off
    Squeezelite        = Off
    UPnP client        = On
    DLNA server        = Off
    GPIO button handler    = Off

    Rotary encoder        = Off
    Encoder params        = 100 2 3 4 5
    Crossfeed        = Off
    Parametric EQ        = Off
    Graphic EQ        = Off
    Polarity inversion    = Off
    Auto-shuffle        = Off
    Autoplay        = Off
    MPD crossfade        = Off
    MPD httpd        = Off

      M P D    S E T T I N G S  

    Version            = 0.20.23
    Volume control        = software
    ALSA device        = hw:0
    SoX resampling        = disabled
    SoX quality        = very high
    SoX multithreading    = off
    DSD over PCM (DoP)    = no
    Replaygain        = off
    Replaygain preamp    = 0
    Volume normalization    = No
    Audio buffer (kb)    = 4096
    Output buffer size (kb)    = 131072
    ALSA auto-resample    = yes
    ALSA auto-channels    = yes
    ALSA auto-format    = yes
    Hardware buffer time    = 500000
    Hardware period time    = 256000000

      B L U E T O O T H    S E T T I N G S  

    Bluetooth ver        = 5.50
    Bluealsa ver        = 1.3.1
    Speaker sharing        = No
    Resume MPD        = No

      A I R P L A Y    S E T T I N G S  

    Version            = 3.3rc6
    Friendly name        = Moode Airplay
    ALSA device        = hw:0
    Interpolation        = soxr
    Output bit depth    = S16
    Output sample rate    = 44100
    Session interruption    = no
    Session timeout (ms)    = 120
    Audio buffer (secs)    = 0.0
    Resume MPD        = No

      S P O T I F Y    S E T T I N G S  

    Friendly name        = Moode Spotify
    ALSA device        = plughw:0
    Bit rate        = 160
    Initial volume        = 0
    Volume curve        = Logarithmic
    Volume normalization    = No
    Normalization pregain    = 0
    Resume MPD        = No

      S Q U E E Z E L I T E    S E T T I N G S  

    Version            = 1.8.7-1052 "DSD/SRC enabled"
    Friendly name        = Moode
    ALSA device        = hw:0
    ALSA params        = 80:4::1
    Output buffers        = 40000:100000
    Task priority        = 45
    Codec list        = flac,pcm,mp3,ogg,aac,alac,dsd
    Other options        = -W -D 500 -R E -S /var/loca
    Resume MPD        = No

      M O O D E    L O G  

   20190515 203300 worker: - Start
   20190515 203300 worker: Successfully daemonized
   20190515 203300 worker: Integrity check (passed)
   20190515 203300 worker: ALSA volume set to (amixer: Unable to find simple control 'Digital',0)
   20190515 203300 worker: Session loaded
   20190515 203300 worker: Debug logging (off)
   20190515 203300 worker: - Platform
   20190515 203302 worker: Rel  (Moode 5.2 2019-05-07)
   20190515 203302 worker: Upd  (None)
   20190515 203302 worker: Rasp (9.9)
   20190515 203302 worker: Kern (4.19.40-v7+)
   20190515 203302 worker: MPD  (0.20.23)
   20190515 203302 worker: Host (moode)
   20190515 203302 worker: Hdwr (Pi-3B 1GB v1.2)
   20190515 203302 worker: Arch (armv7l)
   20190515 203302 worker: Gov  (performance)
   20190515 203302 worker: USB boot not enabled yet
   20190515 203302 worker: File system not expanded yet
   20190515 203302 worker: HDMI port off
   20190515 203302 worker: File check ok
   20190515 203302 worker: - Network
   20190515 203302 worker: eth0 exists
   20190515 203302 worker: eth0 (10.0.0.135)
   20190515 203302 worker: wlan0 does not exist
   20190515 203302 worker: - Audio
   20190515 203302 worker: ALSA outputs unmuted
   20190515 203302 worker: ALSA card number (0)
   20190515 203302 worker: Audio output (I2S audio device)
   20190515 203302 worker: Audio device (Allo DigiOne)
   20190515 203302 worker: ALSA mixer name (Digital)
   20190515 203302 worker: MPD volume control (software)
   20190515 203302 worker: Hdwr volume controller not detected
   20190515 203302 worker: - Services
   20190515 203302 worker: Reset renderer active state
   20190515 203303 worker: MPD conf updated
   20190515 203303 worker: MPD started
   20190515 203303 worker: MPD accepting connections
   20190515 203303 worker: Configure MPD outputs
   20190515 203303 worker: MPD output 1 ALSA default (on)
   20190515 203303 worker: MPD output 2 ALSA crossfeed (off)
   20190515 203303 worker: MPD output 3 ALSA parametric eq (off)
   20190515 203303 worker: MPD output 4 ALSA graphic eq (off)
   20190515 203303 worker: MPD output 5 ALSA polarity inversion (off)
   20190515 203303 worker: MPD output 6 ALSA bluetooth (off)
   20190515 203303 worker: MPD output 7 HTTP stream (off)
   20190515 203303 worker: MPD crossfade (off)
   20190515 203303 worker: Audio source (Local)
   20190515 203303 worker: Output device (Local)
   20190515 203303 worker: UPnP renderer started
   20190515 203303 worker: - Music sources
   20190515 203303 worker: USB sources (none attached)
   20190515 203303 worker: NAS sources (none configured)
   20190515 203303 worker: - Miscellaneous
   20190515 203304 worker: MPD volume level (0) restored
   20190515 203304 worker: ALSA volume level (None)
   20190515 203304 worker: Auto-play is off
   20190515 203304 worker: Maintenance interval (21600)
   20190515 203304 worker: Screen saver activation (Never)
   20190515 203304 worker: Watchdog started
   20190515 203304 worker: Ready
   20190515 203510 worker: Job mpdcfg
Reply
#5
This time the audio device is shown as Allo Digione...that's better.
Volume is still software and set at 0.... What happens when you try increasing the volume ?

Otherwise try to set the volume as 'disabled' rather than 'software' and use your amps volume control.
Reply
#6
So the other strange behavior is that the track try’s to play for about 4 seconds then restarts. No sound.
Reply
#7
(05-16-2019, 01:41 AM)Botte Wrote: I changed it to none and it looked like you said. Then I changed it back to didione and no go.

I do se other things not correct. This is strange I have not had any issues with 5he other builds.

Code:
 S Y S T E M    P A R A M E T E R S  

    Date and time    = 2019-05-15 20:35:59
    System uptime    = up 3 minutes
    Timezone    = America/Chicago
    Release        = moOde 5.2 2019-05-07
    Update        = None    

    Host name    = moode
    ETH0  IP    = 10.0.0.135
    ETH0  MAC    = b8:27:eb:ca:32:99
    WLAN0 IP    = unassigned
    WLAN0 MAC    = no adapter
    WiFi country    = US

    HDWR REV    = Pi-3B 1GB v1.2
    SoC         = BCM2835
    CORES        = 4
    ARCH        = armv7l
    RASPBIAN    = 9.9
    KERNEL        = 4.19.40-v7+
    KTIMER FREQ    = 100 Hz
    USB BOOT    = not enabled
    Warranty    = OK

    ROOT size    = 2.9G
    ROOT used     = 78%
    ROOT avail    = 628M
    FS expand    = not expanded
    MEM free     = 698 MB
    MEM used     = 61 MB
    Temperature     = 46.2°C

    CPU GOV        = performance
    P3-WIFI        = Off
    P3-BT        = Off
    HDMI        = Off
    ETH0 CHECK    = On
    MAX USB CUR    = Off
    UAC2 FIX    = Off
    ETHPORT FIX    = Off
    SSH server    = Off

    LED0        = on
    LED1        = on
    SD CARD        = 50 MHz

      C O R E    S E R V I C E S  

    PHP-FPM        = 7.0.33
    NGINX        = 1.10.3
    SQLite        = 3.16.2
    HOSTAPD        = 2.6
    WIRINGPI    = 2.50

      A P P E A R A N C E   S E T T I N G S  

    Theme            = Default
    Accent color        = Emerald
    Alpha blend        = 1.0
    Adaptive background    = No
    Background image    = No
    Cover backdrop        = No
    Cover blur        = 20px
    Cover scale        = 1.25
    CoverView auto-display    = Never
    CoverView style        = Animated
    Auto-shuffle filter    = None
    Extra metadata        = Yes
    Playback history    = No

      L I B R A R Y   S E T T I N G S  

    Artist list order    = Artist
    Ignore articles        = a,an,the
    Compilation rollup    = No
    Compilation excludes    = greatest hits
    UTF8 character filter    = No
    Cover search pri    = Embedded cover
    Hi-res covers        = Auto
    Pixel ratio        = 2

      A U D I O    P A R A M E T E R S  

    Audio device        = Allo DigiOne
    Interface        = I2S
    Hardware volume        = None
    Mixer name        = Digital
    Audio source        = Local
    Output device        = Local
    Resume MPD aft src chg    = No
    Volume knob        = 0
    Volume mute        = Unmuted
    ALSA version        = 1.1.3-5+rpt4
    SoX version        = 0.1.2-2

    Bluetooth controller    = Off
    Bluetooth pairing agent    = Off
    Airplay receiver    = Off
    Spotify receiver    = Off
    Squeezelite        = Off
    UPnP client        = On
    DLNA server        = Off
    GPIO button handler    = Off

    Rotary encoder        = Off
    Encoder params        = 100 2 3 4 5
    Crossfeed        = Off
    Parametric EQ        = Off
    Graphic EQ        = Off
    Polarity inversion    = Off
    Auto-shuffle        = Off
    Autoplay        = Off
    MPD crossfade        = Off
    MPD httpd        = Off

      M P D    S E T T I N G S  

    Version            = 0.20.23
    Volume control        = software
    ALSA device        = hw:0
    SoX resampling        = disabled
    SoX quality        = very high
    SoX multithreading    = off
    DSD over PCM (DoP)    = no
    Replaygain        = off
    Replaygain preamp    = 0
    Volume normalization    = No
    Audio buffer (kb)    = 4096
    Output buffer size (kb)    = 131072
    ALSA auto-resample    = yes
    ALSA auto-channels    = yes
    ALSA auto-format    = yes
    Hardware buffer time    = 500000
    Hardware period time    = 256000000

      B L U E T O O T H    S E T T I N G S  

    Bluetooth ver        = 5.50
    Bluealsa ver        = 1.3.1
    Speaker sharing        = No
    Resume MPD        = No

      A I R P L A Y    S E T T I N G S  

    Version            = 3.3rc6
    Friendly name        = Moode Airplay
    ALSA device        = hw:0
    Interpolation        = soxr
    Output bit depth    = S16
    Output sample rate    = 44100
    Session interruption    = no
    Session timeout (ms)    = 120
    Audio buffer (secs)    = 0.0
    Resume MPD        = No

      S P O T I F Y    S E T T I N G S  

    Friendly name        = Moode Spotify
    ALSA device        = plughw:0
    Bit rate        = 160
    Initial volume        = 0
    Volume curve        = Logarithmic
    Volume normalization    = No
    Normalization pregain    = 0
    Resume MPD        = No

      S Q U E E Z E L I T E    S E T T I N G S  

    Version            = 1.8.7-1052 "DSD/SRC enabled"
    Friendly name        = Moode
    ALSA device        = hw:0
    ALSA params        = 80:4::1
    Output buffers        = 40000:100000
    Task priority        = 45
    Codec list        = flac,pcm,mp3,ogg,aac,alac,dsd
    Other options        = -W -D 500 -R E -S /var/loca
    Resume MPD        = No

      M O O D E    L O G  

   20190515 203300 worker: - Start
   20190515 203300 worker: Successfully daemonized
   20190515 203300 worker: Integrity check (passed)
   20190515 203300 worker: ALSA volume set to (amixer: Unable to find simple control 'Digital',0)
   20190515 203300 worker: Session loaded
   20190515 203300 worker: Debug logging (off)
   20190515 203300 worker: - Platform
   20190515 203302 worker: Rel  (Moode 5.2 2019-05-07)
   20190515 203302 worker: Upd  (None)
   20190515 203302 worker: Rasp (9.9)
   20190515 203302 worker: Kern (4.19.40-v7+)
   20190515 203302 worker: MPD  (0.20.23)
   20190515 203302 worker: Host (moode)
   20190515 203302 worker: Hdwr (Pi-3B 1GB v1.2)
   20190515 203302 worker: Arch (armv7l)
   20190515 203302 worker: Gov  (performance)
   20190515 203302 worker: USB boot not enabled yet
   20190515 203302 worker: File system not expanded yet
   20190515 203302 worker: HDMI port off
   20190515 203302 worker: File check ok
   20190515 203302 worker: - Network
   20190515 203302 worker: eth0 exists
   20190515 203302 worker: eth0 (10.0.0.135)
   20190515 203302 worker: wlan0 does not exist
   20190515 203302 worker: - Audio
   20190515 203302 worker: ALSA outputs unmuted
   20190515 203302 worker: ALSA card number (0)
   20190515 203302 worker: Audio output (I2S audio device)
   20190515 203302 worker: Audio device (Allo DigiOne)
   20190515 203302 worker: ALSA mixer name (Digital)
   20190515 203302 worker: MPD volume control (software)
   20190515 203302 worker: Hdwr volume controller not detected
   20190515 203302 worker: - Services
   20190515 203302 worker: Reset renderer active state
   20190515 203303 worker: MPD conf updated
   20190515 203303 worker: MPD started
   20190515 203303 worker: MPD accepting connections
   20190515 203303 worker: Configure MPD outputs
   20190515 203303 worker: MPD output 1 ALSA default (on)
   20190515 203303 worker: MPD output 2 ALSA crossfeed (off)
   20190515 203303 worker: MPD output 3 ALSA parametric eq (off)
   20190515 203303 worker: MPD output 4 ALSA graphic eq (off)
   20190515 203303 worker: MPD output 5 ALSA polarity inversion (off)
   20190515 203303 worker: MPD output 6 ALSA bluetooth (off)
   20190515 203303 worker: MPD output 7 HTTP stream (off)
   20190515 203303 worker: MPD crossfade (off)
   20190515 203303 worker: Audio source (Local)
   20190515 203303 worker: Output device (Local)
   20190515 203303 worker: UPnP renderer started
   20190515 203303 worker: - Music sources
   20190515 203303 worker: USB sources (none attached)
   20190515 203303 worker: NAS sources (none configured)
   20190515 203303 worker: - Miscellaneous
   20190515 203304 worker: MPD volume level (0) restored
   20190515 203304 worker: ALSA volume level (None)
   20190515 203304 worker: Auto-play is off
   20190515 203304 worker: Maintenance interval (21600)
   20190515 203304 worker: Screen saver activation (Never)
   20190515 203304 worker: Watchdog started
   20190515 203304 worker: Ready
   20190515 203510 worker: Job mpdcfg

Definitely some errors in the log. I don't have one of these devices so I'm not able to attempt a repro. Maybe another user that owns a DigiOne can help out :-)

   20190515 203300 worker: ALSA volume set to (amixer: Unable to find simple control 'Digital',0)
Reply
#8
I put a thumb drive in with some flac tracks and it plays fine. So I guess it’s a UPnP issue not a digione.

Hope this helps, 

Thanks
Reply
#9
I have the Digi One and works mostly fine with Moode. Even UPnp from mConnect in iOS works fine. I cannot play UPnP from audirvana, no matter how much I try.

A 5.2 RPi without the Digi One plays perfectly with Audirvana and UPnP.

Maybe there is an issue in the combo? Who to 'blame' or ask to resolve the thing? All will just wash their hands claiming it's the others fault.

Rafa.
Reply
#10
Rolled back to 4.19.34 kernel and all is working. Not a digione issue.
Reply


Forum Jump: