Thank you for your donation!


Problem: mode 5.2 Wifi not working with RPI 2 and Hifiberry Dac+ Pro
#1
I updated my audio setup (RPI2 + Edimax wifi usb dongle + Hifiberry Dac+ Pro) from Moode 4.4 to 5.2.

After this operation wifi is not working. 
AP mode shows Moode network but there is no possibility to connect. DHCP assign address from 169.254.x.x network

There is also no possibility to connect to my network (in version 4.4 there was no issue). In this case IP is also assigned from 169.254.x.x network.

But when I turn off Hifiberry Dac+ Pro (by removing line in Config.txt: dtoverlay=hifiberry-dacplus). Moode can connect to wifi, but AP mode still not works correctly (can't connect to Moode network from any device). 

It looks like variation of this known issue: https://github.com/raspberrypi/linux/issues/1588 

Finally I returned to Moode 4.4. 
Probably Moode 5.2 version has new version of WLAN driver or other library which provides such changes.

I understand that my issue might not be very popular and not easy to debug, but maybe someone has any idea what may I try to do. 
I spent few hours for finding solution in google but still without success.  Huh
Reply
#2
Hi,

I have a DAC+Pro, Pi-2B and an EdiMax 7811UN adapter. I'll see if I can repro and then report back.
Reply
#3
Recall

http://moodeaudio.org/forum/showthread.p...6#pid10096

The Edimax WiFi adapter wasn't working in AP mode for several of us.
I have a HFB DAC+ Pro but not in a position at the moment to recreate @mister221's system.

Regards,
Kent
Reply
#4
I ran a quick test yesterday with 5.2 image and this was the result

- Pi-2B and EdiMax 7811UN = FAIL
- Pi-3B and on-board adapter = SUCCESS

My time is limited for next couple of days but i also noticed that hostapd on the 5.2 image is version 2.6 and it should be version 2.7 which is on the 5.0 image. This appears to be a minor regression in the build. Both 2.6 and 2.7 yield same result on 5.2 image. I haven't yet tested 5.0 + 2B + EdiMax.
Reply
#5
I am in your situation--I use a RPI2 with a Hifiberry DAC+ Pro.  I don't use an Edimax adapter but this problem seems like it may not be caused by the Edimax adapter.  So I will hold off on upgrading to 5.2 until I see that this problem is fixed.
Reply
#6
Which adapter do u use?

The problem appears to be due to a regression in 4.19.y kernels. I was able to repro the issue with 4.19.34 and 4.19.40  kernels and Edimax EW-7811Un. If I revert to 4.14.98 then no issues.

Here is 4.14.98 (NOTE: this kernel does not contain the Audiophonics i-sabre driver)

Code:
echo "y" | sudo PRUNE_MODULES=1 rpi-update a08ece3d48c3c40bf1b501772af9933249c11c5b

# cleanup
sudo rm -rf /lib/modules.bak
sudo rm -rf /boot.bak
sudo apt-get clean

sudo reboot

And here are the two 4.19.y kernels

Code:
# kernel ver 4.19.40
echo "y" | sudo PRUNE_MODULES=1 rpi-update 6cb1da772a8c56f44591bec904046b15f1126949
# kernel ver 4.19.34
echo "y" | sudo PRUNE_MODULES=1 rpi-update 99c274691c07480762dcda91a0ebfe3c4f519307

# cleanup
sudo rm -rf /lib/modules.bak
sudo rm -rf /boot.bak
sudo apt-get clean

sudo reboot
Reply


Forum Jump: