Thank you for your donation!


Problem: no sound at next morning streaming radio
#1
Hi,

first to say its  is a great new forum here!!!

I am still running 4.0 2018-01-26 because I am traveling a lot at he moment...
My wife is using Moode to stream our favorite radio station to an AV receiver...
Moode stays powerd on 24h but at night the IP address of our WAN is changing (reconnect du to German providers)
AV receiver is switched off over night

Now every morning she has to stop and start Moode Playlist (radio station) again.. I assume this ist because IP is canging and reconnect over night...?

I do not assume it is related to the link between Moode and AV receiver... (because switching AV off and on works fine)

Is ther any way to automate the "pause" and play " of Moode?

Any other things I can check?

  • Architecture: ARMv7l
  • Hdwr revision: Pi-3B 1GB v1.2
  • MPD version: 0.20.1
  • HifiBerry Digi+
  • Uwe
Reply
#2
One way to troubleshoot is to examine the MPD log right after the failed Play. This should show error messages that indicate whether MPD is not able to open the radio station URL or is not able to open the audio output.

cat /var/log/mpd/log

-Tim
Reply
#3
The log is full with only one message:
May 02 18:03 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun
May 02 18:04 : player: Decoder is too slow; playing silence to avoid xrun

after checking with google for me it looks like the stream is broken?  is there an easy way to restart playing every morning at 7:00?  I supose that would help

Setting up cron with service restart? or any better idea?

Uwe

PS
I tried to add etc/cron.d/mood
# Moode: Restart every morning

45 18   * * *   root    PATH="$PATH:/usr/local/bin/" systemctl restart mpd


and rebooted, but it did not work, sorry I am not a linux geek - any suggestion what to change?
It would als be perfect to trigger mpd to switch the playlist to a default (radio), but this is not a must have..
Reply
#4
no one with a hint for me?
Reply
#5
(05-11-2018, 08:20 AM)Boardman Wrote: no one with a hint for me?

Are you using the clock radio option ??
MoOde>Configure>CLK
Reply
#6
argh...  i missed that option - I will gibe it a try - sometimes the sollution is to easy (-: Thank you!
Reply
#7
Hm, no Idear what is going wron, using CLK it worked one time, but yesterday and today it did not...
is ther one specific situation where mpd is switching to silence... ?

what does the error mean?
May 20 09:38 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:38 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:38 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:40 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:40 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:40 : player: played "http://hr-hr3-live.cast.addradio.de/hr/hr3/live/mp3/128/stream.mp3"
Reply
#8
(05-20-2018, 07:45 AM)Boardman Wrote: Hm, no Idear what is going wron, using CLK it worked one time, but yesterday and today it did not...
is ther one specific situation where mpd is switching to silence... ?

what does the error mean?
May 20 09:38 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:38 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:38 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:39 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:40 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:40 : player: Decoder is too slow; playing silence to avoid xrun
May 20 09:40 : player: played "http://hr-hr3-live.cast.addradio.de/hr/hr3/live/mp3/128/stream.mp3"

Hi, Uwe.

This error message can be found in the compiled mpd binary. It's not in the MPD repo master branch. I had to roll back to v0.20.19 (the current release. actually) to find it in src/player/Thread.cxx. It's preceded by the comment

Code:
/* the decoder is too busy and hasn't provided
                          new PCM data in time: send silence (if the
                          output pipe is empty) */

Wasn't that informative Dodgy

What this doesn't tell us is what to do about it.

A commit was made to the MPD repo on January 2 which removed the subject bit of code with the git comment

Code:
The output plugin shall decide whether to insert silence or do nothing
at all.  The ALSA output plugin has already implemented this.
Inserting silence is not necessary or helpful for some plugins, and
may even hurt them (e.g. "recorder").

We can only hope this means that the latest combination of MPD and ALSA falls over in a more sensible way when the triggering condition occurs.

I haven't seen the error in limited testing here. Is the URL at the end of your listing the station which was supposed to start playing when the clock radio setting is met? Does the silence occur with any other URLs?

Regards,
Kent
Reply
#9
Hi Kent,

this error  - until now - never startet when my Receiver is switched on...  I suppose its somehow reladet to that? not to interenet connection...
I will try with a different audio station...
but yesterday I startet around 9PM to watch TV and switched of the receiver and imediadetly after 9 PW the errors in the log startetd... for the whole night... even my Clock Radio at 7 AM did not work :


May 21 06:59 : player: Decoder is too slow; playing silence to avoid xrun
May 21 06:59 : player: Decoder is too slow; playing silence to avoid xrun
May 21 06:59 : player: Decoder is too slow; playing silence to avoid xrun
May 21 06:59 : player: Decoder is too slow; playing silence to avoid xrun
May 21 06:59 : player: Decoder is too slow; playing silence to avoid xrun
May 21 07:00 : exception: Not seekable
May 21 07:00 : player: Decoder is too slow; playing silence to avoid xrun
May 21 07:00 : player: Decoder is too slow; playing silence to avoid xrun
May 21 07:00 : player: Decoder is too slow; playing silence to avoid xrun
May 21 07:00 : player: Decoder is too slow; playing silence to avoid xrun
May 21 07:00 : player: Decoder is too slow; playing silence to avoid xrun
May 21 07:00 : player: Decoder is too slow; playing silence to avoid xrun
May 21 07:00 : player: Decoder is too slow; playing silence to avoid xrun

and the playlist is not shown: empty Moode Screen


Attached Files Thumbnail(s)
   
Reply
#10
and another test:
I have resetted my Inet connection...
Mood is showing reconnect and after a few seconds its in playing status again...

but in the log the error starts:
May 21 07:32 : player: played "http://hr-hr3-live.cast.addradio.de/hr/hr3/live/mp3/128/stream.mp3"
May 21 07:41 : player: Decoder is too slow; playing silence to avoid xrun
May 21 07:41 : player: Decoder is too slow; playing silence to avoid xrun
May 21 07:41 : player: Decoder is too slow; playing silence to avoid xrun
May 21 07:41 : player: Decoder is too slow; playing silence to avoid xrun


Can you help me getting cron working to restart MPD? Maybe thats a workarround or even an idear to search for the reason...


and the same for different radio station like 
KCMP 89.3 FM - The Current

but here the log was cleared and startet directly with teh error message
Reply


Forum Jump: