Thank you for your donation!


Problem: Touchscreen Calibration
#1
Hey guys,

I hope you can help me with my problem. Hardware is Raspberry Pi3B+ with a 5" joy-it touchscreen.

My touchscreen is driving me crazy. I bring the touchscreen function to life adding this to the config.txt:


Code:
hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_cvt 800 480 60 6 0 0 0
dtoverlay=ads7846,cs=1,penirq=25,penirq_pull=2,speed=50000,keep_vref_on=0,swapxy=0,pmax=255,xohms=150,xmin=200,xmax=3900,ymin=200,ymax=3900
hdmi_drive=1
hdmi_force_hotplug=1


After this I create the calibration file:  „/usr/share/X11/xorg.conf.d/99-calibration.conf"

And add the calibration data:

Code:
Section "InputClass"Identifier      "calibration"MatchProduct    "ADS7846 Touchscreen"Option  "Calibration"   "160 3723 3896 181"Option  "SwapAxes"      "0"EndSection


I also add fbcon=map:10 to the cmdline.txt

The touch function works inaccurate and I can't use 1cm of the display in every direction which makes the display useless.

Change the calibration according to xinput calibrator or changing the x,y data is doing nothing it's always the same.

I don't know what to do anymore. With the joy-it manufacturer version of Raspbian Jessie everything works fine.

I hope you can help me.

Greetings from Austria,
                          Paddy
Reply
#2
@Paddy_B

I have nothing to test this with, but I thought the Option "Calibration" parameters were supposed to be in the order "xMin, xMax, yMin, yMax".

Your parameters appear to be in a different order.

Regards,
Kent
Reply
#3
Hi ,

thank you for your answer but this didn't solved my problem.

But i finally found the right thing after hours and if anybody has the same problem I want to share the solution now:

The problem was that the following direction of the xserver was not installed:
Code:
xserver-xorg-input-evdev

Just install and copy this direction:


Code:
sudo apt-get install xserver-xorg-input-evdev
sudo cp -rf /usr/share/X11/xorg.conf.d/10-evdev.conf
/usr/share/X11/xorg.conf.d/45-evdev.conf

After reboot the touchscreen worked correctly.

Thanks again and have a nice time,
            Patrick
Reply
#4
Nice! Thanks for sharing.
Reply


Forum Jump: