Thank you for your donation!


Raspberry Pi 4 support
#1
Please can we have Pi 4 support? I gather that owing to the hardware changes a different version of Raspbian is required for the Pi 4. I haven't upgraded for a while but it seems moode is now available as images rather than the old buildscript. Is the buildscript method still available? Perhaps this would be a way of getting up and running on the Pi 4.
Reply
#2
(06-24-2019, 10:47 AM)aknaggbaugh Wrote: Please can we have Pi 4 support? I gather that owing to the hardware changes a different version of Raspbian is required for the Pi 4. I haven't upgraded for a while but it seems moode is now available as images rather than the old buildscript. Is the buildscript method still available? Perhaps this would be a way of getting up and running on the Pi 4.

Can't do much until Tim and the test team have RPi4s in their hands. (My order may or may not have been in time to reserve one from the next batch Newark/Element14 receive here in the USA.) 

Every time we port to a new version (Raspbian Buster in this case) odd problems arise. As well, significant hardware changes have been made which mean new drivers may be in play.
Reply
#3
@aknaggbaugh yes the automated builder and manual build script are available in Moode Git repo.

Kent, If I have time today I'll put up a test version of the Builder and generate an image using the Buster Lite zip.
http://downloads.raspberrypi.org/raspbia...r-lite.zip

Even w/o a Pi4 we would need to verify that the Buster based image works on existing Pi's etc.
Reply
#4
Agreed. I still have my house guests so will (try to) wait to explore Buster until the RPi4 arrives (ordered mine from Newark).
Reply
#5
Running a Build but it looks like the Buster repos are really busy. No surprise.

Code:
** Update Raspbian package list
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Reading package lists...
** Upgrading Raspbian installed packages to latest available
Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following packages will be upgraded:
 bind9-host libbind9-161 libdns-export1104 libdns1104 libgssapi-krb5-2
 libisc-export1100 libisc1100 libisccc161 libisccfg163 libk5crypto3 libkrb5-3
 libkrb5support0 liblwres161 libwbclient0 nano raspi-config
16 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,156 kB/5,283 kB of archives.
After this operation, 4,096 B of additional disk space will be used.
Err:1 http://mirrors.gigenet.com/raspbian/raspbian buster/main armhf nano armhf 3.2-3
 Cannot initiate the connection to mirrors.gigenet.com:80 (2001:1850:f000:f000:f000:f000::). - connect (101: Network is unreachable) Could not connect to mirrors.gigenet.com:80 (69.65.16.171), connection timed out [IP: 69.65.16.171 80]
Err:2 http://mirrors.gigenet.com/raspbian/raspbian buster/main armhf libgssapi-krb5-2 armhf 1.17-3
 Cannot initiate the connection to mirrors.gigenet.com:80 (2001:1850:f000:f000:f000:f000::). - connect (101: Network is unreachable) [IP: 69.65.16.171 80]
Err:3 http://mirrors.gigenet.com/raspbian/raspbian buster/main armhf libkrb5-3 armhf 1.17-3
 Cannot initiate the connection to mirrors.gigenet.com:80 (2001:1850:f000:f000:f000:f000::). - connect (101: Network is unreachable) [IP: 69.65.16.171 80]
Err:4 http://mirrors.gigenet.com/raspbian/raspbian buster/main armhf libkrb5support0 armhf 1.17-3
 Cannot initiate the connection to mirrors.gigenet.com:80 (2001:1850:f000:f000:f000:f000::). - connect (101: Network is unreachable) [IP: 69.65.16.171 80]
Err:5 http://mirrors.gigenet.com/raspbian/raspbian buster/main armhf libk5crypto3 armhf 1.17-3
 Cannot initiate the connection to mirrors.gigenet.com:80 (2001:1850:f000:f000:f000:f000::). - connect (101: Network is unreachable) [IP: 69.65.16.171 80]
E: Failed to fetch http://mirrors.gigenet.com/raspbian/raspbian/pool/main/n/nano/nano_3.2-3_armhf.deb  Cannot initiate the connection to mirrors.gigenet.com:80 (2001:1850:f000:f000:f000:f000::). - connect (101: Network is unreachable) Could not connect to mirrors.gigenet.com:80 (69.65.16.171), connection timed out [IP: 69.65.16.171 80]
E: Failed to fetch http://mirrors.gigenet.com/raspbian/raspbian/pool/main/k/krb5/libgssapi-krb5-2_1.17-3_armhf.deb  Cannot initiate the connection to mirrors.gigenet.com:80 (2001:1850:f000:f000:f000:f000::). - connect (101: Network is unreachable) [IP: 69.65.16.171 80]
E: Failed to fetch http://mirrors.gigenet.com/raspbian/raspbian/pool/main/k/krb5/libkrb5-3_1.17-3_armhf.deb  Cannot initiate the connection to mirrors.gigenet.com:80 (2001:1850:f000:f000:f000:f000::). - connect (101: Network is unreachable) [IP: 69.65.16.171 80]
E: Failed to fetch http://mirrors.gigenet.com/raspbian/raspbian/pool/main/k/krb5/libkrb5support0_1.17-3_armhf.deb  Cannot initiate the connection to mirrors.gigenet.com:80 (2001:1850:f000:f000:f000:f000::). - connect (101: Network is unreachable) [IP: 69.65.16.171 80]
E: Failed to fetch http://mirrors.gigenet.com/raspbian/raspbian/pool/main/k/krb5/libk5crypto3_1.17-3_armhf.deb  Cannot initiate the connection to mirrors.gigenet.com:80 (2001:1850:f000:f000:f000:f000::). - connect (101: Network is unreachable) [IP: 69.65.16.171 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
** Error: upgrade failed
** Error: image build exited
** Error: reboot to resume the build
pi@moode:~ $

Maybe later today.
Reply
#6
Hi,

Any update on this request?
Vic
RPi B/MoOde 6.2.1/PS Audio DLIII DAC/Naim NAC72 preamp/Avondale TPX PS/Naim NAP140 power amp/Naim SBL speakers = musical bliss!
Audiomaniak
Reply
#7
(09-17-2019, 11:09 PM)flacguy Wrote: Hi,

Any update on this request?

http://moodeaudio.org/forum/showthread.p...7#pid12027
 Angry
Reply
#8
(09-17-2019, 11:27 PM)JST1963 Wrote:
(09-17-2019, 11:09 PM)flacguy Wrote: Hi,

Any update on this request?

http://moodeaudio.org/forum/showthread.p...7#pid12027

Thanks!!! New to the forum and just found out about Pi4 support! Currently using a Pi B with Moode but just ordered one about a minute ago!
Vic
RPi B/MoOde 6.2.1/PS Audio DLIII DAC/Naim NAC72 preamp/Avondale TPX PS/Naim NAP140 power amp/Naim SBL speakers = musical bliss!
Audiomaniak
Reply


Forum Jump: