Thank you for your donation!


Solved: alsa unknown PCM
#1
I have a working librespot/moodeaudio config using --Device <hardware>, however I want to try two zones so I can vary volume from my terminal.

The following ~/.asoundrc allows me to successfully play a wav with "aplay -D quad2 <wav>" to my new PCM "quad2" which duplicates my audio out to 2 USB headphone audio cards:


Code:
pcm.quad {
    type multi
    slaves.a.pcm "hw:0,0"
    slaves.a.channels 2
    slaves.b.pcm "hw:2,0"
    slaves.b.channels 2
    bindings.0.slave a
    bindings.0.channel 0
    bindings.1.slave a
    bindings.1.channel 1
    bindings.2.slave b
    bindings.2.channel 0
    bindings.3.slave b
    bindings.3.channel 1
}

pcm.quad2 {
    type plug
    slave.pcm "quad"
    ttable.0.0 1
    ttable.1.1 1
    ttable.0.2 1
    ttable.1.3 1
}
However when I change my librespot config to --device quad2 (instead of <hardware>), I get the following errors:

Code:
librespot[432]: ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM quad2                                                                          
librespot[432]: [2019-07-06T14:42:24Z ERROR librespot_playback::audio_backend::alsa] Alsa error PCM open ALSA function 'snd_pcm_open' failed with error 'ENOENT: No such file or directory' 
librespot[432]: [2019-07-06T14:42:24Z ERROR librespot_playback::player] Could not start audio: Alsa error: PCM open failed  

Google has decided that I am in the Wild West and am on my own, so I appreciate any feedback and suggestions!
Reply
#2
What version of Raspbian?
Reply
#3
v9 (stretch) on 4.19.42-v7+ and MoOde v5.3.1. Hardware is a Pi 3+
Reply
#4
moOde places its own ALSA virtual device files in the following directory:

Stretch
Code:
/usr/share/alsa/alsa.conf.d

Buster
Code:
/etc/alsa/conf.d

You might want to try migrating from ~/.asoundrc to /usr/share/alsa/alsa.conf.d directory
Reply
#5
Definitely was unaware that MoOde had it's own device files. I've copied ~/.asoundrc to /usr/share/alsa/alsa.conf.d/ and after a reboot, I have the same error.

I've also noticed that the quad2 is not in AlsaMixer with either .asoundrc scenario and am currently trying to see if that's the issue.
Reply
#6
The file extensions are all .conf in this directory.

Code:
pi@rp2:~ $ ls -l /usr/share/alsa/alsa.conf.d
total 32
-rw-r--r-- 1 root root 1089 Mar 12 17:11 20-bluealsa.conf
-rwxr-xr-x 1 root root  299 Jun 23 12:17 20-bluealsa-dmix.conf
-rwxr-xr-x 1 root root  284 Jun 23 12:17 alsaequal.conf
-rwxr-xr-x 1 root root  137 Jun 12 14:48 btstream.conf
-rwxr-xr-x 1 root root  396 Jun 23 12:17 crossfeed.conf
-rwxr-xr-x 1 root root 1310 Jun 23 12:17 eqfa4p.conf
-rwxr-xr-x 1 root root  260 Jun 23 12:17 invpolarity.conf
-rw-r--r-- 1 root root  103 Jun 28  2017 README
pi@rp2:~ $
Reply
#7
Brilliant little README at the bottom. Renaming .asoundrc to asoundrc.conf was the fix.

Every other song is garbled, guessing a bitrate issue. Super happy tho! Thx!
Reply


Forum Jump: