Thank you for your donation!


Any way to speed up the boot process - 5.3
#1
HI All,

Over the various Version 5 versions, I have noticed an incredibly increase in booting up times.

For example, the system starts and boots very quickly to a login prompt, where it waits atleast 30 seconds, then starts up Moode.

As I have the official Raspberry Pi 7" screen attached, the screen does not show anything for over 2 minutes after that time.

However, after the screen blanks (once Moode starts to load after the login prompt), then the Web Interface is available within 5 secs of that which I can start playing songs (just the screen wont show anything for over the 2 minutes).

So firstly, there must be a setting for it not to wait at the login prompt for 30 seconds before launching Moode (I never saw this in V4) and secondly, why so long to display anything on the screen? Watching the processes, it seems that 2 minutes it isnt doing anything, then a chromium process starts and the screen is displayed. Also, while launching Moode, there is no excess memory or cpu usage. They are very low.

I have just upgraded to this version: 5.3.1 2019-06-12 but still the same boot up times.

Any config ideas? I looked into raspi-config, but there was nothing there to configure.

Thanks,
Rob
Pi 4B 2GB, HiFi Berry Digi+, Original 7" Raspberry Pi Screen, Ethernet Connected, Sandisk Ultra10 SD card, 5amp power supply (Drives the PI and Screen separately) streaming audio via NFS shares from QNAP NAS.
Reply
#2
Post a moode startup log and I'll have a look.

Code:
moodeutl -l

-Tim
Reply
#3
Hi,

I'm just thinking if this might be another "missing entropy" related issue, because as far as I know also browsers require a filled entropy pool.
Maybe, you can also post the messages from /var/log/messages for boot time till it's completely started.

Georg
Reply
#4
(07-21-2019, 11:46 AM)ghoeher Wrote: Hi,

I'm just thinking if this might be another "missing entropy" related issue, because as far as I know also browsers require a filled entropy pool.
Maybe, you can also post the messages from /var/log/messages for boot time till it's completely started.

Georg

+1
Reply
#5
Hi,

Thanks for your replies.

Interestingly, I just read about the "entropy" issue, but didn't take much notice. Better read that again.

I've attached a few files as requested (moodeutl -l and /var/log/messages).

Thanks,
Rob


Attached Files
.zip   moodeutl-l.zip (Size: 1.01 KB / Downloads: 2)
.zip   var_log_messages.zip (Size: 6.47 KB / Downloads: 1)
Pi 4B 2GB, HiFi Berry Digi+, Original 7" Raspberry Pi Screen, Ethernet Connected, Sandisk Ultra10 SD card, 5amp power supply (Drives the PI and Screen separately) streaming audio via NFS shares from QNAP NAS.
Reply
#6
Hi,

thanks for providing the logs.
In the Messages, we can see a similar delay than I had in http://moodeaudio.org/forum/showthread.php?tid=1532

---
Jul 21 13:53:57 RPi-Lounge kernel: [    7.334102] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
Jul 22 20:23:31 RPi-Lounge kernel: [  114.392308] random: crng init done
Jul 22 20:23:31 RPi-Lounge kernel: [  114.392318] random: 7 urandom warning(s) missed due to ratelimiting
---

In my case, installing/enabling "haveged" solved the syntomps - maybe this is also a feasible workarond for your issue:


Code:
sudo apt install haveged
sudo systemctl enable haveged



Kind regards
Georg
Reply
#7
Hi Georg,

After posting, I went and found your post and went through it all and saw the same area you had the delay, and saw that in my files (as you have shown)

I did see what you did to fix and I am really wanting to try it too.

I ran this command: cat /proc/sys/kernel/random/entropy_avail

And it came back with 1093 (just over the magical 1000).

@Tim Curtis  - Did you want me to test anything prior to installing haveged?

Thanks,
Rob
Pi 4B 2GB, HiFi Berry Digi+, Original 7" Raspberry Pi Screen, Ethernet Connected, Sandisk Ultra10 SD card, 5amp power supply (Drives the PI and Screen separately) streaming audio via NFS shares from QNAP NAS.
Reply
#8
(07-22-2019, 11:50 AM)rb0135 Wrote: I ran this command: cat /proc/sys/kernel/random/entropy_avail

And it came back with 1093 (just over the magical 1000).

When did you enter the command? Directly after the logon prompt appeared after a reboot or after Chromium came up?

I suggest to reboot and log on by SSH as soon as possible and run the command again.
Reply
#9
Hi All,

@ghoeher  - Correct, I did try after a while, so I restarted and tried the command. It cam back between 2 and 10 until the screen displayed (2 minutes later) and the value started to go up to just over 1000 each time I ran the command.

@Georg - I ran you commands, restarted and indeed fixed the issue. The screen came up within 10 seconds of powering on. I tried the entropy_avail command and it came back with a value over 2000.

Tried restarting a few times, and the screen is always shown within 10-15 secs of startup... Another one fixed.

Thanks,
Rob
Pi 4B 2GB, HiFi Berry Digi+, Original 7" Raspberry Pi Screen, Ethernet Connected, Sandisk Ultra10 SD card, 5amp power supply (Drives the PI and Screen separately) streaming audio via NFS shares from QNAP NAS.
Reply


Forum Jump: