Thank you for your donation!


ERROR: Failed to open "ALSA default"
#1
Ran a library update on 4.1 (rpi3) & later found it crashed. No response from UI, ssh & ping.

Upon reboot the volume knob read 0dB. Playback appears to start but no audio output. Playback panel now doesn't respond as expected.

mpc status gives the following


Quote:ERROR: Failed to open "ALSA default" [alsa]; Failed to open ALSA device "hw:0,0": No such file or directory

Any advice on possible steps to fix?

Edit: The library update appears to have completed.
Reply
#2
I have the same problem. Did you find a solution?
Reply
#3
(10-11-2018, 04:13 AM)Edenmap1 Wrote: I have the same problem. Did you find a solution?

Hmmm yes - I solved the issue. It may have been something to do with my lirc setup (editing /boot/config.txt) or something else perhaps - don't really know.

Read /boot/config.txt to see if your dac driver is correctly set maybe?

Anyway I would try to solve it by setting the dac driver in audio config and rebooting. Then editing the mpd settings as instructed by the info bubble pop-up which appeared when you set your dac driver.
Basically setup your audio hardware again and reboot.
Reply
#4
(05-04-2018, 05:57 PM)FizzyTea Wrote: Ran a library update on 4.1 (rpi3) & later found it crashed. No response from UI, ssh & ping.

Upon reboot the volume knob read 0dB. Playback appears to start but no audio output. Playback panel now doesn't respond as expected.

mpc status gives the following


Quote:ERROR: Failed to open "ALSA default" [alsa]; Failed to open ALSA device "hw:0,0": No such file or directory

Any advice on possible steps to fix?

Edit: The library update appears to have completed.

Just had the same problem on 4.3

an I2S audio device set to none (+reboot), and back to Allo Boos (+reboot) solves the problem.
Reply
#5
(10-11-2018, 11:18 AM)FizzyTea Wrote:
(10-11-2018, 04:13 AM)Edenmap1 Wrote: I have the same problem. Did you find a solution?

Hmmm yes - I solved the issue. It may have been something to do with my lirc setup (editing /boot/config.txt) or something else perhaps - don't really know.

Read /boot/config.txt to see if your dac driver is correctly set maybe?

Anyway I would try to solve it by setting the dac driver in audio config and rebooting. Then editing the mpd settings as instructed by the info bubble pop-up which appeared when you set your dac driver.
Basically setup your audio hardware again and reboot.
[quote pid='4441' dateline='1539256735']
In my case, I finally found that all my SMB links had been broken because of a failure of my internal network during the night. I reconfigured all of the links and after that all was OK. No more errors.

From what I read though, other users may have had other situations where they got that message and your solution would probably solve the problem.
[/quote]
Reply
#6
Just to chime in I had this same issue after rebuilding a NAS with my music. Changing DAC to none -> reboot -> select dac again -> Reboot and everything is fine. I am not a linux guy. Just saying what worked for me, maybe others can benefit.
Reply
#7
(11-06-2019, 12:37 AM)duracell80 Wrote: Just wanna add to the community my discovery for fixing this issue when I found it.

This line was missing from my /boot/config.txt after a Bluetooth connection had dropped. Without that line ALSA wouldn't work.

Code:
dtparam=audio=on

total noobville over here. Can you, or anyone explain your actions step-by-step?  I'm trying to do this, but am getting nowhere. And still no sound Sad
Reply
#8
(11-06-2019, 12:37 AM)duracell80 Wrote: Just wanna add to the community my discovery for fixing this issue when I found it.

This line was missing from my /boot/config.txt after a Bluetooth connection had dropped. Without that line ALSA wouldn't work.

Code:
dtparam=audio=on

I analyzed the code base and that particular setting is only manipulated in function cfgI2sOverlay() in /var/www/inc/playerlib.php. I also examined the other parts of the code base where config.txt is manipulated. It's not obvious to me how that line could be deleted.

I can never rule out bugs so if you have any insights as to what might have caused it to be deleted I'll try to repro.

-Tim
Reply
#9
But it partially works. I see my playlist playing. But still no sound. No error messages though
I also noticed that Max Alsa volume in
audio config is disabled? i can't turn the alsa volume up.  

In the config.txt file it says dtoverlay=hifiberry digi-pro or something, but i have the digi+ pro. have tried to
change it, but get a lot of errors

couldn't make heads or tails from the sudo raspi-confi.  i didn't know what to do




grtz jouri

quote='duracell80' pid='19418' dateline='1588210276']
[quote pid='14280' dateline='1573000623']
total noobville over here. Can you, or anyone explain your actions step-by-step?  I'm trying to do this, but am getting nowhere. And still no sound Sad
[/quote]

Login to SSH (using Putty on Windows) as user pi password moodeaudio

Code:
$ sudo nano /boot/config.txt
Make your changes then Ctrl+x then Y then Enter then ...

$ sudo reboot

Here's mine currently, I was having the issue when configuring my DAC

lcd_rotate=2
disable_splash=0
disable_overscan=1
hdmi_drive=2
hdmi_blanking=1
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=audio=off
dtoverlay=hifiberry-dacplus

Raspberry Pi Config can also help

$ sudo raspi-config



Hi, i tried your solution. (dtparam-audio=on)

But it partially works. I see my playlist playing. But still no sound. No error messages though
I also noticed that Max Alsa volume in
audio config is disabled? i can't turn the alsa volume up.  

In the config.txt file it says dtoverlay=hifiberry digi-pro or something, but i have the digi+ pro. have tried to
change it, but get a lot of errors

couldn't make heads or tails from the sudo raspi-confi.  i didn't know what to do




grtz jouri

[/quote]


Attached Files Thumbnail(s)
   
Reply
#10
(04-30-2020, 02:15 PM)duracell80 Wrote:
(04-30-2020, 11:29 AM)derbraadwurst Wrote: But it partially works. I see my playlist playing. But still no sound. No error messages though
I also noticed that Max Alsa volume in
audio config is disabled? i can't turn the alsa volume up.  

In the config.txt file it says dtoverlay=hifiberry digi-pro or something, but i have the digi+ pro. have tried to
change it, but get a lot of errors

couldn't make heads or tails from the sudo raspi-confi.  i didn't know what to do



Hi, i tried your solution. (dtparam-audio=on)

But it partially works. I see my playlist playing. But still no sound. No error messages though
I also noticed that Max Alsa volume in
audio config is disabled? i can't turn the alsa volume up.  

In the config.txt file it says dtoverlay=hifiberry digi-pro or something, but i have the digi+ pro. have tried to
change it, but get a lot of errors

couldn't make heads or tails from the sudo raspi-confi.  i didn't know what to do


grtz jouri


What happens if you run alsamixer in the ssh window ? It might be worth starting with a fresh install, take off the DAC and reintroduce it slowly noting the changes you make and that might give some clues as to where alsa is messing up.

sorry, don't understand that Sad
Reply


Forum Jump: