Thank you for your donation!


ERROR: Failed to open "ALSA default"
#11
duracell80
(04-30-2020, 11:29 AM)derbraadwurst Wrote: But it partially works. I see my playlist playing. But still no sound. No error messages though
I also noticed that Max Alsa volume in
audio config is disabled? i can't turn the alsa volume up.  

In the config.txt file it says dtoverlay=hifiberry digi-pro or something, but i have the digi+ pro. have tried to
change it, but get a lot of errors

couldn't make heads or tails from the sudo raspi-confi.  i didn't know what to do



Hi, i tried your solution. (dtparam-audio=on)

But it partially works. I see my playlist playing. But still no sound. No error messages though
I also noticed that Max Alsa volume in
audio config is disabled? i can't turn the alsa volume up.  

In the config.txt file it says dtoverlay=hifiberry digi-pro or something, but i have the digi+ pro. have tried to
change it, but get a lot of errors

couldn't make heads or tails from the sudo raspi-confi.  i didn't know what to do


grtz jouri


What happens if you run alsamixer in the ssh window ? It might be worth starting with a fresh install, take off the DAC and reintroduce it slowly noting the changes you make and that might give some clues as to where alsa is messing up.


Well a friend helped me out. Seems my WM8804 was not working anymore on the digi+ pro board. He thought electrostatic discharge was the culprit. 

Thanks everyone
Reply
#12
Kudos to your helpful friend :-)
Reply
#13
Hi Fizzy,
I had the same problem, sometimes I solved it by restarting moode, then I resolved definitively by changing the driver of the I2S (from HifiDigi + to HifiberryDac)
Reply


Forum Jump: