Thank you for your donation!


Mamboberry HD DAC+ v2 - constant noise
#1
Hi,
I'm switching from HifiBerry DAC+ Pro
I just installed this Mamboberry HD DAC V2 on moOde 6.2.0

https://collybia.com/product/mamboberry-...khz-24bit/



I used to have "hardware" control in MPD.
With Mamboberry HD DAC V2, I cannot set "hardware" control so I set "software" but I get a constant loud noise (I had it too with Hifiberry).
Since I cannot use "disabled 0dB"  , is there a workaround to fully enjoy this Mamboberry HD DAC with hardware control ? Why noise in "software" mode ? Alsa configuration ?

Thank you for your help
Reply
#2
/boot/config.txt
Code:
disable_splash=1
disable_overscan=1
hdmi_drive=2
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=audio=off
dtoverlay=hifiberry-dac
dtoverlay=pi3-disable-wifi
dtoverlay=pi3-disable-bt

/etc/mpd.conf
Code:
#########################################
# This file is automatically generated
# by the MPD configuration page.
#########################################

music_directory "/var/lib/mpd/music"
playlist_directory "/var/lib/mpd/playlists"
db_file "/var/lib/mpd/database"
log_file "/var/log/mpd/log"
pid_file "/var/run/mpd/pid"
state_file "/var/lib/mpd/state"
sticker_file "/var/lib/mpd/sticker.sql"
user "mpd"
group "audio"
bind_to_address "any"
port "6600"
log_level "default"
restore_paused "yes"
auto_update "no"
follow_outside_symlinks "yes"
follow_inside_symlinks "yes"
zeroconf_enabled "no"
zeroconf_name "Moode MPD"
filesystem_charset "UTF-8"
metadata_to_use "+comment"
replaygain "off"
replaygain_preamp "0"
volume_normalization "no"
audio_buffer_size "4096"
max_output_buffer_size "131072"
max_connections "128"

decoder {
plugin "ffmpeg"
enabled "yes"
}

input {
plugin "curl"
}

resampler {
plugin "soxr"
quality "very high"
threads "1"
}

audio_output {
type "alsa"
name "ALSA default"
device "hw:0,0"
mixer_type "software"
dop "no"
}

audio_output {
type "alsa"
name "ALSA crossfeed"
device "crossfeed"
mixer_type "software"
dop "no"
}

audio_output {
type "alsa"
name "ALSA parametric eq"
device "eqfa4p"
mixer_type "software"
dop "no"
}

audio_output {
type "alsa"
name "ALSA graphic eq"
device "alsaequal"
mixer_type "software"
dop "no"
}

audio_output {
type "alsa"
name "ALSA polarity inversion"
device "invpolarity"
mixer_type "software"
dop "no"
}

audio_output {
type "alsa"
name "ALSA bluetooth"
device "btstream"
mixer_type "software"
}

audio_output {
type "httpd"
name "HTTP stream"
port "8000"
encoder "lame"
bitrate "320"
tags "yes"
always_on "yes"
}
Reply
#3
I placed the text in code boxes for readability. Its the 5th button from the right on the toolbar when you are composing/editing a post.

Regarding your question and issue.

1. The ES9023 DAC chip does not include a Hardware volume controller.
2. The symptom "constant load noise" suggests something external to moOde software for example a defective power supply or Raspberry Pi.

-Tim
Reply
#4
Thank you for fast reply and diagnose!
1. to your knowledge is there a Sabre chip DAC with Hardware volume controller ? I have a jitter and cracks with Hifiberry
2. I have a linear power supply, so I'll try another Pi
Reply
#5
You could try either Allo Katana DAC or Audiophonics ES9028/9038 DAC. Both of these ESS Sabre based devices support Hardware volume.
Reply
#6
(09-12-2019, 12:55 PM)powskii Wrote: ...but I get a constant loud noise (I had it too with Hifiberry)...


1. to your knowledge is there a Sabre chip DAC with Hardware volume controller ? I have a jitter and cracks with Hifiberry
2. I have a linear power supply, so I'll try another Pi

Hi,

I combined bits of two of your posts in the above quote.

Since you have this constant loud noise with either DAC you should be suspicious of *all* your external components. These include
  • The downstream audio equipment. One possibility is it's being over-driven by the DAC output.
  • The power supply. Just because you "have a linear power supply" doesn't mean it's good for this purpose. Try substituting a genuine RPi power supply just to be sure.
  • The RPi. I have to say I'm dubious but swapping RPis is an easy test.
  • Grounds (or earths in countries which speak the Queen's English  Tongue). Improper grounding of various pieces of audio equipment can induce hum/noise. Granted this is not as common a problem as it used to be, but it still can happen.
Since you've already replaced the HiFiBerry DAC+ Pro this observation might be irrelevant but I've not experienced the issues you had with yours. Since Tim makes it so easy to configure, I've tried both software volume control and hardware volume control with this DAC and it works fine for me with either choice. (I don't believe hardware volume control is a magic elixir, by the way.)

Regards,
Kent
Reply
#7
Hi,

Thank you for this precision. By the way thanks for this great work on moOde.

I've just tested with a new Pi 3B+ : same problem on both DAC : constant noise/hum with software volume controller.
Disabled vol controller are OK on Hifiberry and Mamboberry, hardware vol controller is ok on Hifiberry.
So not a Pi problem.
This hum appears only when playing audio from USB , webradios are fine : why is this please ?

Regards,
Xavier
Reply
#8
(09-12-2019, 02:11 PM)TheOldPresbyope Wrote: Since you have this constant loud noise with either DAC you should be suspicious of *all* your external components. These include
  • The downstream audio equipment. One possibility is it's being over-driven by the DAC output.
  • The power supply. Just because you "have a linear power supply" doesn't mean it's good for this purpose. Try substituting a genuine RPi power supply just to be sure.
  • The RPi. I have to say I'm dubious but swapping RPis is an easy test.
  • Grounds (or earths in countries which speak the Queen's English  Tongue). Improper grounding of various pieces of audio equipment can induce hum/noise. Granted this is not as common a problem as it used to be, but it still can happen.
Since you've already replaced the HiFiBerry DAC+ Pro this observation might be irrelevant but I've not experienced the issues you had with yours. Since Tim makes it so easy to configure, I've tried both software volume control and hardware volume control with this DAC and it works fine for me with either choice. (I don't believe hardware volume control is a magic elixir, by the way.)

Regards,
Kent

Hi,

Thank you for this precision. By the way thanks for this great work on moOde.

The downstream audio equipment : Dynaudio active speaker 
The power supply / ground problem : maybe yes this would be getting very annoying....

I've just tested with a new Pi 3B+ : same problem on both DAC : constant noise/hum with software volume controller.
Disabled vol controller are OK on Hifiberry and Mamboberry, hardware vol controller is ok on Hifiberry.
So not a Pi problem.
This hum appears only when playing audio from USB , webradios are fine : why is this please ?

Regards,
Xavier
Reply
#9
The symptom "This hum appears only when playing audio from USB , webradios are fine" suggests something external to moOde software.

Try playing the Stereo Test file which is on the SDCard.
Reply
#10
Yes same problem with the stereo test file on SD
and same problem with another USB drive.
I have tested other power supplies, still same problem...

What does it suggest ?
Reply


Forum Jump: