Thank you for your donation!


Solved: Can’t connect to NAS
#11
Your IP address 192.168.68.117 is not typically what would be assigned by a home Router. Normally a home network will be using 192.168.1 or 192.168.0, not a .68 subnet.

Is your home network using a non-standard configuration?

Typically when hosts can't be found on a network it's because DNS is not configured correctly or network routing is broken because of other configuration issues.

If the network is configured correctly then from the Pi you should be able to ping any other host on the network by name. If not then there is a network configuration issue.

-Tim
Reply
#12
All the devices on my network have a .68 subnet. I don’t know enough about it to set it up non-standard but it’s possible I’ve done something wrong somewhere. The pi is plugged into a switch wired into my router which is wired direct to my modem so there wasn’t much setup involved apart from plugging them in and I’ve never messed with the dns settings that I can recall.
Reply
#13
From the Pi can you ping other hosts on your network?

Example: ping my Mac Air, host name is LT1

Code:
pi@rp3:~ $ ping LT1
PING LT1.home (192.168.1.155) 56(84) bytes of data.
64 bytes from LT1.home (192.168.1.155): icmp_seq=1 ttl=64 time=3.73 ms
64 bytes from LT1.home (192.168.1.155): icmp_seq=2 ttl=64 time=23.1 ms
64 bytes from LT1.home (192.168.1.155): icmp_seq=3 ttl=64 time=251 ms
64 bytes from LT1.home (192.168.1.155): icmp_seq=4 ttl=64 time=109 ms
Reply
#14
I can try. Where would I type that and how do I know what my MacBook pro’s host name is? Do I need to reboot back into noobs?
Reply
#15
Hi Simon,

I have a few questions.

1) You mentioned you tried connecting with your NAS IP address. From your logs, the IP address shows 10.1.1.5 that you manually put in. Your logs show the IP address for the PI is 192.168.68.117.

Well, the fact that those IP address subnets are totally different (the 10.1.1 and the 192.168.68 addresses) you will NEVER connect to your NAS (unless you have a high knowledge of network routing). Both the NAS and the PI must be on the same Address Range, so both 10.1.1.# or both 192.168.68.#

You mention above, that all your devices on your network have a .68 subnet, so why did you try to connect to the NAS (as shown in the logs above) with 10.1.1.5?

2) In your screen shot, you have tried to mount Volumes/music. This is incorrect has you have to have the NAS Name or IP first, then Volumes and music must be shared on the NAS. Also, the correct syntax is //nas name or ip/share/folder. There is no colon after the NAS name/IP address. so an example would be //nas name/sharename

Also to note above, you have to get the case (upper/lower case) correct as the pathnames are case sensitive.

With Synology NAS, it is best to turn on "Maximum SMB Protocol 3". This setting should be in the SMB configuration area.

You should also have a valid username and password to connect to the share with and that user needs full access on the share.

3) You state you have a Mac. Does the MAC connect to the NAS? If so, what is the "path" on the MAC show?

In your log above, it specifically states it cant find the NAS called Volumes, which shows that you are not using the correct format of the sharename. From the log: (20191004 232322 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)).

To find your Macbook host name, a simple google search shows: Click the Apple logo in the top left corner, and then select System Preferences from the Apple Menu.Click on the Sharing icon. Your computer name will be listed at the top of the window that opens in the Computer Name field.

I think you need to configure your network correctly before stating the (software) is the problem and trying to switch between the different versions of software (Moode, Run, Volumio, etc). Also, SMB can be fiddly at the best of times. I suggest to use NFS (as did Sander mention above).

Rob
Pi 4B 2GB, HiFi Berry Digi+, Original 7" Raspberry Pi Screen, Ethernet Connected, Sandisk Ultra10 SD card, 5amp power supply (Drives the PI and Screen separately) streaming audio via NFS shares from QNAP NAS.
Reply
#16
Hi @rb0135

Thanks for the detailed post. I’m at work now but when I get home I’ll sit down and try to absorb it and follow/respond thoughtfully.

Briefly, though: If, in my frustration, I sounded like I was blaming Moode for the problem, I’m absolutely not and I really appreciate @Tim Curtis and everybody’s help. I tried Volumio and Rune because I was out of ideas but, based on everything I’ve read, Moode sounds better so I still want it to be my player, if I can get it to connect.

I’m a self-taught networking novice and there is an excellent chance my network configuration is hacked together based on a bunch of haphazard forward fails but it’s what I’ve got so I need to try to make it work.

I’ll delve into your post over a cup of tea tonight (again, highly appreciated) and let you know what I find

Thanks, Simon
Reply
#17
Heart 
(10-08-2019, 07:39 AM)rb0135 Wrote: Hi Simon,

I have a few questions.

1) You mentioned you tried connecting with your NAS IP address. From your logs, the IP address shows 10.1.1.5 that you manually put in. Your logs show the IP address for the PI is 192.168.68.117.

Well, the fact that those IP address subnets are totally different (the 10.1.1 and the 192.168.68 addresses) you will NEVER connect to your NAS (unless you have a high knowledge of network routing). Both the NAS and the PI must be on the same Address Range, so both 10.1.1.# or both 192.168.68.#

10.1.1.5 is how I log in to my NAS from the Mac's finder, via a browser, my apple tv, all my synology apps and both RuneAudio and Volumio. When I go to system information in the NAS that's what it says the IP address is and I can understand that that might introduce problems but it's only with Moode so I don't think it's the only thing but I'm open to suggestions about how to change it.

You mention above, that all your devices on your network have a .68 subnet, so why did you try to connect to the NAS (as shown in the logs above) with 10.1.1.5?

I just always have ¯\_(ツ)_/¯ 

2) In your screen shot, you have tried to mount Volumes/music. This is incorrect has you have to have the NAS Name or IP first, then Volumes and music must be shared on the NAS. Also, the correct syntax is //nas name or ip/share/folder. There is no colon after the NAS name/IP address. so an example would be //nas name/sharename

Also to note above, you have to get the case (upper/lower case) correct as the pathnames are case sensitive.

When I'm in my music folder on the Mac's finder I can select 'Copy "music" as Pathname' and I get "/Volumes/music" so that's exactly what I used (without the first slash). I also tried "10.1.1.5/Volumes/music", "10.1.1.5/music" (I think this is what worked on RuneAudio), "volume1/music" and "10.1.1.5/volume1/music" because I saw that somewhere too. I haven't tried a double slash as I didn't see that anywhere but I'm game if you think that's it

With Synology NAS, it is best to turn on "Maximum SMB Protocol 3". This setting should be in the SMB configuration area.

I did this based on something I saw in a Volumio forum and it's what got Volumio working. Didn't seem to make a difference for Moode

You should also have a valid username and password to connect to the share with and that user needs full access on the share.

Yes, I tried it with username and password and also with "Guest" and no password as per a suggestion I saw on this forum (I think?)

3) You state you have a Mac. Does the MAC connect to the NAS? If so, what is the "path" on the MAC show?

Yes. "smb://10.1.1.5" or just "10.1.1.5". I used to connect with "afp://Server._afpovertcp._tcp.local" but that stopped working for some reason. I don't know if that's pertinent

In your log above, it specifically states it cant find the NAS called Volumes, which shows that you are not using the correct format of the sharename. From the log: (20191004 232322 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)).

Ok. Do you know where I can find the correct format?

To find your Macbook host name, a simple google search shows: Click the Apple logo in the top left corner, and then select System Preferences from the Apple Menu.Click on the Sharing icon. Your computer name will be listed at the top of the window that opens in the Computer Name field.

Ok, got that. Where do I enter it on the Pi to ping the MBP?

I think you need to configure your network correctly before stating the (software) is the problem and trying to switch between the different versions of software (Moode, Run, Volumio, etc).

As above, I'm not suggesting there's anything wrong with Moode, I just can't get it to talk to my NAS and I'm trying to work out why so I can enjoy it.

Also, SMB can be fiddly at the best of times. I suggest to use NFS (as did Sander mention above).

Yes, I think I've tried everything with NFS as well

Rob
[quote pid='13569' dateline='1570520342']
I can't stress enough that I am simply a monkey pushing buttons that look like they might be the right shape so I really appreciate everyone's patient advice. I'm really looking forward to getting it going. Thanks again, Simon
[/quote]
Reply
#18
Your NAS (10.1.1.5) and Pi (192.168.68.117) are on different networks and thus can't find or communicate with each other.

Pi needs to have an IP address in 10.1.1.* range in order to see your NAS. Normally your home Router will assign clients via DHCP the correct IP address, Gateway address and DNS address.
Reply
#19
Ok. Should I change the IP address on the pi or on the router? How would I do that? Like I said, everything else is getting along fine so I’m wary of having to reconfigure the whole system.
Reply
#20
I can't offer any advice because I don't understand your network configuration and how hosts can be assigned completely different networks i.e., 10.x.x.x and 192.x.x.x.

-Tim
Reply


Forum Jump: