Thank you for your donation!


Solved: cli mpc volume not working
#1
Hello
i would like to know if the Volume my be changed by

mpc volume 60

i just ask because in my case it is not working. 

have a nice day
vinc
Raspberry Pi3B+ --> HiFiBerry DAC+ PRO --> Cyrus | Pre - Pre Amplifier --> D. Klimo | Kent monoblocks --> Piega | Piega LDR 8.2
Reply
#2
Do you mean the volume knob is not updating or the volume itself is not changing?

If you want the volume to change AND the knob to update then use vol.sh

pi@rp2:~ $ /var/www/vol.sh --help
Usage: vol.sh [OPTION] [VOLUME]
Change the volume and update the knob.

With no OPTION or VOLUME, print the current volume.
With just VOLUME, set current volume to VOLUME.

-up VOLUME value between 1 and 100
-dn VOLUME value between 1 and 100
-mute mute or unmute the volume
-restore set volume to current knob level
--version print the program version
--help print this help text
Reply
#3
Hello Tim
thanks for your feedback if i do a

$ /var/www/vol.sh 60
$ /var/www/vol.sh 90

it works if i do add it in a crontab like

15 19 * * * /var/www/vol.sh 60
20 19 * * * /var/www/vol.sh 85
25 19 * * * /var/www/vol.sh 60
30 19 * * * /var/www/vol.sh 85
35 19 * * * /var/www/vol.sh 60

and doing a
service cron reload

did not work

any idea whats wrong?

have a nice day
vinc
Raspberry Pi3B+ --> HiFiBerry DAC+ PRO --> Cyrus | Pre - Pre Amplifier --> D. Klimo | Kent monoblocks --> Piega | Piega LDR 8.2
Reply
#4
Cron is disabled by default in moOde

You could enable cron with sudo systemctl enable cron or using systemd-timer instead.
Reply
#5
Hello @TookaFace
Cron is working by default on my Pi

I did Put the Command into a bashfile - and with Cron just call up the file itself it works to me know.
Raspberry Pi3B+ --> HiFiBerry DAC+ PRO --> Cyrus | Pre - Pre Amplifier --> D. Klimo | Kent monoblocks --> Piega | Piega LDR 8.2
Reply


Forum Jump: