Thank you for your donation!


Pi4 digi hat
#11
Nope. Never tried volumio, I just don't like how it sounds. No matter what I tried...It always sounds like...umm...Discomusic Wink
Anyway...

I will try your brute force suggestion and post results
Reply
#12
Best way to troubleshoot:

1. Install stock Raspbian Buster Lite 2019-09-26
https://www.raspberrypi.org/downloads/raspbian/

2. Install Linux kernel 4.19.75
Code:
echo "y" | sudo PRUNE_MODULES=1 rpi-update d9321aceacfc6619b4238c6c764203b1122f2f9b

sudo rm -rf /lib/modules.bak
sudo rm -rf /boot.bak
sudo apt-get clean

3. Configure the correct overlay for the audio device: 
- Hifiberry Digi/Digi+ = hifiberry-digi
- Hifiberry Digi+ Pro = hifiberry-digi-pro

Code:
sudo nano /boot/config.txt

# Add the line below to the end
dtoverlay=hifiberry-digi

Save the file
Reboot

Then examine the boot log for errors trying to load the overlay

Code:
dmesg

If the overlay fails to load with errors then submit a bug report to Hifiberry with the list of steps that they can use to reproduce the issue.
Reply
#13
[Post edit: just saw Tim's reply. Count on him to get to the crux of the matter!]

@starbender

I make no recommendations of players based on how they sound (I don't trust either my ears or my taste!) [1]

The reason I mentioned Volumio is that for RPis it is built on Raspbian too (caveat: according to the os-release file in the current volumio 2.632 image I just downloaded, it's built on "Raspbian GNU/Linux 8 (jessie)").

Regards,
Kent

[1] a casual observer might notice which Forum I hang out in.
Reply
#14
No idea why, but wm8804 base digi hat works fine with moode 6.3.

Cool
Reply
#15
(10-27-2019, 07:14 AM)starbender Wrote: No idea why, but wm8804 base digi hat works fine with moode 6.3.

Cool

Good news. When I can I'll check this on my Pi2Design HAT to confirm on different wm8804 hardware. It would be great if the problem has solved itself. I probably won't have the time until later this week though.
Reply
#16
I tested my pi 4b and Pi2Design 502DAC Pro again this morning with Moode 6.3.0 but the combination is still not working. I'll try again one 6.4 is released.
Reply


Forum Jump: