Thank you for your donation!


-> Session permissions (Reapplied)
#1
Hi,

since yesterday I have this error ....
Excerpt is from today
---------------------------
20191010 090240 worker: Session permissions (OK)
20191010 090240 worker: Watchdog started
20191010 090240 worker: Ready
20191010 090241 watchdog: Session permissions (Reapplied)
20191010 090247 watchdog: Session permissions (Reapplied)
20191010 090254 watchdog: Session permissions (Reapplied)
20191010 090301 watchdog: Session permissions (Reapplied)
20191010 090307 watchdog: Session permissions (Reapplied)
---------------------------

-> Moode 6.3.0
-> Linux moode 4.19.76-v8+ #1272 SMP PREEMPT Fri Oct 4 15:11:39 BST 2019 aarch64 GNU/Linux

I could not find anything up to now .....
Thanks in advance for your help
Zeferino
Reply
#2
Revert to a stock 6.3.0 build (4.19.75, 32-bit)
Reply
#3
(10-10-2019, 11:33 AM)Tim Curtis Wrote: Revert to a stock 6.3.0 build (4.19.75, 32-bit)

image set new and left on 32 bit ..
Everything fits now ...
Thank you Tim.
Reply
#4
Nice :-)

The error "watchdog: Session permissions (Reapplied)" in theory should never happen but I recall during the development of moOde 6 series I would occasionally see incorrect permissions for the PHP session file. It was rare and only seemed to occur after loading updated development moOde sources and configs on the Pi then rebooting. A second reboot and no error.

I added a bit of code to watchdog.sh script to check and reset the permissions if necessary which should correct the error after one occurrence. If it keeps reappearing in the log I may need to further investigate the issue.

A new kernel or 64-bit should not cause the error.

-Tim
Reply
#5
(10-10-2019, 12:16 PM)Tim Curtis Wrote: Nice :-)

The error "watchdog: Session permissions (Reapplied)" in theory should never happen but I recall during the development of moOde 6 series I would occasionally see incorrect permissions for the PHP session file. It was rare and only seemed to occur after loading updated development moOde sources and configs on the Pi then rebooting. A second reboot and no error.

I added a bit of code to watchdog.sh script to check and reset the permissions if necessary which should correct the error after one occurrence. If it keeps reappearing in the log I may need to further investigate the issue.

A new kernel or 64-bit should not cause the error.

-Tim

I watch this for a while ...

thanks again
Reply
#6
I have this problem right now (on version 6.2.1):
......
20191020 154950 watchdog: Session permissions (Reapplied)
20191020 154956 watchdog: Session permissions (Reapplied)
20191020 155002 watchdog: Session permissions (Reapplied)
.......
I'm applying the in place update to 6.3.0....
Reply
#7
I'm curious. How is this error manifested, e.g., what unexpected moOde behavior caused you to look at the log?

And did it disappear on a reboot as Tim suggested it might?

Regards,
Kent
Reply
#8
Same error here:
20191027 181157 worker: Watchdog started
20191027 181157 worker: Ready
20191027 181157 watchdog: Session permissions (Reapplied)
20191027 181204 watchdog: Session permissions (Reapplied)
Running last 6.3.0 which was upgraded online from 6.2.1.
Shutdown command does not work, Rpi remain power on with red led.
Changed to 64bit same error.
Reply
#9
(10-27-2019, 04:17 PM)liv_s Wrote: #1> Same error here:
20191027 181157 worker: Watchdog started
20191027 181157 worker: Ready
20191027 181157 watchdog: Session permissions (Reapplied)
20191027 181204 watchdog: Session permissions (Reapplied)
Running last 6.3.0 which was upgraded online from 6.2.1.
#2> Shutdown command does not work, Rpi remain power on with red led.
#3> Changed to 64bit same error.

#1> Same questions I asked a week ago. What precipitated this error report? What had you done prior, what caused you to look at the log, and did it go away when you rebooted?

#2> The shutdown command only stops Linux safely and puts the RPi into a low-power state. It does not turn off the power. Various people have posted power-on/power-off hacks to the Web. Google is your friend.

#3> As Tim said before, this PHP behavior should not depend on the kernel. 

Regards,
Kent
Reply
#10
#1 - It is related to #2 as some time ago the shutdown command was fine.
My setup is http://moodeaudio.org/forum/showthread.php?tid=1230
I move from 5.xx to 6.xx without installing the scripts for pimoroni on/off shim.
Normally I use to let the device power on 24/24, but last days I want to shutdown in the evening.
I google for answer about this behavior and look in the log.
Did not go away with reboot.
#2 - I understand this is a different story and not related to #1.
Before with scripts when I execute shutdown command it just stops Rpi. No red led on Rpi.
I will install again the pimoroni scripts to see if error is still there, as is the only difference.
It could be this, as the power to Rpi goes by on/off shim.

LE: Solved after installing pimoroni scripts. Now power off is complete, either by button or gui.
Reply


Forum Jump: