Thank you for your donation!


moOde 6.4.0 bug reports
(12-29-2019, 05:02 PM)feh123 Wrote: Hi

Just to follow on re my Spotify issue. I re-installed 6.4.0 and managed to get Moode operational for my NAS based music and internet radio. However Spotify will only work directly through my Naim streamer. Moode Spotify connect is there as an available device on my Spotify app but if I connect to it I get no sound although the app shows no error and I see a timer for the track playing.

I confess I'm a bit mystified by your issue.

I don't have the HiFiBerry Digi Pro HAT nor any S/PDIF equipment. 

ATM I'm playing Spotify Premium tracks without a problem on an RPi3B+ running moOde 6.4.0 and a HiFiBerry DAC+ feeding an amp and speakers. 
I've got the moOde Spotify bitrate setting at 320k. 

pgrep shows the librespot process is running, e.g., reports the process number:

Code:
pi@moode:~ $ pgrep librespot
1197


The attached image shows the alsamixer report.

The hw_parameters appear to be the same as yours

Code:
pi@moode:~ $ cat /proc/asound/card0/pcm0p/sub0/hw_params
access: RW_INTERLEAVED
format: S16_LE
subformat: STD
channels: 2
rate: 44100 (44100/1)
period_size: 225
buffer_size: 22050


Since the "Spotify Active" overlay apparently locks your home screen so you can't click the Audio info selection, you can instead point your browser directly to http://<your player name or IP address>/audioinfo.php

Here's the audioinfo I scraped from my browser

Quote:Input / Output
    Source: Spotify stream
    Encoded at: Unknown
    Decoded to: 16 bit, 44.1 kHz, Stereo, VBR
    Destination: Local
    Output rate: 16 bit, 44.1 kHz, Stereo, 1.411 Mbps
DSP operations
    Volume ctl: Software (MPD 32-bit float with dither)
    Resampling: n/a
    Polarity inv:
    Crossfade: n/a
    Crossfeed: n/a
    Parametric EQ: off
    Graphic EQ: off
    Replaygain: n/a
    Normalize vol: n/a
    Chip options: FIR interpolation with de-emphasis, Gain=0dB, Boost=0dB
Audio Device
    Device: HiFiBerry DAC+
    Chip: Burr Brown PCM5122
    Interface: I2S 
    Formats: S16_LE, S24_LE, S32_LE
    Platform: Pi-3B+ 1GB v1.3

Note that the default Initial volume setting is 0% in the Spotify Config page. You did remember to change this and/or to use your Spotify app to increase the volume to some non-zero value, right?

Regards,
Kent


Attached Files Thumbnail(s)
   
Reply


Messages In This Thread
moOde 6.4.0 bug reports - by Tim Curtis - 11-28-2019, 04:06 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-28-2019, 04:13 PM
RE: moOde 6.4.0 bug reports - by suzywong - 11-30-2019, 01:52 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-30-2019, 03:22 PM
RE: moOde 6.4.0 bug reports - by suzywong - 12-01-2019, 10:41 AM
RE: moOde 6.4.0 bug reports - by cryptout - 12-14-2019, 02:54 PM
RE: moOde 6.4.0 bug reports - by Herman - 11-28-2019, 10:34 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-28-2019, 10:35 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-28-2019, 10:44 PM
RE: moOde 6.4.0 bug reports - by Herman - 11-28-2019, 10:59 PM
RE: moOde 6.4.0 bug reports - by Herman - 11-28-2019, 11:10 PM
RE: moOde 6.4.0 bug reports - by Herman - 11-28-2019, 11:41 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-29-2019, 01:03 AM
RE: moOde 6.4.0 bug reports - by Herman - 11-29-2019, 06:53 PM
RE: moOde 6.4.0 bug reports - by TookaFace - 11-29-2019, 08:16 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-29-2019, 11:55 AM
RE: moOde 6.4.0 bug reports - by TookaFace - 11-29-2019, 01:27 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-29-2019, 01:57 PM
RE: moOde 6.4.0 bug reports - by TookaFace - 11-29-2019, 02:03 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-29-2019, 02:24 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-30-2019, 03:14 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-30-2019, 12:22 AM
RE: moOde 6.4.0 bug reports - by Herman - 11-30-2019, 09:42 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-30-2019, 03:16 PM
RE: moOde 6.4.0 bug reports - by Herman - 11-30-2019, 07:21 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-30-2019, 07:27 PM
RE: moOde 6.4.0 bug reports - by Herman - 12-01-2019, 12:29 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 01:10 PM
RE: moOde 6.4.0 bug reports - by Herman - 12-01-2019, 01:39 PM
RE: moOde 6.4.0 bug reports - by godt2p4 - 11-30-2019, 05:20 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-30-2019, 04:43 PM
RE: moOde 6.4.0 bug reports - by godt2p4 - 12-01-2019, 02:00 AM
RE: moOde 6.4.0 bug reports - by Mr.R0b0t - 11-30-2019, 06:53 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-30-2019, 07:26 PM
RE: moOde 6.4.0 bug reports - by Mr.R0b0t - 11-30-2019, 07:51 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-30-2019, 08:40 PM
RE: moOde 6.4.0 bug reports - by sjoerdju - 11-30-2019, 08:38 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 11-30-2019, 08:54 PM
RE: moOde 6.4.0 bug reports - by sjoerdju - 12-01-2019, 01:20 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 03:59 PM
RE: moOde 6.4.0 bug reports - by sjoerdju - 12-01-2019, 08:47 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-01-2019, 12:30 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 01:29 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-01-2019, 02:11 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 02:22 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-01-2019, 02:31 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 02:51 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-01-2019, 02:57 PM
RE: moOde 6.4.0 bug reports - by ghoeher - 12-01-2019, 02:40 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 02:48 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 02:02 PM
RE: moOde 6.4.0 bug reports - by TheOldPresbyope - 12-01-2019, 02:58 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 03:19 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-01-2019, 04:14 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 04:19 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-01-2019, 08:11 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 08:34 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-02-2019, 07:44 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-02-2019, 12:50 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-03-2019, 09:20 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-01-2019, 09:39 PM
RE: moOde 6.4.0 bug reports - by sjoerdju - 12-02-2019, 08:55 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-02-2019, 12:53 PM
RE: moOde 6.4.0 bug reports - by sjoerdju - 12-02-2019, 06:17 PM
RE: moOde 6.4.0 bug reports - by bobfa - 12-02-2019, 12:30 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-02-2019, 12:57 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-02-2019, 07:34 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-03-2019, 12:42 PM
RE: moOde 6.4.0 bug reports - by TheOldPresbyope - 12-03-2019, 02:36 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-03-2019, 03:04 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-03-2019, 03:11 PM
RE: moOde 6.4.0 bug reports - by TheOldPresbyope - 12-03-2019, 03:11 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-03-2019, 06:07 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-03-2019, 09:32 PM
RE: moOde 6.4.0 bug reports - by stefano_mbp - 12-03-2019, 10:57 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-03-2019, 11:36 PM
RE: moOde 6.4.0 bug reports - by TheOldPresbyope - 12-04-2019, 03:11 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-03-2019, 11:41 PM
RE: moOde 6.4.0 bug reports - by BlackSmile - 12-04-2019, 07:54 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-04-2019, 08:48 PM
RE: moOde 6.4.0 bug reports - by swizzle - 12-05-2019, 03:05 AM
RE: moOde 6.4.0 bug reports - by BlackSmile - 12-05-2019, 01:01 PM
RE: moOde 6.4.0 bug reports - by bobfa - 12-08-2019, 04:31 PM
RE: moOde 6.4.0 bug reports - by alanthebat - 12-12-2019, 10:09 PM
RE: moOde 6.4.0 bug reports - by TheOldPresbyope - 12-08-2019, 06:01 PM
RE: moOde 6.4.0 bug reports - by bobfa - 12-10-2019, 01:16 AM
RE: moOde 6.4.0 bug reports - by bobfa - 12-12-2019, 04:24 AM
RE: moOde 6.4.0 bug reports - by bobfa - 12-16-2019, 11:28 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-12-2019, 03:14 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-14-2019, 03:25 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-14-2019, 05:54 PM
RE: moOde 6.4.0 bug reports - by soundof-ferns - 12-14-2019, 07:22 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-14-2019, 07:50 PM
RE: moOde 6.4.0 bug reports - by soundof-ferns - 12-14-2019, 08:28 PM
RE: moOde 6.4.0 bug reports - by feh123 - 12-16-2019, 10:27 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-16-2019, 12:26 PM
RE: moOde 6.4.0 bug reports - by feh123 - 12-23-2019, 07:30 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-17-2019, 12:10 AM
RE: moOde 6.4.0 bug reports - by alanthebat - 12-17-2019, 05:41 PM
RE: moOde 6.4.0 bug reports - by bobfa - 12-19-2019, 10:31 PM
RE: moOde 6.4.0 bug reports - by cryptout - 12-21-2019, 11:44 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-22-2019, 02:41 AM
RE: moOde 6.4.0 bug reports - by bobfa - 12-23-2019, 12:34 AM
RE: moOde 6.4.0 bug reports - by TheOldPresbyope - 12-21-2019, 02:18 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-23-2019, 01:05 AM
RE: moOde 6.4.0 bug reports - by TheOldPresbyope - 12-23-2019, 02:33 AM
RE: moOde 6.4.0 bug reports - by weaver - 12-23-2019, 10:27 AM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-23-2019, 12:10 PM
RE: moOde 6.4.0 bug reports - by weaver - 12-23-2019, 01:10 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-23-2019, 01:45 PM
RE: moOde 6.4.0 bug reports - by weaver - 12-23-2019, 01:52 PM
RE: moOde 6.4.0 bug reports - by TheOldPresbyope - 12-23-2019, 02:48 PM
RE: moOde 6.4.0 bug reports - by weaver - 12-23-2019, 03:07 PM
RE: moOde 6.4.0 bug reports - by weaver - 12-23-2019, 07:18 PM
RE: moOde 6.4.0 bug reports - by feh123 - 12-28-2019, 06:12 PM
RE: moOde 6.4.0 bug reports - by feh123 - 12-28-2019, 06:46 PM
RE: moOde 6.4.0 bug reports - by TookaFace - 12-29-2019, 03:36 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 12-29-2019, 10:33 PM
RE: moOde 6.4.0 bug reports - by feh123 - 12-29-2019, 05:02 PM
RE: moOde 6.4.0 bug reports - by TheOldPresbyope - 12-30-2019, 09:11 PM
RE: moOde 6.4.0 bug reports - by feh123 - 12-31-2019, 09:00 AM
RE: moOde 6.4.0 bug reports - by MTAnthony - 12-31-2019, 01:20 AM
RE: moOde 6.4.0 bug reports - by CallMeMike - 12-31-2019, 06:16 AM
RE: moOde 6.4.0 bug reports - by TookaFace - 01-08-2020, 12:31 PM
RE: moOde 6.4.0 bug reports - by defthoms - 01-17-2020, 01:04 PM
RE: moOde 6.4.0 bug reports - by Tim Curtis - 01-17-2020, 03:10 PM
RE: moOde 6.4.0 bug reports - by defthoms - 01-17-2020, 10:14 PM
RE: moOde 6.4.0 bug reports - by CallMeMike - 01-18-2020, 08:39 AM

Forum Jump: