Thank you for your donation!


Problem: Moode 4.4 - ssh troubles
#1
I would like to be able to send commands to my moode player via ssh from my Android or iPhone .  I tried several Android apps and my MacBook but the attempts to login to my player are rejected.  I can use web ssh successfully.   Any ideas what I'm doing wrong?  I'm using pi and moodeaudio credentials.
Thanks
Reply
#2
(11-30-2019, 04:14 PM)glhoop Wrote: I would like to be able to send commands to my moode player via ssh from my Android or iPhone .  I tried several Android apps and my MacBook but the attempts to login to my player are rejected.  I can use web ssh successfully.   Any ideas what I'm doing wrong?  I'm using pi and moodeaudio credentials.
Thanks

What diagnostic message are you receiving when the attempt is rejected? How does data make its way from your mobile devices and your moOde player? E.g., what exactly is your networking configuration?

I've stopped using SSH clients on my Android phone(s). The screen and keyboard are too small and fiddly, but logging into moOde players worked for me when I did use them. SSH logins are working for me using the Shelly app on my iPad. This is true whether the moOde player is in wireless AP mode and the iPad is connected as a wireless client, or the player is a host on my LAN and the iPad is connected to an access point on the LAN. I just have to make sure the two are on the same subnet and I'm using the correct IP address.

Regards,
Kent
Reply
#3
The moode player is attached to the wireless network in my home.  I connect to the same WiFi network and attempt to access the moode player via ssh just like I do when I access moode via the web interface via it's ip address.  Is debug info available from the moode player?  I'm not getting any significant debug info from the android apps or my macbook, just that connection refused.  I looked at the system info log in moode but no entries related to a refused login attempt.
Reply
#4
@glhoop you've added a blank "ssh" file to the boot dir on the pi?
Reply
#5
A "connection refused" will normally mean the target is on the network but nothing is listening on the target port, in this case ssh on port 22. Thus sshd isn't running.
Have you enabled the ssh server in Moode's settings (under System)?
Reply
#6
Yes, I've added the file ssh and ssh server is enabled.
Reply
#7
But a default moOde installation starts the sshd service already, listening to port 22. The notion that you need a blank ssh file in the root directory at first start-up is a holdover from the way one configures bare Raspbian. Tim's taken care of that.

Bottom line, you should be able to ssh into your moOde player from the get-go using the stated credentials.

That System config setting starts the "SSH term server" which enables use of the "Web SSH terminal". This "terminal" accesses a specialized web service listening to port 4200.

If the sshd service is running and listening on port 22 and you still can't connect, then one has to suspect there is something interrupting the passage of packets to the port. Typically a firewall is the culprit.

Regards,
Kent
Reply
#8
I decided to download the latest version of moode & now ssh works.
Reply
#9
Can this somehow be move from port 22 to another port?
Reply
#10
(12-02-2019, 03:01 AM)glhoop Wrote: I decided to download the latest version of moode & now ssh works.

Great.

Please change this thread to “SOLVED”.

Regards,
Kent
Reply


Forum Jump: