Thank you for your donation!


Problem: Library build problem with my Audiophonics ES09038q2m RaspTouch
#9
@maartin

OK, I finally managed to create a test case which behaves in the manner you described.

Scenario:

OpenMediaVault server running on host OMV-HC1 with the following snippet of its directory tree structure:

Code:
/path-to/Music
      ./Music/lots of my music in subdirectories
      ./Music/test
      ./Music/test/a number music test files

I have configured OpenMediaVault to serve the subdirectory /path-to/Music as an SMB/CIFS share with guest privileges using SMBv1.0 protocol. That's what you see in the smbtree output in my previous posts. This share is discovered by the scanning function in moOde's Source Mount panel and reported as Server Path OMV-HC1/Music

It mounts fine in moOde and MPD indexes all its contents (which include the music test files in /path-to/Music/test).

Now, if I try manually to mount the subdirectory /path-to/Music/test as Server Path OMV-HC1/Music/test I get the same error message you got.

Code:
mount error(2): No such file or directory

Not surprising, since I haven't told OpenMediaVault to offer this subdirectory as a SMB/CIFS share. It's accessible to moOde only via the SMB/CIFS share which contains it.

At this point I have two Musical Sources entries in the Library Config panel: OMV-SMB (the friendly name I gave the true share) with a green checkmark and OMB-test (the friendly name I gave the not true share) with a red X.

What had been puzzling me was the mount error number 2 because in all the Samba testing with intentional faults I've done over the past few years I never got that particular error number---6, 13, 15, 95, 115, etc., sure, but not 2. Now I know it's because I never tried to abuse Samba this particular way before!

Regards,
Kent
Reply


Messages In This Thread
RE: Library build problem with my Audiophonics ES09038q2m RaspTouch - by TheOldPresbyope - 12-04-2019, 06:53 PM

Forum Jump: