Thank you for your donation!


Solved: Problem playing High Rez File
#11
(12-11-2019, 05:04 AM)DRONE7 Wrote:
Quote:(my boss used to accuse me of always wanting to eat my desert first!)

Gobi or Sahara ?

You have earthier tastes or better dentition than I... Big Grin

I'd like to say this was a result of my "dry" humor but in truth I was just tired  Tongue
Reply
#12
@Facel

If you are curious about the actual negotiated configuration of your Ethernet interface, you could try this from the command line

Code:
pi@moode4b:~ $ ethtool eth0
Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Half 1000baseT/Full
    Supported pause frame use: Symmetric Receive-only
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Half 1000baseT/Full
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                         100baseT/Half 100baseT/Full
                                         1000baseT/Half 1000baseT/Full
    Link partner advertised pause frame use: Symmetric Receive-only
    Link partner advertised auto-negotiation: Yes
    Link partner advertised FEC modes: Not reported
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
    Current message level: 0x00000007 (7)
                   drv probe link
    Link detected: yes

This tells a lot about the capabilities of the interface hardware and driver. Note the Speed: and Duplex: lines. They describe my current connection.

Also, you can try

Code:
pi@moode4b:~ $ ifconfig eth0
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       inet 192.168.1.174  netmask 255.255.255.0  broadcast 192.168.1.255
       inet6 fe80::7ca3:e9ee:ee53:53f2  prefixlen 64  scopeid 0x20<link>
       ether dc:a6:32:0e:e6:25  txqueuelen 1000  (Ethernet)
       RX packets 4747  bytes 563750 (550.5 KiB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 1724  bytes 1773130 (1.6 MiB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

You should see all zeros on the RX errors/TX errors lines. (Don't know what your JRMC is running on but you could try the equivalent command on that host too.)

Regards,
Kent
Reply
#13
(12-11-2019, 12:55 PM)Tim Curtis Wrote: The "64-bit" not listed in dropdown for kernel arch is a bug thats fixed in upcoming 6.4.1. update

Code:
- FIX: 64-bit kernel not listed in dropdown if USBridge SIG

If swapping in the USBridge, which uses a different Ethernet chipset than the SIG, fixes the problem it would suggest a possible compatibility issue between the SIG's Ethernet chipset / driver and the Switch. 

Maybe when the switch and the SIG auto-negotiate the connection it ends up being only half-duplex or something like that.

One option is to switch to the Comfast WiFi adapter and use the 5gHz band :-)

Thanks Tim for your feedback
I prefer to stick to RJ45 Ethernet.

As your 6.3 version  added  "NEW: Support for Allo USBridge SIG including enhanced Eth driver"  do you see a way to check if it could be a harware
failure on th sig ?

do you have any availability date for the 6.4.1 version ?
Reply
#14
(12-11-2019, 01:47 PM)TheOldPresbyope Wrote: @Facel

If you are curious about the actual negotiated configuration of your Ethernet interface, you could try this from the command line

Sorry TheOldPresbyope I did not see your post ...(it is not a joke)

Here is my result

Code:
pi@moode:~ $ ethtool eth0
Settings for eth0:
       Supported ports: [ TP MII ]
       Supported link modes:   10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Half 1000baseT/Full
       Supported pause frame use: No
       Supports auto-negotiation: Yes
       Supported FEC modes: Not reported
       Advertised link modes:  10baseT/Half 10baseT/Full
                               100baseT/Half 100baseT/Full
                               1000baseT/Full
       Advertised pause frame use: Symmetric
       Advertised auto-negotiation: Yes
       Advertised FEC modes: Not reported
       Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                            100baseT/Half 100baseT/Full
       Link partner advertised pause frame use: Symmetric
       Link partner advertised auto-negotiation: Yes
       Link partner advertised FEC modes: Not reported
       Speed: 100Mb/s
       Duplex: Full
       Port: MII
       PHYAD: 3
       Transceiver: internal
       Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
       Current message level: 0x00007fff (32767)
                              drv probe link timer ifdown ifup rx_err tx_err tx              _queued intr tx_done rx_status pktdata hw wol
       Link detected: yes



and also

Code:
pi@moode:~ $ ifconfig eth0
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       inet 192.168.1.45  netmask 255.255.255.0  broadcast 192.168.1.255
       inet6 2a01:e35:2e98:99e0:d15e:38d9:9e7e:b7bf  prefixlen 64  scopeid 0x0<global>
       inet6 fe80::be80:82c3:20f6:ecde  prefixlen 64  scopeid 0x20<link>
       ether 00:17:f7:00:a8:66  txqueuelen 1000  (Ethernet)
       RX packets 1246  bytes 400682 (391.2 KiB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 834  bytes 480017 (468.7 KiB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Reply
#15
I have made the update for The "64-bit" not listed in dropdown for kernel arch is a bug thats fixed in upcoming 6.4.1. and it seems to solve the problem ...

Nevertheless, after : "sudo sed -i 's/Pi-CM3+ Lite/CM3+ Lite/' /var/www/inc/playerlib.php" I can choose 64 bit in the combo box ....
after reboot => the 64 bit does not appears anymore in the combo box but my problem with playing high rez files has desappeared !!!

I steel need to check that there is no other glitch regarding audio ...
Reply
#16
This is a bug - "after reboot => the 64 bit does not appears anymore in the combo box".

Fixed for upcoming 6.4.1 update :-)
Reply
#17
@Facel

Glad to hear your problem has disappeared. At this point, I don't know why it disappeared any more than I know why it existed to begin with Undecided

The network interface info you posted seems ok. Good speed, full duplex, no dropped packets.

I started my test with the 64-bit kernel only because I'd already chosen it for a different test. Using the test configuration described previously, there's no difference between using the 32-bit kernel and the 64-bit kernel when I play 24-bit/192KHz FLAC tracks. It just works™. 

Borrowing Tim's byline, enjoy the music!

Regards,
Kent
Reply
#18
(12-12-2019, 04:08 PM)TheOldPresbyope Wrote: I started my test with the 64-bit kernel only because I'd already chosen it for a different test. Using the test configuration described previously, there's no difference between using the 32-bit kernel and the 64-bit kernel when I play 24-bit/192KHz FLAC tracks. It just works™. 

Borrowing Tim's byline, enjoy the music!

Regards,
Kent

 Sure but you do not have a USBridge Sig iin your configuration for testing ...
Reply
#19
I initially had a few lines about that very point but deleted them because it seemed presumptive to speculate about hardware (and whatever software mods it requires) I don't have. Good luck.
Reply
#20
You can speculate about the hardware (that's what I do)
The USBridge sig is using a Rasberry Compute Module connected to an Allo card. This Allo card has the Ethernet + USB (clean) connectors ...+ other USB

Now the audio is not jerky anymore BUT the audio is not as good as it should be... There are some scratch noises (as if I was listening to some bad vinyl, or bad radio station ...) this occurs mostly when selecting a new song, and from now and then during playing (even on 44 Kh files). (FYI I had the same results with Volumio)
To me the hardware/drivers are very probably involved.
Reply


Forum Jump: