Thank you for your donation!


Problem: Can't hear any sound setting MPD SoX compansating Kernel bug
#1
So today I installed MoOde on my Raspberry and I'm thrilled by the design of it and how it looks Smile . After enjoying a 1st song, I tried another MP3 song and I've encountered the horrible white noise issue as described here:

http://moodeaudio.org/forum/showthread.p...ight=noise

And so I've applied the workaround suggested in the 2nd message and the loud white noise was gone. However, I can hear no sound at all now.

I'm using Raspberry Pi 3 with Allo Piano 2.1 DAC and the Kali reclocker.

Here are my current Audio configuration parameters:


Code:
Audio device        = Allo Piano 2.1 Hi-Fi DAC
Interface        = I2S
Mixer name        = Master
Hardware volume        = Controller detected
Max ALSA volume        = 100
Audio source        = Local
Output device        = Local
Resume MPD        = No
Volume knob        = 0
Volume mute        = Unmuted
Saved MPD vol        = 0
Preamp volume        = 0
ALSA version        = 1.1.8-1+rpt1
SoX version        = 0.1.2-3

Bluetooth controller    = Off
Pairing agent        = Off
Airplay receiver    = Off
Spotify receiver    = Off
Squeezelite        = Off
UPnP client        = Off
DLNA server        = Off
GPIO button handler    = Off
UPnP browser        = Off

Auto-shuffle        = Off
Autoplay        = Off
Rotary encoder        = Off
Encoder params        = 100 2 3 23 24
Polarity inversion    = Off
Crossfeed        = Off
Crossfade        = Off
Parametric EQ        = Off
Graphic EQ        = Off
MPD httpd        = Off


And the MPD settings:


Code:
Version            = 0.21.16
Volume control        = software
ALSA device        = hw:0
SoX resampling        = 192000:32:2
SoX quality        = very high
SoX multithreading    = off
DSD over PCM (DoP)    = no
Replaygain        = off
Replaygain preamp    = 0
Volume normalization    = No
Audio buffer        = 4096 (kb)
Output buffer size    = 131072 (kb)


I tried other bitrates for the SoX resampling and they didn't work...

I hope I've given enough information in order for this to be debugged. Thanks in advance.
Reply
#2
While the song is playing post the contents of the Audio info screen plus the command below.

Code:
/var/www/command/util.sh get-alsavol Master
Reply
#3
(12-12-2019, 06:49 PM)doronbehar Wrote: So today I installed MoOde on my Raspberry and I'm thrilled by the design of it and how it looks Smile . After enjoying a 1st song, I tried another MP3 song and I've encountered the horrible white noise issue as described here:

http://moodeaudio.org/forum/showthread.p...ight=noise

And so I've applied the workaround suggested in the 2nd message and the loud white noise was gone. However, I can hear no sound at all now.

I'm using Raspberry Pi 3 with Allo Piano 2.1 DAC and the Kali reclocker.

...

I tried other bitrates for the SoX resampling and they didn't work...

I hope I've given enough information in order for this to be debugged. Thanks in advance.


Go ahead and do what Tim asked, but I have a background observation.

The specific post you cite describes a workaround for a kernel bug which prevents the Allo product from reproducing audio sampled at 24-bit depth. The workaround consists of padding each 3-byte sample (=24 bits) to a length of 4 bytes (=32 bits). Technically this isn't resampling since all the existing bits stay the same.

But you said "another MP3 song." That's not 24-bit audio. Indeed, since MP3 is a lossy compression technique, it's difficult to assign a notion of a bit depth to MP3-encoded material. If MP3 is the problem then the workaround would not seem to be the answer.

How about looking at both songs---the one that plays and the one that fails to play?

Regards,
Kent
Reply
#4
Thanks for your quick replies guys, I hoped I'll get email notifications but I didn't hence I'm replying only now.

@TheOldPresbyope I got confused when I was writing the post in regard to the MP3/flac issue: Originally, before setting SoX in MPD, playing a flac file worked fine but an MP3 file produced the noise issue. Now, as I said, no sound is heard at all.

@Tim Curtis, While playing both the Flac and MP3 files, the command you posted says:

Code:
pi@moode:~ $ /var/www/command/util.sh get-alsavol Master
100%

For the Flac file which used to play when SoX was disabled, the audio info says:

16/44.1 FLAC

And for the MP3 file which produced the noise when SoX was disabled:


44.1 MPEG Audio
Reply
#5
BTW @Tim Curtis while thinking more over this, was it ever considered to downgrade the kernel in order to mitigate this bug? I noticed there's the 4.0.9 kernel branch which we could use instead of the current 4.14 branch. WDYT?
Reply
#6
The file that shows as "44.1 MPEG Audio" in Audio info probably can't be decoded correctly by MPD/FFMPEG. Errors might show up in the MPD log but not something I can fix.

Do u mean the Kali 24-bit noise bug?

moOde 6 series is based on Raspbian Buster (10.0 and higher) which requires the 4.19.y kernel branch. Not possible to downgrade kernel.
Reply
#7
Quote:The file that shows as "44.1 MPEG Audio" in Audio info probably can't be decoded correctly by MPD/FFMPEG. Errors might show up in the MPD log but not something I can fix.

That's impossible. With MPD installed here on my PC, I can hear all of my music library just fine. My MoOde installation mounts these files via Samba. Please @Tim Curtis, this couldn't be the reason for MPD to fail playing those files. Could you please take a look at the settings I've posted in my initial post? There must be something wrong there...
Reply
#8
Is your PC version the same as moOde version 0.21.16?
What does the MPD log show when trying to play the file?
Reply
#9
The log is empty when I press to play either of these files. I can hear a small noise when doing so but no sound comes out. I can also the blue and red* LEDS on the board blink during the play.

EDIT: typo in red
Reply
#10
Quote:Is your PC version the same as moOde version 0.21.16?

No. My PC's distro is NixOS and it's MPD is compiled with most decoders / features, see this list.
Reply


Forum Jump: