Thank you for your donation!


Validating software/hardware configuration
#1
Hi,

I am new to the RP3B+ audio field but have had many years experience with stereo and computers, so I though it might be relatively straightforward to setup a server for my 500+ CDs. My system is as follows:

RP3B+
Allo Digione HAT
Coax out from Digione to Schiit Mode 3
Analog from Schiit to preamp
Moode OS

Configuration of the system seemed to go ok, wireless is working fine, but Moode would not recognize my FAT32 USB. I made an exFAT drive and put an mp3 and a flac file and moode mounted it fine. The files appear to play, but I hear no sound. I validated the coax and Schiit DAC by putting using my CD player as a source so I know that part of the chain works. 

The moode audio player seems to be working ok however how do I validate the digione? 

I am very rusty(!) with Linux and I do not know how to find files on the MiniSD card apart for communicating via the browser. Is there a way of accessing configuration files not via moode?

Thanks everyone in advance for the help. Noob who like great sound and wants a simple, but good sounding, streamer!
Reply
#2
The symptom "The files appear to play, but I hear no sound." suggests a volume configuration issue.

Reboot and then post the contents of System info.
Menu, Configure, System
Menu, System info
Reply
#3
(01-04-2020, 11:00 PM)Tim Curtis Wrote: The symptom "The files appear to play, but I hear no sound." suggests a volume configuration issue.

Reboot and then post the contents of System info.
Menu, Configure, System
Menu, System info

Tim,

Thanks for the rapid response. Here is my System Info:


S Y S T E M   P A R A M E T E R S

moOde release = 6.4.0 2019-11-24
Raspbian OS = 10.2
Linux kernel = 4.19.83-v7+ #1277
Platform = Pi-3B+ 1GB v1.3
Architecture = armv7l (32-bit)
System uptime = up 6 minutes
Timezone = America/Chicago
Current time = 2020-01-04 17:40:25

Host name = moode
Ethernet address = unassigned
Ethernet MAC = b8:27:eb:60:61:07
WLAN address = 192.168.1.204
WLAN MAC = b8:27:eb:35:34:52
WLAN country = US

SoC identifier = bcm2837
Core count = 4
Kernel timer freq = 100 Hz
SDCard freq = 50 MHz
USB boot = enabled
Warranty = OK

Root size = 3.4G
Root used = 79%
Root available = 696M
Root expand = not expanded
Memory free = 678 MB
Memory used = 88 MB
SoC temperature = 42.4°C

CPU governor = ondemand
Onboard WiFi = On
Onboard BT = Off
HDMI output = Off
Eth addr wait = On
Max USB current = Off
USB (UAC2) fix = Off
Pi-3B+ eth fix = Off
SSH term server = Off

PHP-FPM version = 7.3.11
NGINX version = 1.14.2
SQLite3 version = 3.27.2
Hostapd version = 2.8-devel
WiringPi version = 2.50
RPi.GPIO version = 0.7.0

A U D I O   P A R A M E T E R S

Audio device = Allo DigiOne
Interface = I2S
Mixer name = Digital
Hardware volume = None
Max ALSA volume = 100
Audio source = Local
Output device = Local
Resume MPD = No
Volume knob = 79
Volume mute = Unmuted
Saved MPD vol = 0
Preamp volume = 0
ALSA version = 1.1.8-1+rpt1
SoX version = 0.1.2-3

Bluetooth controller = Off
Pairing agent = Off
Airplay receiver = Off
Spotify receiver = Off
Squeezelite = Off
UPnP client = Off
DLNA server = Off
GPIO button handler = Off
UPnP browser = Off

Auto-shuffle = Off
Autoplay = Off
Rotary encoder = Off
Encoder params = 100 2 3 23 24
Polarity inversion = Off
Crossfeed = Off
Crossfade = Off
Parametric EQ = Off
Graphic EQ = Off
MPD httpd = Off

A P P E A R A N C E   S E T T I N G S

Theme = Default
Accent color = Emerald
Alpha blend = 1.0
Adaptive background = No
Background image = No
Cover backdrop = No
Cover blur = 20px
Cover scale = 1.25
CoverView auto-display = Never
CoverView style = Animated
Auto-shuffle filter = None
Extra metadata = Yes
Playback history = No

L I B R A R Y   S E T T I N G S

Instant play action = Clear/Play
Show genres column = Yes
Album grouping = by Artist
Compilation identifier = Various Artists
Recently added = 1 Month
Ignore articles = a,an,the
UTF8 character filter = No
Hi-res thumbs = Auto
Cover search pri = Embedded cover
Pixel ratio = 2

M P D   S E T T I N G S

Version = 0.21.16
Volume control = software
ALSA device = hw:0
SoX resampling = disabled
SoX quality = very high
SoX multithreading = off
DSD over PCM (DoP) = no
Replaygain = off
Replaygain preamp = 0
Volume normalization = No
Audio buffer = 4096 (kb)
Output buffer size = 131072 (kb)

B L U E T O O T H   S E T T I N G S

Bluetooth ver = 5.50
Bluealsa ver = 2.0.0
Speaker sharing = No
Resume MPD = No
PCM buffer time = 500000 (µs)

A I R P L A Y   S E T T I N G S

Version = 3.3.5
Friendly name = Moode Airplay
ALSA device = hw:0
Interpolation = soxr
Output bit depth = S16
Output sample rate = 44100
Session interruption = no
Session timeout = 120 (ms)
Latency offset = 0.0 (secs)
Audio buffer = 0.2 (secs)
Resume MPD = No

S P O T I F Y   S E T T I N G S

Friendly name = Moode Spotify
ALSA device = plughw:0
Bit rate = 160
Initial volume = 0
Volume curve = Logarithmic
Volume normalization = No
Normalization pregain = 0
Resume MPD = No

S Q U E E Z E L I T E   S E T T I N G S

Version = 1.8.7-1052 "DSD/SRC enabled"
Friendly name = Moode
ALSA device = hw:0
ALSA params = 80:4::1
Output buffers = 40000:100000
Task priority = 45
Codec list = flac,pcm,mp3,ogg,aac,alac,dsd
Other options = -W -D 500 -R E -S /var/local
Resume MPD = No

L O C A L   D I S P L A Y   S E T T I N G S

Local UI display = Off
Mouse cursor = On
Screen blank = 600 Secs
Wake display on play = Off
Brightness = 255
Pixel aspect ratio = Default
Rotate screen = 0 Deg

M O O D E   S T A R T U P   L O G

20200104 172536 worker: -- Start
20200104 172536 worker: Successfully daemonized
20200104 172536 worker: Integrity check (passed)
20200104 172536 worker: Session loaded
20200104 172536 worker: Debug logging (off)
20200104 172536 worker: Device raw: Card0 (ALSA) | Card1 () | I2Sdev (Allo DigiOne)
20200104 172536 worker: Device cfg: Name (Allo DigiOne) | Card (0) | MPDdev (0) | Mixer (Digital) | Alsavol: (none)
20200104 172536 worker: ALSA volume (None)
20200104 172536 worker: -- System
20200104 172538 worker: Host name     (moode)
20200104 172538 worker: moOde release (6.4.0 2019-11-24)
20200104 172538 worker: Raspbian OS   (10.2)
20200104 172538 worker: Linux kernel  (4.19.83-v7+ #1277)
20200104 172538 worker: Platform      (Pi-3B+ 1GB v1.3)
20200104 172538 worker: Architecture  (armv7l)
20200104 172538 worker: MPD version   (0.21.16)
20200104 172538 worker: CPU governor  (ondemand)
20200104 172538 worker: USB boot enabled
20200104 172538 worker: File system not expanded yet
20200104 172538 worker: HDMI port off
20200104 172539 worker: File check (OK)
20200104 172539 worker: -- Network
20200104 172539 worker: eth0 exists
20200104 172539 worker: eth0 wait 0 for IP address
20200104 172542 worker: eth0 wait 1 for IP address
20200104 172545 worker: eth0 wait 2 for IP address
20200104 172548 worker: eth0 wait 3 for IP address
20200104 172552 worker: eth0 wait 4 for IP address
20200104 173428 worker: eth0 address not assigned
20200104 173428 worker: wlan0 exists
20200104 173428 worker: wifi country (US)
20200104 173428 worker: wlan0 trying SSID (PPLAN2)
20200104 173428 worker: IP addr (192.168.1.204)
20200104 173428 worker: Netmask (255.255.255.0)
20200104 173428 worker: Gateway (192.168.1.254)
20200104 173428 worker: Pri DNS (192.168.1.254)
20200104 173428 worker: Domain  (attlocal.net)
20200104 173428 worker: -- Audio
20200104 173428 worker: ALSA outputs unmuted
20200104 173428 worker: ALSA card number (0)
20200104 173428 worker: Audio output (I2S audio device)
20200104 173428 worker: Audio device (Allo DigiOne)
20200104 173429 worker: Audio formats (U8, S16_LE)
20200104 173429 worker: ALSA mixer name (Digital)
20200104 173429 worker: MPD volume control (software)
20200104 173429 worker: Hdwr volume controller not detected
20200104 173429 worker: -- Services
20200104 173429 worker: Reset renderer active state
20200104 173430 worker: MPD conf updated
20200104 173430 worker: MPD started
20200104 173430 worker: MPD accepting connections
20200104 173430 worker: Configure MPD outputs
20200104 173430 worker: MPD output 1 ALSA default (on)
20200104 173430 worker: MPD output 2 ALSA crossfeed (off)
20200104 173430 worker: MPD output 3 ALSA parametric eq (off)
20200104 173430 worker: MPD output 4 ALSA graphic eq (off)
20200104 173430 worker: MPD output 5 ALSA polarity inversion (off)
20200104 173430 worker: MPD output 6 ALSA bluetooth (off)
20200104 173430 worker: MPD output 7 HTTP stream (off)
20200104 173430 worker: MPD crossfade (off)
20200104 173430 worker: Audio source (Local)
20200104 173430 worker: Output device (Local)
20200104 173430 worker: USB auto-mounter (udisks-glue)
20200104 173430 worker: -- Music sources
20200104 173431 worker: USB source (STORE N GO)
20200104 173431 worker: NAS and UPnP sources (mountall initiated)
20200104 173431 worker: -- Miscellaneous
20200104 173431 worker: Saved MPD vol level (0)
20200104 173431 worker: Preamp volume level (0)
20200104 173431 worker: MPD volume level (79) restored
20200104 173431 worker: ALSA volume level (None)
20200104 173431 worker: Auto-play (Off)
20200104 173431 worker: Maintenance interval (6 hrs)
20200104 173431 worker: Screen saver activation (Never)
20200104 173431 worker: Session permissions (OK)
20200104 173431 worker: Watchdog started
20200104 173431 worker: Ready
20200104 173431 watchdog: INFO Audio output is (closed)

Thanks!

Phil
Reply
#4
Nothing obvious to me except possibly the raw device name of "ALSA" for Card0. Normally this name indicates the on-board Pi audio device.

Code:
20200104 172536 worker: Device raw: Card0 (ALSA) | Card1 () | I2Sdev (Allo DigiOne)

I don't have one of these boards so maybe post the output of the cmd below and see if another user with a Digione gets same result.

Code:
aplay -l
Reply
#5
(01-05-2020, 12:50 PM)Tim Curtis Wrote: Nothing obvious to me except possibly the raw device name of "ALSA" for Card0. Normally this name indicates the on-board Pi audio device.

Code:
20200104 172536 worker: Device raw: Card0 (ALSA) | Card1 () | I2Sdev (Allo DigiOne)

I don't have one of these boards so maybe post the output of the cmd below and see if another user with a Digione gets same result.

Code:
aplay -l
Tim,

Thanks!

Stupid question. How do I access the command line prompt for my RP3B+when accessing via a browser?

Thanks,

Phil
Reply
#6
@p2potter

Hi, Phil.

One accesses the moOde command line via ssh. You can take advantage of moOde's built-in SSH term server (go to m>config>system, enable SSH term server and then open the Web SSH terminal) or by ssh'ing to moOde from another computer. Use username: pi, password: moodeaudio.

For most folks using ssh is easier if working from a desktop or laptop with a real keyboard than from a tablet or phone.

Regards,
Kent
Reply
#7
@p2potter

To follow up on Tim's response, here's what I get with an I2S HiFiBerry DAC+ HAT attached to an RPi3B+

Code:
20200105 105635 worker: Device raw: Card0 (sndrpihifiberry) | Card1 () | I2Sdev (HiFiBerry DAC+)


If instead I use moOde with a USB DAC (here, a USB-BT device named "W2")  I get

Code:
20191227 103832 worker: Device raw: Card0 (ALSA) | Card1 (W2) | I2Sdev (none)


As for aplay, here's the output with the HiFiBerry DAC+

Code:
pi@moode:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 [HiFiBerry DAC+ HiFi pcm512x-hifi-0]
 Subdevices: 1/1
 Subdevice #0: subdevice #0


In your OP you had a second issue,

Quote:Moode would not recognize my FAT32 USB.


FAT32-formatted drives are perfectly acceptable to moOde. I'm playing a test file from one now (a 256MB ! thumbdrive from back in the day).

I'm going to assume you mean you didn't see, e.g., the drive in the Folder view. Keep in mind that the Folder view is not a file manager view. It is MPD's view of its music resources. For your drive to show up, two conditions have to be met. The drive has to contain music files and the drive has to have been scanned by MPD in a library re-gen or update operation.

Regards,
Kent
Reply
#8
Guys,

Sorry for the late response (couple of busy days at work). Here is the data I received from aplay. I do not see any reference to the Digione, but not sure exactly what to expect!


**** List of PLAYBACK Hadware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
   Subdevices 7/7
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
   Subdevice #2: subdevice #2
   Subdevice #3: subdevice #3
   Subdevice #4: subdevice #4
   Subdevice #5: subdevice #5
   Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI  [bcm2835 IEC958/HDMI]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI  [bcm2835 IEC958/HDMI]
   Subdevices: 1/1
   Subdevice #0: subdevice #0


Thanks,

Phil
Reply
#9
(01-06-2020, 11:28 PM)P p2potter Wrote: Guys,

I though I would check another OS player to see if it was a hardware or software issue. So I downloaded Volumino and after a very rapid setup procedure, I now have sound. I have no idea why moOde does not recognize the digione, and while I would love to get this software working, its hard to give up something that is generating sound!!

Ant clues on what I can do to get moOde, in the mood?

thanks,


Phil
Reply
#10
(01-06-2020, 11:28 PM)p2potter Wrote: Guys,

Sorry for the late response (couple of busy days at work). Here is the data I received from aplay. I do not see any reference to the Digione, but not sure exactly what to expect!


**** List of PLAYBACK Hadware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
   Subdevices 7/7
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
   Subdevice #2: subdevice #2
   Subdevice #3: subdevice #3
   Subdevice #4: subdevice #4
   Subdevice #5: subdevice #5
   Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI  [bcm2835 IEC958/HDMI]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI  [bcm2835 IEC958/HDMI]
   Subdevices: 1/1
   Subdevice #0: subdevice #0


Thanks,

Phil


This is the output I would expect when you have not selected your I2S device (e.g., setting "None") in Audio Config.

Regards,
Kent
Reply


Forum Jump: