Thank you for your donation!


file for older installation
#1
Hello
when i do download the newest version i got a file like
rxxx-iso.zip

if i wish to install a older version
https://moodeaudio.org/docs/SOURCES.html

there are 6 files now, which should i take?
the moOde 5.3.1 Build Recipe v2.10

have a nice day
vinc
Raspberry Pi3B+ --> HiFiBerry DAC+ PRO --> Cyrus | Pre - Pre Amplifier --> D. Klimo | Kent monoblocks --> Piega | Piega LDR 8.2
Reply
#2
The ISO images are hosted in moOde Git repo, releases.
https://github.com/moode-player/moode
Reply
#3
Hello @Tim Curtis
thanks for the fast feedback
will try it - again with the older version...
Raspberry Pi3B+ --> HiFiBerry DAC+ PRO --> Cyrus | Pre - Pre Amplifier --> D. Klimo | Kent monoblocks --> Piega | Piega LDR 8.2
Reply
#4
Strange Strange
i can't install / run moode anymore also older version works not any more!
when it boot it boots in WIFI AP mode - do a scan select ssid add password change country - save do a reboot!

then it boots and fast i could ping the dhcp ip of the Pi!
As soon it is ready there - i loos the ping ip paket.
The Pi is back in AP Moode…
Check the config the ssid and correct password are there!

so just installed a Pi Debian lite, the connection is there and never lost again. also doing large update all without Problems.

so what could be the reason MoodeAudio Always go back to AP Mode???

have a nice day
vinc
Raspberry Pi3B+ --> HiFiBerry DAC+ PRO --> Cyrus | Pre - Pre Amplifier --> D. Klimo | Kent monoblocks --> Piega | Piega LDR 8.2
Reply
#5
Hello
would it possible to install moodeAudio on a Raspbian (Debian10)? Not using the image, but doing some
apt install -y xxx (what would be needed)

have a nice day
vinc
Raspberry Pi3B+ --> HiFiBerry DAC+ PRO --> Cyrus | Pre - Pre Amplifier --> D. Klimo | Kent monoblocks --> Piega | Piega LDR 8.2
Reply
#6
(01-14-2020, 08:10 AM)vikozo Wrote: Hello
would it possible to install moodeAudio on a Raspbian (Debian10)? Not using the image, but doing some
apt install -y xxx (what would be needed)

have a nice day
vinc


moOde is built, not installed, on a fresh copy of Raspbian by following the multi-step build recipe.

Regards,
Kent
Reply
#7
(01-13-2020, 11:25 AM)vikozo Wrote: Strange Strange
i can't install / run moode anymore also older version works not any more!
when it boot it boots in WIFI AP mode - do a scan select ssid add password change country - save do a reboot!

then it boots and fast i could ping the dhcp ip of the Pi!
As soon it is ready there - i loos the ping ip paket.
The Pi is back in AP Moode…
Check the config the ssid and correct password are there!
...

Hi, vinc.

I haven't looked at the networking part of the moOde codebase in a long time so I'm not going to speculate.

How about giving some more details---

First, check that this is happening with a default moOde installation, e.g., with no changes except for configuring the network interface. Assuming it does, then when it reboots after making this change, does it stay in WiFi client mode long enough for you to see the Web UI?

How do you ping the DHCP IP of the PI? By invoking "ping moode"? By default ping repeats at 1 second intervals. If you start pinging at the same time you reboot the player, you'll see a succession of "Host Unreachable" lines before it begins reporting successful pings. How many times does the ping succeed? Here's a snippet of the output when I ping a booting moOde player from a Linux laptop:

Code:
kreed@T520 ~ $ ping moodelr
PING moodeLR.fios-router.home (192.168.1.198) 56(84) bytes of data.
...lines with increasing icmp_seq numbers...
From 192.168.1.188 icmp_seq=42 Destination Host Unreachable
64 bytes from 192.168.1.198: icmp_seq=43 ttl=64 time=733 ms
64 bytes from 192.168.1.198: icmp_seq=44 ttl=64 time=34.0 ms
64 bytes from 192.168.1.198: icmp_seq=45 ttl=64 time=4.20 ms
...more lines until I kill the process with ^C...


When moOde reverts to AP mode, SSH back in and have a look at the logs. In /var/log/moode.log you'll see initial entries like the following as it connects in WiFi client mode (where I have not turned off "wait for eth0 address" in System Config):

Code:
20200114 072836 worker: -- Network
20200114 072836 worker: eth0 exists
20200114 072836 worker: eth0 wait 0 for IP address
20200114 072839 worker: eth0 wait 1 for IP address
20200114 072842 worker: eth0 wait 2 for IP address
20200114 072845 worker: eth0 wait 3 for IP address
20200114 072857 worker: eth0 wait 4 for IP address
20200114 072900 worker: eth0 address not assigned
20200114 072901 worker: wlan0 exists
20200114 072901 worker: wifi country (US)
20200114 072901 worker: wlan0 trying SSID (xxxxxxx)
20200114 072901 worker: IP addr (192.168.1.198)
20200114 072901 worker: Netmask (255.255.255.0)
20200114 072901 worker: Gateway (192.168.1.1)
20200114 072901 worker: Pri DNS (192.168.1.1)
20200114 072901 worker: Domain  (yyyyyyy)


Do you see any later lines in moode.log relating to the network interface?

How about network-related entries in /var/log/syslog?

Regards,
Kent

PS - unmodified Raspbian does not include the hostapd code and is not configured to use it so it can't exhibit the same behavior.
Reply
#8
@TheOldPresbyope
Thanks for your feedback.

I took the newest img i got - "install" it to my Raspberry Pi 3b+
i know the MAC Address my DHCP Server give allways the same IP Adresse to it!
it start in a first step!
- Login with my IPAD - go to network settings
- do a ssid scan
- select the ssid needed and add the password (Yes i am sure it is correct because it is simple)
- i also change the country to Switzerland
- i press save
- it ask for a reboot - i do so
- as soon it reboots i start pinging and after a while i got th respond below 7ms all the time
- then when finish booting and loading Moodeaudio - the ping are lost from the PC i have
- back to my IPAD i found the ssid moode do enter go to network setting - the information are still there
- rescan reselect readd the password - ask for reboot i do so

have a nice day
vinc
Raspberry Pi3B+ --> HiFiBerry DAC+ PRO --> Cyrus | Pre - Pre Amplifier --> D. Klimo | Kent monoblocks --> Piega | Piega LDR 8.2
Reply
#9
@TheOldPresbyope

i will try it with this link
moOde is built, not installed, on a fresh copy of Raspbian by following the multi-step build recipe.
Raspberry Pi3B+ --> HiFiBerry DAC+ PRO --> Cyrus | Pre - Pre Amplifier --> D. Klimo | Kent monoblocks --> Piega | Piega LDR 8.2
Reply
#10
(01-14-2020, 02:56 PM)vikozo Wrote: @TheOldPresbyope

i will try it with this link
moOde is built, not installed, on a fresh copy of Raspbian by following the multi-step build recipe.



Are you sure you want/need to do this? It's a lot of work and once the build recipe is complete you have exactly the same moOde player as the one Tim distributes as an image file.

If you have only an iPad available to communicate with the moOde player then reviewing the logs will be tedious.

Your signature line says:

Quote:Raspberry Pi3B+ --> HiFiBerry DAC+ PRO

Are you trying to connect to the AP on the 2.4GHz band using the Pi's onboard WiFi transceiver? IIRC, there was a problem with signal interference from early HiFiBerry DAC+ Pro boards. It's possible that's an issue here.

Simple test: remove the DAC and reboot. Is the connection now solid? Then the DAC is the problem.

Possible mitigation strategies: change to a different DAC; connect on the 5GHz band; switch to an external USB-WiFi adapter, preferably on a USB extender cable to get it away from the DAC.

Regards,
Kent
Reply


Forum Jump: