Thank you for your donation!


Problem: Audio injector sound card. Anyone could get it running ?
#1
Hi you all

Moode+Raspberry have changed my musical life.
However, until now, i could get the audio injector sound carte running.

I've tried with a PI+DAC+Audio injector and now another PI (A+) + Audio injector only. But in the confg/audio/I2s there is still no audio injector choice available.

(i''ve tried also with a tutorial for Volumio, and my DAC couldn't work at all).

Ideas ?
.
Reply
#2
(01-12-2020, 02:29 PM)Maitresinh Wrote: Hi you all

Moode+Raspberry have changed my musical life.
However, until now, i could get the audio injector sound carte running.

I've tried with a PI+DAC+Audio injector and now another PI (A+) + Audio injector only. But in the confg/audio/I2s there is still no audio injector choice available.

(i''ve tried also with a tutorial for Volumio, and my DAC couldn't work at all).

Ideas ?
.

First time I've heard of Audio Injector. A quick search reveals they make several different cards. They refer users to https://github.com/Audio-Injector for information and discussion.

Looking at /boot/overlays on a moOde 6.4.0 player, I see three Audio Injector-related files are included in Raspbian:

Code:
audioinjector-addons.dtbo
audioinjector-ultra.dtbo
audioinjector-wm8731-audio.dtbo


No doubt Tim  will need more information before adding Audio Injector to the list of supported cards. In the meantime, you can try manually editing your /boot/config.txt file to load the appropriate overlay for your card. Consult their github site to find out which as well as to find out if other adjustments are necessary.

Regards,
Kent
Reply
#3
Thank you so much for your (quick) answer Kent.

Mine is the "normal" stereo card
https://github.com/Audio-Injector/stereo-and-zero

I wanted to use my moode-pi as an ampli, in order to add a vinyl player

Anyway

1/ I put my sd card into my computer
2/i access to the /boot/config.text
3/ i just add

dtoverlay=audioinjector-wm8731-audio



Is that correct ?
Reply
#4
@Maitresinh

From https://github.com/Audio-Injector/stereo-and-zero

Quote:Manual setup method
  • <<don't do the update shown in this first step>>
  • Make sure the default audio device tree is not loaded for PWM output (/boot/config.txt), this is because it uses the same I2S bus. (Comment out dtparam=audio=on)
  • Make sure the Audio Injector device tree is loaded at boot time : dtoverlay=audioinjector-wm8731-audio
  • Reboot to force the correct device tree to load

where I deleted their first step.

Try it and see. The worst that can happen is it doesn't work. Save the existing /boot/config.txt file so you can restore it if need be. (IIRC, moOde will recreate it when you do a new configuration but why tempt fate?)

Regards,
Kent
Reply
#5
Ok, i'm trying.

edit : juste before i've tried to download the package https://github.com/Audio-Injector/stereo...-1_all.deb


Once connected to the Pi/moode, i do

wget https://github.com/Audio-Injector/stereo...-1_all.deb


but get
--2020-01-12 16:25:18-- https://github.com/Audio-Injector/stereo...-1_all.deb
Resolving github.com (github.com)... failed: Name or service not known.
wget: unable to resolve host address ‘github.com’
Reply
#6
ok done

here is my config file after edit

-------------
disable_splash=1
disable_overscan=1
hdmi_drive=2
hdmi_blanking=1
#dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=audio=on
dtoverlay=audioinjector-wm8731-audio
#dtoverlay=pi3-disable-wifi
#dtoverlay=pi3-disable-bt

---------------------------------

Rebooted. Moode is running, but there is no new i2s device, at least no "audio injector" one in the list
Reply
#7
@Maitresinh



Downloading that .deb package was not part of the manual setup procedure. I have no idea what's in it.

Sorry, I should not have assumed knowledge on your part. The manual setup has nothing to do with moOde's list of cards. What we're trying to do here is act "as if" moOde already knew about the Audio Injector card.

First, in Audio Config, setup moOde for some I2S audio device. For simplicity, I suggest you select the "Generic-2 I2S (rpi-dac)" device. Reboot.

When I just did this with moOde 6.4.0 on an RPi4B, hostname moodeLR, I see the new config.txt file:


Code:
pi@moodeLR:~ $ more /boot/config.txt
disable_splash=1
disable_overscan=1
hdmi_drive=2
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=audio=off
dtoverlay=rpi-dac
#dtoverlay=pi3-disable-wifi
#dtoverlay=pi3-disable-bt
 
Change* the dtoverlay= line to reflect your overlay name. Reboot. You should be able to start playing music.
Once this works, don't try to change the moOde I2S setting (and ignore what System Info reports is your audio device) or you'll have to do the manual edit again.
Regards,
Kent

*This should be done in moOde via an SSH session
Reply
#8
Thanks a lot. I've done it, now i will try with a sound source in a couple of days and let you know
Reply
#9
(6 hours ago)Maitresinh Wrote: Thanks a lot. I've done it, now i will try with a sound source in a couple of days and let you know

Sometimes I'm confidently wrong(!) so do please let us know.

Regards,
Kent
Reply


Forum Jump: