Thank you for your donation!


Moode eventually unrechable until i reboot...
#11
Here are the logs. My Moode is currently "crashed" (not available at 192.168... but reachable via ssh)

----------------------------------------------------------------------------------

S Y S T E M P A R A M E T E R S

moOde release = 6.4.0 2019-11-24
Raspbian OS = 10.2
Linux kernel = 4.19.83-v7+ #1277
Platform = Pi-3B 1GB v1.2
Architecture = armv7l (32-bit)
System uptime = up 1 day, 3 hours, 27 minutes
Timezone = Europe/Paris
Current time = 2020-01-21 04:47:24

Host name = moode
Ethernet address = 192.168.0.102
Ethernet MAC = b8:27:eb:0c:1b:39
WLAN address = unassigned
WLAN MAC = b8:27:eb:59:4e:6c
WLAN country = FR

SoC identifier = bcm2837
Core count = 4
Kernel timer freq = 100 Hz
SDCard freq = 50 MHz
USB boot = not enabled
Warranty = OK

Root size = 29G
Root used = 10%
Root available = 25G
Root expand = expanded
Memory free = 631 MB
Memory used = 94 MB
SoC temperature = 37.6°C

CPU governor = ondemand
Onboard WiFi = On
Onboard BT = Off
HDMI output = Off
Eth addr wait = On
Max USB current = Off
USB (UAC2) fix = Off
Pi-3B+ eth fix = Off
SSH term server = Off

PHP-FPM version = 7.3.11
NGINX version = 1.14.2
SQLite3 version = 3.27.2
Hostapd version = 2.8-devel
WiringPi version = 2.50
RPi.GPIO version = 0.7.0

A U D I O P A R A M E T E R S

Audio device = IQaudIO Pi-DigiAMP+
Interface = I2S
Mixer name = Digital
Hardware volume = Controller detected
Max ALSA volume = 100
Audio source = Local
Output device = Bluetooth
Resume MPD = No
Volume knob = 42
Volume mute = Unmuted
Saved MPD vol = 0
Preamp volume = 0
ALSA version = 1.1.8-1+rpt1
SoX version = 0.1.2-3

Bluetooth controller = On
Pairing agent = Off
Airplay receiver = Off
Spotify receiver = Off
Squeezelite = Off
UPnP client = Off
DLNA server = Off
GPIO button handler = Off
UPnP browser = Off

Auto-shuffle = Off
Autoplay = Off
Rotary encoder = Off
Encoder params = 100 2 3 23 24
Polarity inversion = Off
Crossfeed = Off
Crossfade = Off
Parametric EQ = Off
Graphic EQ = Off
MPD httpd = Off

A P P E A R A N C E S E T T I N G S

Theme = Pure Black
Accent color = Emerald
Alpha blend = 1.0
Adaptive background = Yes
Background image = Yes
Cover backdrop = Yes
Cover blur = 20px
Cover scale = 1.25
CoverView auto-display = 60
CoverView style = Animated
Auto-shuffle filter = None
Extra metadata = Yes
Playback history = Yes

L I B R A R Y S E T T I N G S

Instant play action = Clear/Play
Show genres column = Yes
Album grouping = by Artist
Compilation identifier = Various Artists, compilation, VA
Recently added = 1 Month
Ignore articles = a,an,the
UTF8 character filter = No
Hi-res thumbs = Auto
Cover search pri = Embedded cover
Pixel ratio = 3

M P D S E T T I N G S

Version = 0.21.16
Volume control = hardware
ALSA device = hw:0
SoX resampling = disabled
SoX quality = very high
SoX multithreading = off
DSD over PCM (DoP) = no
Replaygain = off
Replaygain preamp = 0
Volume normalization = No
Audio buffer = 4096 (kb)
Output buffer size = 131072 (kb)

B L U E T O O T H S E T T I N G S

Bluetooth ver = 5.50
Bluealsa ver = 2.0.0
Speaker sharing = Yes
Resume MPD = No
PCM buffer time = 500000 (μs)

A I R P L A Y S E T T I N G S

Version = 3.3.5
Friendly name = Moode Airplay
ALSA device = hw:0
Interpolation = soxr
Output bit depth = S16
Output sample rate = 44100
Session interruption = no
Session timeout = 120 (ms)
Latency offset = 0.0 (secs)
Audio buffer = 0.2 (secs)
Resume MPD = No

S P O T I F Y S E T T I N G S

Friendly name = Moode Spotify
ALSA device = plughw:0
Bit rate = 160
Initial volume = 0
Volume curve = Logarithmic
Volume normalization = No
Normalization pregain = 0
Resume MPD = No

S Q U E E Z E L I T E S E T T I N G S

Version = 1.8.7-1052 "DSD/SRC enabled"
Friendly name = Moode
ALSA device = hw:0
ALSA params = 80:4::1
Output buffers = 40000:100000
Task priority = 45
Codec list = flac,pcm,mp3,ogg,aac,alac,dsd
Other options = -W -D 500 -R E -S /var/local
Resume MPD = No

L O C A L D I S P L A Y S E T T I N G S

Local UI display = Off
Mouse cursor = On
Screen blank = 600 Secs
Wake display on play = Off
Brightness = 255
Pixel aspect ratio = Default
Rotate screen = 0 Deg

M O O D E S T A R T U P L O G

20200120 012009 worker: -- Start
20200120 012010 worker: Successfully daemonized
20200120 012010 worker: Integrity check (passed)
20200120 012010 worker: Session loaded
20200120 012010 worker: Debug logging (off)
20200120 012010 worker: Device raw: Card0 (IQaudIODAC) | Card1 () | I2Sdev (IQaudIO Pi-DigiAMP+)
20200120 012010 worker: Device cfg: Name (IQaudIO Pi-DigiAMP+) | Card (0) | MPDdev (0) | Mixer (Digital) | Alsavol: (0)
20200120 012010 worker: ALSA volume set to (0%)
20200120 012010 worker: -- System
20200120 012012 worker: Host name (moode)
20200120 012012 worker: moOde release (6.4.0 2019-11-24)
20200120 012012 worker: Raspbian OS (10.2)
20200120 012012 worker: Linux kernel (4.19.83-v7+ #1277)
20200120 012012 worker: Platform (Pi-3B 1GB v1.2)
20200120 012012 worker: Architecture (armv7l)
20200120 012012 worker: MPD version (0.21.16)
20200120 012012 worker: CPU governor (ondemand)
20200120 012012 worker: USB boot not enabled yet
20200120 012012 worker: File system expanded
20200120 012012 worker: HDMI port off
20200120 012013 worker: File check (OK)
20200120 012013 worker: -- Network
20200120 012013 worker: eth0 exists
20200120 012013 worker: IP addr (192.168.0.102)
20200120 012013 worker: Netmask (255.255.255.0)
20200120 012013 worker: Gateway (0.0.0.0)
20200120 012013 worker: Pri DNS ()
20200120 012013 worker: Domain (192.168.0.1)
20200120 012014 worker: wlan0 exists
20200120 012014 worker: wifi country (FR)
20200120 012014 worker: wlan0 SSID is blank
20200120 012014 worker: eth0 addr exists, AP mode not started
20200120 012014 worker: wlan0 address not assigned
20200120 012014 worker: -- Audio
20200120 012014 worker: IQaudIO Pi-DigiAMP+ unmuted
20200120 012014 worker: ALSA card number (0)
20200120 012014 worker: Audio output (I2S audio device)
20200120 012014 worker: Audio device (IQaudIO Pi-DigiAMP+)
20200120 012014 worker: Audio formats (S16_LE, S24_LE, S32_LE)
20200120 012014 worker: ALSA mixer name (Digital)
20200120 012014 worker: MPD volume control (hardware)
20200120 012014 worker: Hdwr volume controller exists
20200120 012014 worker: Max ALSA volume (100%)
20200120 012014 worker: -- Services
20200120 012014 worker: Reset renderer active state
20200120 012015 worker: MPD conf updated
20200120 012015 worker: MPD started
20200120 012016 worker: MPD accepting connections
20200120 012016 worker: Configure MPD outputs
20200120 012016 worker: MPD output 1 ALSA default (off)
20200120 012016 worker: MPD output 2 ALSA crossfeed (off)
20200120 012016 worker: MPD output 3 ALSA parametric eq (off)
20200120 012016 worker: MPD output 4 ALSA graphic eq (off)
20200120 012016 worker: MPD output 5 ALSA polarity inversion (off)
20200120 012016 worker: MPD output 6 ALSA bluetooth (on)
20200120 012016 worker: MPD output 7 HTTP stream (off)
20200120 012016 worker: MPD crossfade (off)
20200120 012016 worker: Audio source (Local)
20200120 012016 worker: Output device (Bluetooth)
20200120 012016 worker: Audio scrobbler started
20200120 012016 worker: Bluetooth controller started
#12
Here is the warning message under the Audio Config option to turn on the Bluetooth controller.

"WARNING: A Bluetooth adapter must be physically attached and enabled before turning this ON otherwise moOde startup will fail."

Here are the telltale lines from the Sysinfo that u posted and the last line in Moode log showing the system hang when trying to start the Bluetooth controller.

Onboard BT = Off
.
.
Bluetooth controller = On
.
.
20200120 012016 worker: Bluetooth controller started

The remedy is to start with a fresh image and leave Onboard BT ON.
#13
the "onboard off" is because i've just tried with an external usb bluetooth device.
but i've got the same erreor as with the internal bluetooth.

So: are you sure ? Do "fresh image" mean i have to re-install another image on my sd card ?
#14
So: i've just switched back to bluetooth internal and played music. It crashed.
here are the logs

-------------------


S Y S T E M P A R A M E T E R S

moOde release = 6.4.0 2019-11-24
Raspbian OS = 10.2
Linux kernel = 4.19.83-v7+ #1277
Platform = Pi-3B 1GB v1.2
Architecture = armv7l (32-bit)
System uptime = up 1 hour, 2 minutes
Timezone = Europe/Paris
Current time = 2020-01-20 02:26:25

Host name = moode
Ethernet address = 192.168.0.102
Ethernet MAC = b8:27:eb:0c:1b:39
WLAN address = unassigned
WLAN MAC = b8:27:eb:59:4e:6c
WLAN country = FR

SoC identifier = bcm2837
Core count = 4
Kernel timer freq = 100 Hz
SDCard freq = 50 MHz
USB boot = not enabled
Warranty = OK

Root size = 29G
Root used = 10%
Root available = 25G
Root expand = expanded
Memory free = 647 MB
Memory used = 105 MB
SoC temperature = 39.7°C

CPU governor = ondemand
Onboard WiFi = On
Onboard BT = On
HDMI output = Off
Eth addr wait = On
Max USB current = Off
USB (UAC2) fix = Off
Pi-3B+ eth fix = Off
SSH term server = Off

PHP-FPM version = 7.3.11
NGINX version = 1.14.2
SQLite3 version = 3.27.2
Hostapd version = 2.8-devel
WiringPi version = 2.50
RPi.GPIO version = 0.7.0

A U D I O P A R A M E T E R S

Audio device = IQaudIO Pi-DigiAMP+
Interface = I2S
Mixer name = Digital
Hardware volume = Controller detected
Max ALSA volume = 100
Audio source = Local
Output device = Bluetooth
Resume MPD = No
Volume knob = 75
Volume mute = Unmuted
Saved MPD vol = 0
Preamp volume = 0
ALSA version = 1.1.8-1+rpt1
SoX version = 0.1.2-3

Bluetooth controller = On
Pairing agent = Off
Airplay receiver = Off
Spotify receiver = Off
Squeezelite = Off
UPnP client = Off
DLNA server = Off
GPIO button handler = Off
UPnP browser = Off

Auto-shuffle = Off
Autoplay = Off
Rotary encoder = Off
Encoder params = 100 2 3 23 24
Polarity inversion = Off
Crossfeed = Off
Crossfade = Off
Parametric EQ = Off
Graphic EQ = Off
MPD httpd = Off

A P P E A R A N C E S E T T I N G S

Theme = Pure Black
Accent color = Emerald
Alpha blend = 1.0
Adaptive background = Yes
Background image = Yes
Cover backdrop = Yes
Cover blur = 20px
Cover scale = 1.25
CoverView auto-display = 60
CoverView style = Animated
Auto-shuffle filter = None
Extra metadata = Yes
Playback history = Yes

L I B R A R Y S E T T I N G S

Instant play action = Clear/Play
Show genres column = Yes
Album grouping = by Artist
Compilation identifier = Various Artists, compilation, VA
Recently added = 1 Month
Ignore articles = a,an,the
UTF8 character filter = No
Hi-res thumbs = Auto
Cover search pri = Embedded cover
Pixel ratio = 1.25

M P D S E T T I N G S

Version = 0.21.16
Volume control = hardware
ALSA device = hw:0
SoX resampling = disabled
SoX quality = very high
SoX multithreading = off
DSD over PCM (DoP) = no
Replaygain = off
Replaygain preamp = 0
Volume normalization = No
Audio buffer = 4096 (kb)
Output buffer size = 131072 (kb)

B L U E T O O T H S E T T I N G S

Bluetooth ver = 5.50
Bluealsa ver = 2.0.0
Speaker sharing = Yes
Resume MPD = No
PCM buffer time = 500000 (μs)

A I R P L A Y S E T T I N G S

Version = 3.3.5
Friendly name = Moode Airplay
ALSA device = hw:0
Interpolation = soxr
Output bit depth = S16
Output sample rate = 44100
Session interruption = no
Session timeout = 120 (ms)
Latency offset = 0.0 (secs)
Audio buffer = 0.2 (secs)
Resume MPD = No

S P O T I F Y S E T T I N G S

Friendly name = Moode Spotify
ALSA device = plughw:0
Bit rate = 160
Initial volume = 0
Volume curve = Logarithmic
Volume normalization = No
Normalization pregain = 0
Resume MPD = No

S Q U E E Z E L I T E S E T T I N G S

Version = 1.8.7-1052 "DSD/SRC enabled"
Friendly name = Moode
ALSA device = hw:0
ALSA params = 80:4::1
Output buffers = 40000:100000
Task priority = 45
Codec list = flac,pcm,mp3,ogg,aac,alac,dsd
Other options = -W -D 500 -R E -S /var/local
Resume MPD = No

L O C A L D I S P L A Y S E T T I N G S

Local UI display = Off
Mouse cursor = On
Screen blank = 600 Secs
Wake display on play = Off
Brightness = 255
Pixel aspect ratio = Default
Rotate screen = 0 Deg

M O O D E S T A R T U P L O G

20200120 012415 worker: -- Start
20200120 012415 worker: Successfully daemonized
20200120 012415 worker: Integrity check (passed)
20200120 012415 worker: Session loaded
20200120 012415 worker: Debug logging (off)
20200120 012415 worker: Device raw: Card0 (IQaudIODAC) | Card1 () | I2Sdev (IQaudIO Pi-DigiAMP+)
20200120 012415 worker: Device cfg: Name (IQaudIO Pi-DigiAMP+) | Card (0) | MPDdev (0) | Mixer (Digital) | Alsavol: (0)
20200120 012415 worker: ALSA volume set to (0%)
20200120 012416 worker: -- System
20200120 012417 worker: Host name (moode)
20200120 012417 worker: moOde release (6.4.0 2019-11-24)
20200120 012417 worker: Raspbian OS (10.2)
20200120 012417 worker: Linux kernel (4.19.83-v7+ #1277)
20200120 012417 worker: Platform (Pi-3B 1GB v1.2)
20200120 012417 worker: Architecture (armv7l)
20200120 012417 worker: MPD version (0.21.16)
20200120 012417 worker: CPU governor (ondemand)
20200120 012418 worker: USB boot not enabled yet
20200120 012418 worker: File system expanded
20200120 012418 worker: HDMI port off
20200120 012418 worker: File check (OK)
20200120 012418 worker: -- Network
20200120 012418 worker: eth0 exists
20200120 012419 worker: IP addr (192.168.0.102)
20200120 012419 worker: Netmask (255.255.255.0)
20200120 012419 worker: Gateway (0.0.0.0)
20200120 012419 worker: Pri DNS ()
20200120 012419 worker: Domain (192.168.0.1)
20200120 012419 worker: wlan0 exists
20200120 012419 worker: wifi country (FR)
20200120 012419 worker: wlan0 SSID is blank
20200120 012419 worker: eth0 addr exists, AP mode not started
20200120 012419 worker: wlan0 address not assigned
20200120 012419 worker: -- Audio
20200120 012419 worker: IQaudIO Pi-DigiAMP+ unmuted
20200120 012419 worker: ALSA card number (0)
20200120 012419 worker: Audio output (I2S audio device)
20200120 012419 worker: Audio device (IQaudIO Pi-DigiAMP+)
20200120 012420 worker: Audio formats (S16_LE, S24_LE, S32_LE)
20200120 012420 worker: ALSA mixer name (Digital)
20200120 012420 worker: MPD volume control (hardware)
20200120 012420 worker: Hdwr volume controller exists
20200120 012420 worker: Max ALSA volume (100%)
20200120 012420 worker: -- Services
20200120 012420 worker: Reset renderer active state
20200120 012420 worker: MPD conf updated
20200120 012421 worker: MPD started
20200120 012422 worker: MPD accepting connections
20200120 012422 worker: Configure MPD outputs
20200120 012422 worker: MPD output 1 ALSA default (off)
20200120 012422 worker: MPD output 2 ALSA crossfeed (off)
20200120 012422 worker: MPD output 3 ALSA parametric eq (off)
20200120 012422 worker: MPD output 4 ALSA graphic eq (off)
20200120 012422 worker: MPD output 5 ALSA polarity inversion (off)
20200120 012422 worker: MPD output 6 ALSA bluetooth (on)
20200120 012422 worker: MPD output 7 HTTP stream (off)
20200120 012422 worker: MPD crossfade (off)
20200120 012422 worker: Audio source (Local)
20200120 012422 worker: Output device (Bluetooth)
20200120 012422 worker: Audio scrobbler started
20200120 012422 worker: Bluetooth controller started
20200120 012427 worker: Bluetooth controller initialized
20200120 012427 worker: USB auto-mounter (udisks-glue)
20200120 012427 worker: -- Music sources
20200120 012427 worker: USB sources (none attached)
20200120 012428 worker: NAS and UPnP sources (mountall initiated)
20200120 012428 worker: -- Miscellaneous
20200120 012428 worker: Saved MPD vol level (0)
20200120 012428 worker: Preamp volume level (0)
20200120 012428 worker: MPD volume level (42) restored
20200120 012428 worker: ALSA volume level (0%)
20200120 012428 worker: Auto-play (Off)
20200120 012428 worker: Maintenance interval (6 hrs)
20200120 012428 worker: Screen saver activation (60)
20200120 012428 worker: Session permissions (OK)
20200120 012428 worker: Watchdog started
20200120 012428 worker: Ready
20200120 012428 watchdog: INFO Audio output is (closed)
#15
@Maitresinh

I've reread this thread and I'm unclear about some of your statements.

1. Is it the case that you eventually reach this crash condition even when you run moOde as was previously suggested by @CallMeMike. That is to say, with MPD audio output -> Local (and, preferably with Bluetooth Renderer setting "OFF")? Or is the case that you eventually reach this crash condition only when you run with MPD audio output -> Bluetooth? You've also mentioned using Bluetooth as the source. Do you eventually reach the crash condition with Bluetooth as source and Local as output?

2. You've talked about moOde eventually crashing, after 12h - 24h, say, but in your latest post you said it's crashed and the system log shows it's only been up for an hour. Did it crash right away?

3. Of course, the underlying system hasn't crashed: you can open an SSH session. It's the UI that isn't responding because parts of the moOde application aren't running. There's several possibilities.

To try to gain a toehold, let's look for several possible hints in the logs.

egrep -i '(warn|error|fail)' /var/log/moode.log
egrep -i '(warn|error|fail)' /var/log/syslog

So, for example, here's the output from a moOde player where I purposely killed the MPD process (and the watchdog script helpfully started it again.)

Code:
pi@moode3a:/etc $ egrep -i '(fail|error|warn)' /var/log/moode.log
20200124 121516 watchdog: MPD restarted (check syslog for errors)
pi@moode3a:/etc $ egrep -i '(fail|error|warn)' /var/log/syslog
Jan 24 10:42:15 moode3a rngd[307]: stats: FIPS 140-2 failures: 0
Jan 24 11:42:15 moode3a rngd[307]: stats: FIPS 140-2 failures: 0
Jan 24 12:15:14 moode3a systemd[1]: mpd.service: Failed with result 'signal'.
Jan 24 12:42:15 moode3a rngd[307]: stats: FIPS 140-2 failures: 0

The FIPS failure reports are expected and can be ignored for this exercise.

It's probably most enlightening to do this test as soon after your system crashes as possible since it's possible the logs get rotated or truncated after some time (I really don't recall when this happens.)

And, yes, Tim was suggesting you re-image your uSD card.

Regards,
Kent
#16
Thanks for your patience.

1/ The crash happen only when bluetooth...but bith with bluetooth in or out. I've used mi moode to receveived bluettoth from a projector as i said,. I worked quite fine at the begnining but eventually, there were a lot of cuts, at the point it was impossible to ear. So yes, in a way, it wasn't the same that with bluetooth out (which work fine and stop to work withtout previous signs).

2/ i was wrong : it use to happen after an hour or so

3/ i've done it. here ar the logs below

4/ Last but not least: i've tried with an other (older) PI. And i had the same problem. So i'm not sure about the image, but i'll try

-------------
Last login: Mon Jan 20 02:25:45 2020 from 192.168.0.104
pi@moode:~ $ egrep -i '(warn|error|fail)' /var/log/moode.log
pi@moode:~ $ egrep -i '(warn|error|fail)' /var/log/syslog
Jan 21 00:19:59 moode rngd[332]: stats: FIPS 140-2 failures: 0
Jan 21 01:19:59 moode rngd[332]: stats: FIPS 140-2 failures: 0
Jan 21 02:19:59 moode rngd[332]: stats: FIPS 140-2 failures: 0
Jan 21 03:19:59 moode rngd[332]: stats: FIPS 140-2 failures: 0
Jan 21 04:19:59 moode rngd[332]: stats: FIPS 140-2 failures: 0
Jan 21 05:19:59 moode rngd[332]: stats: FIPS 140-2 failures: 0
Jan 21 06:19:59 moode rngd[332]: stats: FIPS 140-2 failures: 0
Jan 21 07:19:59 moode rngd[332]: stats: FIPS 140-2 failures: 0
Jan 21 08:19:59 moode rngd[332]: stats: FIPS 140-2 failures: 0
Jan 20 01:19:59 moode kernel: [ 0.741497] WARN::dwc_otg_hcd_init:1045: FIQ DMA bounce buffers: virt = bad04000 dma = 0xfad04000 len=9024
Jan 20 01:19:59 moode kernel: [ 0.753296] WARN::hcd_init_fiq:457: FIQ on core 1
Jan 20 01:19:59 moode kernel: [ 0.754870] WARN::hcd_init_fiq:458: FIQ ASM at 8067e4c4 length 36
Jan 20 01:19:59 moode kernel: [ 0.756409] WARN::hcd_init_fiq:497: MPHI regs_base at bb810000
Jan 20 01:19:59 moode kernel: [ 6.095129] vc_sm_cma: module is from the staging directory, the quality is unknown, you have been warned.
Jan 20 01:19:59 moode kernel: [ 6.223069] bcm2835_mmal_vchiq: module is from the staging directory, the quality is unknown, you have been warned.
Jan 20 01:19:59 moode kernel: [ 6.277416] bcm2835_v4l2: module is from the staging directory, the quality is unknown, you have been warned.
Jan 20 01:19:59 moode kernel: [ 6.279475] bcm2835_codec: module is from the staging directory, the quality is unknown, you have been warned.
Jan 20 01:19:59 moode kernel: [ 9.366604] random: 7 urandom warning(s) missed due to ratelimiting
Jan 20 01:20:16 moode dbus-daemon[324]: [system] Activation via systemd failed for unit 'dbus-org.bluez.service': Unit dbus-org.bluez.service not found.
Jan 20 01:20:16 moode bluealsa[1009]: /usr/bin/bluealsa: Couldn't get managed objects: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.bluez.service not found.
Jan 20 01:19:59 moode kernel: [ 0.741295] WARN::dwc_otg_hcd_init:1045: FIQ DMA bounce buffers: virt = bad04000 dma = 0xfad04000 len=9024
Jan 20 01:19:59 moode kernel: [ 0.753084] WARN::hcd_init_fiq:457: FIQ on core 1
Jan 20 01:19:59 moode kernel: [ 0.754659] WARN::hcd_init_fiq:458: FIQ ASM at 8067e4c4 length 36
Jan 20 01:19:59 moode kernel: [ 0.756198] WARN::hcd_init_fiq:497: MPHI regs_base at bb810000
Jan 20 01:19:59 moode kernel: [ 5.946241] vc_sm_cma: module is from the staging directory, the quality is unknown, you have been warned.
Jan 20 01:19:59 moode kernel: [ 6.099028] bcm2835_mmal_vchiq: module is from the staging directory, the quality is unknown, you have been warned.
Jan 20 01:19:59 moode kernel: [ 6.099046] bcm2835_mmal_vchiq: module is from the staging directory, the quality is unknown, you have been warned.
Jan 20 01:19:59 moode kernel: [ 6.147677] bcm2835_v4l2: module is from the staging directory, the quality is unknown, you have been warned.
Jan 20 01:19:59 moode kernel: [ 6.185737] bcm2835_codec: module is from the staging directory, the quality is unknown, you have been warned.
Jan 20 01:19:59 moode kernel: [ 9.013660] random: 7 urandom warning(s) missed due to ratelimiting
Binary file /var/log/syslog matches
#17
@Maitresinh

So, these lines were unexpected

Code:
Jan 20 01:20:16 moode dbus-daemon[324]: [system] Activation via systemd failed for unit 'dbus-org.bluez.service': Unit dbus-org.bluez.service not found.
Jan 20 01:20:16 moode bluealsa[1009]: /usr/bin/bluealsa: Couldn't get managed objects: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.bluez.service not found.

and also

Code:
Binary file /var/log/syslog matches


Whatever else is going on, this last line of your output suggests to me your install was or has gotten corrupted. Normally, the Linux/Raspbian syslog file is a text file. Witness

Code:
pi@moodecd:~ $ file /var/log/syslog
/var/log/syslog: ASCII text


Do, please, start with a fresh download of the moOde 6.4.0 zip file freshly flashed to a uSD card, preferably using a program like Belena's Etcher, which validates the flashed result.

Added: Of course, the usual admonitions about an adequate power supply and quality uSD card apply.

Regards,
Kent
#18
RE-installed with Etcher (like the first time) on a Scandisck SD card (30Go, class1)

My Power supply is close to this one
https://fr.aliexpress.com/item/32949210347.html

...i had a UI "crash" after a while. Sad

Here are the logs...i've just "mounted" my NAS, with some error (i forgot to enter the name of the source)

--------------------

pi@moode:~ $ egrep -i '(warn|error|fail)' /var/log/syslog
pi@moode:~ $ egrep -i '(warn|error|fail)' /var/log/moode.log
20200125 224922 sourceMount(): Mount error: (mount error(2): No such file or directory
20200125 225007 sourceMount(): Mount error: (mount error(2): No such file or directory
20200125 225024 sourceMount(): Mount error: (mount error(2): No such file or directory
20200125 225025 sourceMount(): Mount error: (mount error(2): No such file or directory
20200126 003634 moode.php: MPD connect failed: cmd=(clrplayall)
20200126 003634 moode.php: MPD connect failed: cmd=(addall)
20200126 003636 moode.php: MPD connect failed: cmd=(clrplayall)
------------------
S Y S T E M   P A R A M E T E R S

moOde release           = 6.4.0 2019-11-24
Raspbian OS             = 10.2
Linux kernel            = 4.19.83-v7+ #1277
Platform                = Pi-3B 1GB v1.2
Architecture            = armv7l (32-bit)
System uptime           = up 1 hour, 59 minutes
Timezone                = Europe/Paris
Current time            = 2020-01-26 00:38:31

Host name               = moode
Ethernet address        = 192.168.0.102
Ethernet MAC            = b8:27:eb:0c:1b:39
WLAN address            = unassigned
WLAN MAC                = b8:27:eb:59:4e:6c
WLAN country            = US

SoC identifier          = bcm2837
Core count              = 4
Kernel timer freq       = 100 Hz
SDCard freq             = 50 MHz
USB boot                = not enabled
Warranty                = OK

Root size               = 3.4G
Root used               = 79%
Root available          = 695M
Root expand             = not expanded
Memory free             = 598 MB
Memory used             = 118 MB
SoC temperature         = 40.8°C

CPU governor            = ondemand
Onboard WiFi            = On
Onboard BT              = On
HDMI output             = Off
Eth addr wait           = On
Max USB current         = Off
USB (UAC2) fix          = Off
Pi-3B+ eth fix          = Off
SSH term server         = Off

PHP-FPM version         = 7.3.11
NGINX version           = 1.14.2
SQLite3 version         = 3.27.2
Hostapd version         = 2.8-devel
WiringPi version        = 2.50
RPi.GPIO version        = 0.7.0

A U D I O   P A R A M E T E R S

Audio device            = IQaudIO Pi-DigiAMP+
Interface               = I2S
Mixer name              = Digital
Hardware volume         = Controller detected
Max ALSA volume         = 100
Audio source            = Local
Output device           = Bluetooth
Resume MPD              = No
Volume knob             = 31
Volume mute             = Unmuted
Saved MPD vol           = 0
Preamp volume           = 0
ALSA version            = 1.1.8-1+rpt1
SoX version             = 0.1.2-3

Bluetooth controller    = On
Pairing agent           = Off
Airplay receiver        = Off
Spotify receiver        = Off
Squeezelite             = Off
UPnP client             = Off
DLNA server             = Off
GPIO button handler     = Off
UPnP browser            = Off

Auto-shuffle            = Off
Autoplay                = Off
Rotary encoder          = Off
Encoder params          = 100 2 3 23 24
Polarity inversion      = Off
Crossfeed               = Off
Crossfade               = Off
Parametric EQ           = Off
Graphic EQ              = Off
MPD httpd               = Off

A P P E A R A N C E   S E T T I N G S

Theme                   = Default
Accent color            = Emerald
Alpha blend             = 1.0
Adaptive background     = No
Background image        = No
Cover backdrop          = No
Cover blur              = 20px
Cover scale             = 1.25
CoverView auto-display  = Never
CoverView style         = Animated
Auto-shuffle filter     = None
Extra metadata          = Yes
Playback history        = No

L I B R A R Y   S E T T I N G S

Instant play action     = Clear/Play
Show genres column      = Yes
Album grouping          = by Artist
Compilation identifier  = Various Artists
Recently added          = 1 Month
Ignore articles         = a,an,the
UTF8 character filter   = No
Hi-res thumbs           = Auto
Cover search pri        = Embedded cover
Pixel ratio             = 1.25

M P D   S E T T I N G S

Version                 = 0.21.16
Volume control          = software
ALSA device             = hw:0
SoX resampling          = disabled
SoX quality             = very high
SoX multithreading      = off
DSD over PCM (DoP)      = no
Replaygain              = off
Replaygain preamp       = 0
Volume normalization    = No
Audio buffer            = 4096 (kb)
Output buffer size      = 131072 (kb)

B L U E T O O T H   S E T T I N G S

Bluetooth ver           = 5.50
Bluealsa ver            = 2.0.0
Speaker sharing         = No
Resume MPD              = No
PCM buffer time         = 500000 (μs)

A I R P L A Y   S E T T I N G S

Version                 = 3.3.5
Friendly name           = Moode Airplay
ALSA device             = hw:0
Interpolation           = soxr
Output bit depth        = S16
Output sample rate      = 44100
Session interruption    = no
Session timeout         = 120 (ms)
Latency offset          = 0.0 (secs)
Audio buffer            = 0.2 (secs)
Resume MPD              = No

S P O T I F Y   S E T T I N G S

Friendly name           = Moode Spotify
ALSA device             = plughw:0
Bit rate                = 160
Initial volume          = 0
Volume curve            = Logarithmic
Volume normalization    = No
Normalization pregain   = 0
Resume MPD              = No

S Q U E E Z E L I T E   S E T T I N G S

Version                 = 1.8.7-1052 "DSD/SRC enabled"
Friendly name           = Moode
ALSA device             = hw:0
ALSA params             = 80:4::1
Output buffers          = 40000:100000
Task priority           = 45
Codec list              = flac,pcm,mp3,ogg,aac,alac,dsd
Other options           = -W -D 500 -R E -S /var/local
Resume MPD              = No

L O C A L   D I S P L A Y   S E T T I N G S

Local UI display        = Off
Mouse cursor            = On
Screen blank            = 600 Secs
Wake display on play    = Off
Brightness              = 255
Pixel aspect ratio      = Default
Rotate screen           = 0 Deg

M O O D E   S T A R T U P   L O G

20200125 223942 worker: -- Start
20200125 223942 worker: Successfully daemonized
20200125 223942 worker: Integrity check (passed)
20200125 223942 worker: Session loaded
20200125 223942 worker: Debug logging (off)
20200125 223942 worker: Device raw: Card0 (IQaudIODAC) | Card1 () | I2Sdev (IQaudIO Pi-DigiAMP+)
20200125 223942 worker: Device cfg: Name (On-board audio device) | Card (0) | MPDdev (0) | Mixer (PCM) | Alsavol: (0)
20200125 223942 worker: ALSA volume set to (0%)
20200125 223942 worker: -- System
20200125 223944 worker: Host name     (moode)
20200125 223944 worker: moOde release (6.4.0 2019-11-24)
20200125 223944 worker: Raspbian OS   (10.2)
20200125 223944 worker: Linux kernel  (4.19.83-v7+ #1277)
20200125 223944 worker: Platform      (Pi-3B 1GB v1.2)
20200125 223944 worker: Architecture  (armv7l)
20200125 223944 worker: MPD version   (0.21.16)
20200125 223944 worker: CPU governor  (ondemand)
20200125 223944 worker: USB boot not enabled yet
20200125 223944 worker: File system not expanded yet
20200125 223945 worker: HDMI port off
20200125 223945 worker: File check (OK)
20200125 223945 worker: -- Network
20200125 223945 worker: eth0 exists
20200125 223945 worker: IP addr (192.168.0.102)
20200125 223945 worker: Netmask (255.255.255.0)
20200125 223945 worker: Gateway (192.168.0.1)
20200125 223946 worker: Pri DNS ()
20200125 223946 worker: Domain  (192.168.0.1)
20200125 223946 worker: wlan0 exists
20200125 223946 worker: wifi country (US)
20200125 223946 worker: wlan0 SSID is blank
20200125 223946 worker: eth0 addr exists, AP mode not started
20200125 223946 worker: wlan0 address not assigned
20200125 223946 worker: -- Audio
20200125 223946 worker: IQaudIO Pi-DigiAMP+ unmuted
20200125 223946 worker: ALSA card number (0)
20200125 223946 worker: Audio output (I2S audio device)
20200125 223946 worker: Audio device (IQaudIO Pi-DigiAMP+)
20200125 223946 worker: Audio formats (S16_LE, S24_LE, S32_LE)
20200125 223946 worker: ALSA mixer name (Digital)
20200125 223946 worker: MPD volume control (software)
20200125 223947 worker: Hdwr volume controller exists
20200125 223947 worker: Max ALSA volume (100%)
20200125 223947 worker: -- Services
20200125 223947 worker: Reset renderer active state
20200125 223947 worker: MPD conf updated
20200125 223947 worker: MPD started
20200125 223948 worker: MPD accepting connections
20200125 223948 worker: Configure MPD outputs
20200125 223948 worker: MPD output 1 ALSA default (on)
20200125 223948 worker: MPD output 2 ALSA crossfeed (off)
20200125 223948 worker: MPD output 3 ALSA parametric eq (off)
20200125 223948 worker: MPD output 4 ALSA graphic eq (off)
20200125 223948 worker: MPD output 5 ALSA polarity inversion (off)
20200125 223948 worker: MPD output 6 ALSA bluetooth (off)
20200125 223948 worker: MPD output 7 HTTP stream (off)
20200125 223948 worker: MPD crossfade (off)
20200125 223948 worker: Audio source (Local)
20200125 223948 worker: Output device (Local)
20200125 223948 worker: Bluetooth controller started
20200125 223953 worker: Bluetooth controller initialized
20200125 223953 worker: USB auto-mounter (udisks-glue)
20200125 223953 worker: -- Music sources
20200125 223954 worker: USB sources (none attached)
20200125 223954 worker: NAS and UPnP sources (none configured)
20200125 223954 worker: -- Miscellaneous
20200125 223954 worker: Saved MPD vol level (0)
20200125 223954 worker: Preamp volume level (0)
20200125 223954 worker: MPD volume level (0) restored
20200125 223954 worker: ALSA volume level (100%)
20200125 223954 worker: Auto-play (Off)
20200125 223954 worker: Maintenance interval (6 hrs)
20200125 223954 worker: Screen saver activation (Never)
20200125 223954 worker: Session permissions (OK)
20200125 223954 worker: Watchdog started
20200125 223954 worker: Ready
20200125 223954 watchdog: INFO Audio output is (closed)
20200125 224458 worker: Job updmpddb
20200125 224921 worker: Job sourcecfg
20200125 224922 sourceMount(): Mount error: (mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20200125 224925 worker: Job updmpddb
20200125 225006 worker: Job sourcecfg
20200125 225007 sourceMount(): Mount error: (mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20200125 225010 worker: Job updmpddb
20200125 225024 sourceMount(): Mount error: (mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20200125 225025 sourceMount(): Mount error: (mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20200125 225045 worker: Job updmpddb
20200125 225117 worker: Job sourcecfg
20200125 225121 worker: Job updmpddb
20200125 225345 worker: Job updthmcache
20200125 225346 thmcache: Start
20200125 225346 thmcache: directory: NAS
20200125 225346 thmcache: directory: SDCARD
20200125 225351 worker: Job rescanmpddb
20200125 225412 thmcache: Done: 53 album dirs processed
20200126 003634 moode.php: MPD connect failed: cmd=(clrplayall)
20200126 003634 moode.php: MPD connect failed: cmd=(addall)
20200126 003636 moode.php: MPD connect failed: cmd=(clrplayall)
-----------------
#19
From the logs it shows your i2s DAC as...IQaudIO Pi-DigiAMP+

Which, on reading the product page, uses a 24v pwr supply and feeds the Pi, from that, a 2.5 amp/5volt supply.
http://iqaudio.co.uk/hats/9-pi-digiamp.html

Yet you quote your power supply as ...

My Power supply is close to this one
https://fr.aliexpress.com/item/32949210347.html

But that's an off-brand 5volt supply...so are you feeding the Pi from that and the IQaudIO Pi-DigiAMP+ some other supply..? How ???? Dodgy
Or is the off-brand supply feeding the Pi and back-feeding the IQaudIO Pi-DigiAMP+ ? Dodgy Dodgy

Please clarify...


NOTE the powering warning for the IQaudIO Pi-DigiAMP+ in the readme ....item 8

http://www.iqaudio.com/downloads/IQaudIO.pdf
#20
IQaudIO used to sell a 15V XP supply for the DigiAmp+ but now they offer a nice 19V supply.
http://iqaudio.co.uk/home/24-19v-power-b...&results=3

I use the 15V with mine :-)


Forum Jump: