Thank you for your donation!


Problem: Correct sample rate USB DAC
#1
Hello to all. 
First i want to thanks for this amazing software. Really amazing where audio is right now.

I searched a lot and couldnt find this issue. 

So, i´m using the last version os Moode (6.4.2) on a RPi 4 (4GB). I´m also using it as a Roon endpoint (via ethernet). I´m using the RPi 4 connected to a Acoustic Research AR-UA1 usb DAC. The DAC is recognized and i can send audio to it. The issue is that i really don´t know if the DAC is playing the correct sample rate or not. The DAC has a litlle LED that indicates the sample rate being played. 
On Windows (wasapi and asio) i always get the right color but on the RPi4 i always get the same color regardless of the sample rate played. 
Example: Windows - 88khz file - get a blue color (correct)
              RPi4       - 88Khz file - get a green color (its the default color and also means 48khz)
In the example above, i have to mention one thing. When i start playing the 88khz on the RPi4 i get the blue color for half a second and then it defaults to green. The music still plays and no dropouts or similar. Is i play 192Khz is the same. Correct color for a brief moment and then gree. 

On the Moode info it says that a 88Khz is being send to the PRPi4. And using the command cat /proc/asound/card1/pcm0p/sub0/hw_params says the same. 

So i assume the correct sample rate is going out the RPi4, but why the DAC is not showing me the correct sample rate? Maybe the DAC is playing in the correct sample rate and the colors doesnt work correctly on Linux...but i would like to be sure of that. 

Thanks in advance.
Reply
#2
If you are playing via Roon endpoint then post the issue in the Roon Forum. If playing via MPD and hw_params shows the correct sample rate being sent to the DAC then it would suggest the DAC may not be compatible with Linux.

Does the manufacturer state the DAC supports Linux?
Reply
#3
Hi,

I use the Audioquest Dragonfly (DF) as USB-DAC which indicates the sample rates also with an color changing LED. (Only until 24bit/96khz)

All colors are show the correct sampling rate, like also shown in the "Audio info". With the exception of the 16 bit/ 44.1 kHz input rate. There the output rate is 24 bit/ 44.1 kHz (Same green color on DF)

Regards
Norbert
Reply
#4
(02-14-2020, 01:50 PM)Tim Curtis Wrote: If you are playing via Roon endpoint then post the issue in the Roon Forum. If playing via MPD and hw_params shows the correct sample rate being sent to the DAC then it would suggest the DAC may not be compatible with Linux.

Does the manufacturer state the DAC supports Linux?

Thank you. 
So, im using it as roon endpoint but with Moode. Also, i tried several option (Ropieee, HQ NAA, Raspbian, Volumio, DietPi) and always had the exact same issue. I posted here because i settled on Moode (liked it the most). The manufacture does not state is Linux compatible. Also, it only produces speakers now and left the support for previous products..so no help there. 

One thing to point is that ALSA says the only suportted formats for the dac is 32_LE and as i checked ragrdless the files being played are 16bit or 24bit, the RPi4 always outputs in 32bit... DAC oficial specs says 16/24bit compatible, not 32bit. Dont know if thas the issue or not. 
DAC is USB 2.0 Audio compatible so it should work correctly with ALSA.. guess i'm wrong.. 

If theres any command that you think i should try please let me know. 
Thank you
Reply
#5
Hi Norbert.
Thanks.

So, in your case is only one sample rate that does not show correctly. In my case are all Sad

Have you tried using the DF with a usb powered hub? I read somewhere that it could be to lack of properly powered usb ports. At least in our case with these only usb powered Dacs.

Best regards,
Bruno
Reply
#6
Hi Bruno!

To clarify that again.

When playing a 16 bit / 44.1 kHz signal (classic CD ripp):

-> via for example a Hifiberry DAC + then moode Audio info shows "16 bit, 44.1kHz, Stereo". That is correct.

-> via Dragonfly moode Audio info then shows "24 bit, 44.1kHz, Stereo". That is correct too! because the DF extrapolates the signal from 16 to 24 bits and then communicates it to moode.

That means moode plays bit perfect under the default settings (without equalizer settings for example).

Maybe something is wrong in your setup?

Best Regards
Norbert
Reply
#7
Hello everyone, taking advantage of the conversation on the topic I would like to take a doubt, the signal from the USB output is it bit perfect or suffers some resampling ???

I'm in this doubt because I see the output signal as 32bit, and once a person more experienced in linux told me that he would only get bit perfect through ALSA, is this true ???
Reply
#8
Many high speed USB chipsets only accept 32-bit word length. In this case ALSA zero-pads 16 and 24-bit samples to 32-bit. The original 16 or 24 bits are unchanged so bit-perfect is maintained.
Reply


Forum Jump: