Thank you for your donation!


Problem: Cannot set up USB hard drives
#1
Sad 
I have a Raspberry Pi running Moode 6.3.0. I'm trying to plug a hard drive in to it (WD My Passport) with two partitions on it. The partition I care about is formatted exFAT. Digging through the settings on moode.local, I can find absolutelry no way to access the files on this drive, but the drive spins up. If I go to configure>library>music sources>create, and then enter in moode\usb\archive\music, it will accept it in the dialogue box, but when I try to save that configuration, I get a message that says "share cannot be left blank" and I go back to the music sources page and absolutely nothing has changed, and it still says "nothing configured". I've been fiddling with this for hours now and nothing I do gets me any results. Any ideas?


Oh and I've been trying to dump my system info for you all, but when I press "system info", in the top right menu, nothing happens.


Device info:

Release Information Platform Information
  • Raspbian: 10.1
  • Linux kernel: 4.19.75-v7+ #1270
  • Platform: Pi-2B 1GB v1.1
  • Architecture: armv7l
  • MPD version: 0.20.23


Reply
#2
Oh I managed to get the system info:

S Y S T E M P A R A M E T E R S

moOde release = 6.3.0 2019-10-02
Raspbian OS = 10.1
Linux kernel = 4.19.75-v7+ #1270
Platform = Pi-2B 1GB v1.1
Architecture = armv7l (32-bit)
System uptime = up 6 hours, 34 minutes
Timezone = Greenwich
Current time = 2020-02-16 21:25:30

Host name = moode
Ethernet address = 192.168.0.13
Ethernet MAC = b8:27:eb:19:cc:31
WLAN address = 192.168.0.12
WLAN MAC = 74:da:38:42:44:5c
WLAN country = GB

SoC identifier = bcm2836
Core count = 4
Kernel timer freq = 100 Hz
SDCard freq = 50 MHz
USB boot = not available
Warranty = OK

Root size = 3.4G
Root used = 82%
Root available = 608M
Root expand = expanded
Memory free = 579 MB
Memory used = 106 MB
SoC temperature = 40.1°C

CPU governor = ondemand
Onboard WiFi = None
Onboard BT = None
HDMI output = On
Eth addr wait = On
Max USB current = Off
USB (UAC2) fix = Off
Pi-3B+ eth fix = Off
SSH term server = Off

PHP-FPM version = 7.3.9
NGINX version = 1.14.2
SQLite3 version = 3.27.2
Hostapd version = 2.8-devel
WiringPi version = 2.50
RPi.GPIO version = 0.7.0

A U D I O P A R A M E T E R S

Audio device = HiFiBerry DAC+
Interface = I2S
Hardware volume = Controller detected
Mixer name = Digital
Audio source = Local
Output device = Local
Resume MPD = No
Volume knob = 100
Volume mute = Unmuted
Saved MPD vol = 0
Preamp volume = 0
ALSA version = 1.1.8-1+rpt1
SoX version = 0.1.2-3

Bluetooth controller = Off
Pairing agent = Off
Airplay receiver = On
Spotify receiver = Off
Squeezelite = Off
UPnP client = Off
DLNA server = Off
GPIO button handler = Off
UPnP browser = Off

Auto-shuffle = Off
Autoplay = Off
Rotary encoder = Off
Encoder params = 100 2 3 23 24
Polarity inversion = Off
Crossfeed = Off
Crossfade = Off
Parametric EQ = Off
Graphic EQ = Off
MPD httpd = Off

A P P E A R A N C E S E T T I N G S

Theme = Default
Accent color = Emerald
Alpha blend = 1.0
Adaptive background = No
Background image = No
Cover backdrop = No
Cover blur = 20px
Cover scale = 1.25
CoverView auto-display = Never
CoverView style = Animated
Auto-shuffle filter = None
Extra metadata = Yes
Playback history = No

L I B R A R Y S E T T I N G S

Instant play action = Clear/Play
Show genres column = Yes
Album grouping = by Artist
Compilation identifier = Various Artists
Recently added = 1 Month
Ignore articles = a,an,the
UTF8 character filter = No
Hi-res thumbs = Auto
Cover search pri = Embedded cover
Pixel ratio = 2

M P D S E T T I N G S

Version = 0.20.23
Volume control = software
ALSA device = hw:0
SoX resampling = disabled
SoX quality = very high
SoX multithreading = off
DSD over PCM (DoP) = no
Replaygain = off
Replaygain preamp = 0
Volume normalization = No
Audio buffer = 4096 (kb)
Output buffer size = 131072 (kb)

B L U E T O O T H S E T T I N G S

Bluetooth ver = 5.50
Bluealsa ver = 1.3.1
Speaker sharing = No
Resume MPD = No
PCM buffer time = 500000 (\u03BCs)

A I R P L A Y S E T T I N G S

Version = 3.3.2
Friendly name = Moode Airplay
ALSA device = hw:0
Interpolation = soxr
Output bit depth = S16
Output sample rate = 44100
Session interruption = no
Session timeout = 30 (ms)
Audio buffer = 0.0 (secs)
Resume MPD = No

S P O T I F Y S E T T I N G S

Friendly name = Moode Spotify
ALSA device = plughw:0
Bit rate = 160
Initial volume = 0
Volume curve = Logarithmic
Volume normalization = No
Normalization pregain = 0
Resume MPD = No

S Q U E E Z E L I T E S E T T I N G S

Version = 1.8.7-1052 "DSD/SRC enabled"
Friendly name = Moode
ALSA device = hw:0
ALSA params = 80:4::1
Output buffers = 40000:100000
Task priority = 45
Codec list = flac,pcm,mp3,ogg,aac,alac,dsd
Other options = -W -D 500 -R E -S /var/local
Resume MPD = No

L O C A L D I S P L A Y S E T T I N G S

Local UI display = Off
Mouse cursor = Off
Screen blank = 600 Secs
Brightness = 255
Pixel aspect ratio = Default
Rotate screen = 0 Deg

M O O D E S T A R T U P L O G

20200216 095106 worker: -- Start
20200216 095106 worker: Successfully daemonized
20200216 095106 worker: Integrity check (passed)
20200216 095106 worker: Session loaded
20200216 095106 worker: Debug logging (off)
20200216 095107 worker: ALSA volume set to (0%)
20200216 095107 worker: -- System
20200216 095110 worker: Host name (moode)
20200216 095110 worker: moOde release (6.3.0 2019-10-02)
20200216 095110 worker: Raspbian OS (10.1)
20200216 095110 worker: Linux kernel (4.19.75-v7+ #1270)
20200216 095110 worker: Platform (Pi-2B 1GB v1.1)
20200216 095110 worker: Architecture (armv7l)
20200216 095110 worker: MPD version (0.20.23)
20200216 095110 worker: CPU governor (ondemand)
20200216 095110 worker: USB boot not available
20200216 095110 worker: File system not expanded yet
20200216 095110 worker: HDMI port on
20200216 095111 worker: File check (OK)
20200216 095111 worker: -- Network
20200216 095111 worker: eth0 exists
20200216 095112 worker: eth0 (192.168.0.13)
20200216 095112 worker: wlan0 exists
20200216 095112 worker: wifi country (GB)
20200216 095112 worker: wlan0 trying SSID (VM4981079)
20200216 095112 worker: wlan0 (192.168.0.12)
20200216 095112 worker: -- Audio
20200216 095113 worker: ALSA outputs unmuted
20200216 095113 worker: ALSA card number (0)
20200216 095113 worker: Audio output (I2S audio device)
20200216 095113 worker: Audio device (HiFiBerry DAC+)
20200216 095114 worker: Supported audio formats (S16_LE, S24_LE, S32_LE)
20200216 095114 worker: ALSA mixer name (Digital)
20200216 095114 worker: MPD volume control (software)
20200216 095114 worker: Hdwr volume controller exists
20200216 095114 worker: -- Services
20200216 095114 worker: Reset renderer active state
20200216 095115 worker: MPD conf updated
20200216 095116 worker: MPD started
20200216 095117 worker: MPD accepting connections
20200216 095117 worker: Configure MPD outputs
20200216 095117 worker: MPD output 1 ALSA default (on)
20200216 095117 worker: MPD output 2 ALSA crossfeed (off)
20200216 095117 worker: MPD output 3 ALSA parametric eq (off)
20200216 095117 worker: MPD output 4 ALSA graphic eq (off)
20200216 095117 worker: MPD output 5 ALSA polarity inversion (off)
20200216 095117 worker: MPD output 6 ALSA bluetooth (off)
20200216 095117 worker: MPD output 7 HTTP stream (off)
20200216 095117 worker: MPD crossfade (off)
20200216 095117 worker: Audio source (Local)
20200216 095117 worker: Output device (Local)
20200216 095117 worker: Airplay receiver started
20200216 095117 worker: USB auto-mounter (udisks-glue)
20200216 095117 worker: -- Music sources
20200216 095118 worker: USB sources (none attached)
20200216 095118 worker: NAS and UPnP sources (none configured)
20200216 095118 worker: -- Miscellaneous
20200216 095118 worker: Saved MPD vol level (0)
20200216 095118 worker: Preamp volume level (0)
20200216 095118 worker: MPD volume level (100) restored
20200216 095118 worker: ALSA volume level (100%)
20200216 095118 worker: Auto-play (Off)
20200216 095118 worker: Maintenance interval (6 hrs)
20200216 095118 worker: Screen saver activation (Never)
20200216 095118 worker: Session permissions (OK)
20200216 095118 worker: Watchdog started
20200216 095118 worker: Ready
20200216 095306 worker: Job airplaysvc
20200216 152027 worker: Job timezone
20200216 203018 watchdog: PHP restarted (fpm child limit > 40)
20200216 153347 worker: Job updmpddb
20200216 153351 worker: Job rescanmpddb
20200216 153431 worker: Job updmpddb
20200216 154611 worker: Job updmpddb
20200216 155240 worker: Maintenance completed
20200216 155358 worker: Job updmpddb
Reply
#3
Ideally on a Linux system you're best having a Linux native filesystem like ext4 instead of a Windows filesystem, on the other hand I think exfat-fuse package is already installed on Moode so it should be mounting without you having to create a source. Just plug in your drive and scan the library.
Reply
#4
As vinn posted, you just need to update or re-gen the mpd database.

I run an NTFS formated 2TB seagate drive with no issues.

Good luck. Smile
Reply
#5
Nothing happens when I press the buttons to either the update or regen mpd database.
Reply
#6
Very Top right when you select update or regen should be a small ' arrowed spinner' Is that present?
If it is then wait until it completes and disappears. Then the update will have completed.

However, I think your problem is as reported by the error you quoted " I get a message that says "share cannot be left blank"
I am a professional finder with the memory of an elephant.... a curse but a useful curse :-)
Reply
#7
(02-16-2020, 11:14 PM)DRONE7 Wrote: Very Top right when you select update or regen should be a small ' arrowed spinner'  Is that present?
If it is then wait until it completes and disappears. Then the update will have completed.

However, I think your problem is as reported by the error you quoted    " I get a message that says "share cannot be left blank"

That does appear, and then disappears, and when it disappears nothing has changed.
Reply
#8
Releases less than 6.4.x are not supported. Install latest 6.4.2 release, plug in USB drive then post the output of the command below. It should list subdirectories corresponding to each partition label.

Code:
ls /media
Reply
#9
@Cymbal Monkey

Let me expand on Tim's answer.

Does your partition contain music files? If not, it won't show up.

If it does, then:

When you SSH into your moOde player, what do you get when you execute the following commands

1. sudo blkid

2. ls -l /media

Example: 

Here I have a moOde 6.4.2 player with a USB Thumb Drive plugged in. 

The drive has three partitions. The first is a  FAT32 partition with label "LEXAR8GB1" [left over from a previous test], the second is an ext4 partition with no label, the third is an ext4 partition with label "part3". It's been mounted by Raspbian as /dev/sda1, /dev/sda2, /dev/sda3. 

The rest of the lines here relate to the uSD card.

Code:
pi@moodevu:~ $ sudo blkid
/dev/mmcblk0p1: LABEL_FATBOOT="boot" LABEL="boot" UUID="5203-DB74" TYPE="vfat" PARTUUID="6c586e13-01"
/dev/mmcblk0p2: LABEL="rootfs" UUID="2ab3f8e1-7dc6-43f5-b0db-dd5759d51d4e" TYPE="ext4" PARTUUID="6c586e13-02"
/dev/sda1: LABEL="LEXAR8GB1" UUID="AF20-72AD" TYPE="vfat" PARTUUID="c7f80f7d-01"
/dev/sda2: UUID="6955e457-451d-45f8-bb82-ae7f4c2a463f" TYPE="ext4" PARTUUID="c7f80f7d-02"
/dev/sda3: LABEL="part3" UUID="9d574a65-3f0b-4b8f-9eb0-7a0a5fce1f5b" TYPE="ext4" PARTUUID="c7f80f7d-03"
/dev/mmcblk0: PTUUID="6c586e13" PTTYPE="dos"

Code:
pi@moodevu:~ $ ls -l /media
total 12
drwxr-xr-x 3 pi   pi   4096 Feb 16 18:50 6955e457-451d-45f8-bb82-ae7f4c2a463f
drwxr-xr-x 2 root root 4096 Dec 31  1969 LEXAR8GB1
drwxr-xr-x 3 pi   pi   4096 Feb 16 18:50 part3

Since I didn't label the second partition, Raspbian has used the UUID (6955e457...).

The first and second partitions contain music files. The third does not.

When I update MPD, the first two partitions show up in the directory panel, the third does not (because MPD found no music files).

Regards,
Kent
Reply
#10
@TheOldPresbyope

I updated to the latest version of Moode and ran the commands. This is what it spat out. I don't really know what I'm looking at as far as the first command is concerned, but it clearly sees the hard drive, which contains both a backup of my laptop and a partition called archive, which contains the music I would like to access in \archive\music. I'm not quite sure where I go from here though.

Code:
pi@moode:~ $ sudo blkid
ls -l /media                                                                                                    
/dev/mmcblk0p1: LABEL_FATBOOT="boot" LABEL="boot" UUID="5203-DB74" TYPE="vfat" PARTUUID="6c586e13-01"            
/dev/mmcblk0p2: LABEL="rootfs" UUID="2ab3f8e1-7dc6-43f5-b0db-dd5759d51d4e" TYPE="ext4" PARTUUID="6c586e13-02"    
/dev/mmcblk0: PTUUID="6c586e13" PTTYPE="dos"                                                                    
pi@moode:~ $  ls -l /media
total 129                                                                                                        
drwxrwxrwx 1 root root 131072 Dec 31  1969 Archive
drwxr-xr-x 2 root root    512 Dec 31  1969 EFI
Reply


Forum Jump: