Thank you for your donation!


Problem: Finding a PCM Always On Option
#1
Hello,

First I want to thank Tim and everyone here for a great piece of software and excellent support.  I have a new KEF LSX speaker that I am driving with my Raspberry Pi 3B with HiFiBerry Digi+ via its optical output (16bit, 44.1kHz), loading FLAC files from a SMB share on my NAS, using v4.4 of MoodeAudio.  (yes, I realize I should update)  The problem is that the first 1-2 seconds of each song gets cut off due to the handshake time required for the LSX optical input to lock onto the data stream.  (in a gapless playlist this happens only with the 1st song)

Some notes:
- It doesn't happen on all my DACs.  (Chord and Dynaudio products don't have the issue)

- I contacted KEF technical support and they said they believe the optical output drops off when no signal is being played.  He felt this was unusual as most devices with an optical output operate in an "always on" mode.  (a stream of zeros is output instead of no signal)  He suspected I don't see it on all my DACs because they have a faster handshake.

It seems others have had this issue too but it's very dependent on the hardware & software (e.g., MPD with Moode with HiFiBerry Digi+) and I haven't found a clear solution yet.  I was hoping someone with much more experience might have some ideas?

Thank you very much in advance!

- Chris -
Reply
#2
The Kef specs indicate support for up to 192kHz/24bit input.
What happens if you up-sample in MoOde to 24bit/*kHz ?? (MPD Config>SoX Resampling)
I am a professional finder with the memory of an elephant.... a curse but a useful curse :-)
Reply
#3
"using v4.4 of MoodeAudio"

Upgrade to 6.4.2 and report back.
Reply
#4
(02-18-2020, 02:58 AM)Tim Curtis Wrote: "using v4.4 of MoodeAudio"

Upgrade to 6.4.2 and report back.

I upgraded Moode to 6.4.2.  (yay! - an alphabetical list on the right to quickly jump to an artist / folder)  The problem didn't go away but I now became aware of the fact that there is a 3 second timer involved.  If I stop a song (or it stops by itself) then the optical connection stays alive for 3 seconds, after which I hear a very faint pop through the speakers.  After this moment, if I start to play a song, the first 1-2 seconds are missed.  But before this moment (within those 3 seconds), if I start a new song, it plays perfectly.

There are multiple ways (among others I'm sure) to solve this:
1- Automatically first play a short 1-2 second silence track whenever a new song is selected by the user to play
2- Keep the optical PCM output always on
3- Increase the 3 second timer

I'm not sure which is most straightforward / simple, but option #3 sounds potentially easy.  Does anyone know where / what is controlling that 3 second timer which shuts off the PCM after a song is completed?  If I could extend that (to, say 30 seconds) then that would help a lot.  (or if there's an easy way to implement one of the other options that's probably even better)

- Chris -

(Sorry, I forgot to test the SoX upsampling.  Good idea, I'll do that tonight.)
Reply
#5
(02-18-2020, 09:25 AM)symbiotic_ic Wrote:
(02-18-2020, 02:58 AM)Tim Curtis Wrote: "using v4.4 of MoodeAudio"

Upgrade to 6.4.2 and report back.

I upgraded Moode to 6.4.2.  (yay! - an alphabetical list on the right to quickly jump to an artist / folder)  The problem didn't go away but I now became aware of the fact that there is a 3 second timer involved.  If I stop a song (or it stops by itself) then the optical connection stays alive for 3 seconds, after which I hear a very faint pop through the speakers.  After this moment, if I start to play a song, the first 1-2 seconds are missed.  But before this moment (within those 3 seconds), if I start a new song, it plays perfectly.

There are multiple ways (among others I'm sure) to solve this:
1- Automatically first play a short 1-2 second silence track whenever a new song is selected by the user to play
2- Keep the optical PCM output always on
3- Increase the 3 second timer

I'm not sure which is most straightforward / simple, but option #3 sounds potentially easy.  Does anyone know where / what is controlling that 3 second timer which shuts off the PCM after a song is completed?  If I could extend that (to, say 30 seconds) then that would help a lot.  (or if there's an easy way to implement one of the other options that's probably even better)

- Chris -

(Sorry, I forgot to test the SoX upsampling.  Good idea, I'll do that tonight.)

SoX upsampling didn't change the behavior, unfortunately.
How do I increase the ~3 second timer that shuts off the PCM output data stream (via optical using the HiFiBerry Digi+) when a song stops?
Reply
#6
Use a different DAC? Seriously this is a DAC issue, as you say your Chord DAC doesn't have this problem.
Reply


Forum Jump: