Thank you for your donation!


Radio Logos lost
#1
Hi everybody,
I decided to add some new radios in my Moode Player and (in version 6.4.0) I trasfered about 60 .PLS, and related .JPG and thumbs in the correct directories.
Everything went well.
Passing from 6.4.0 to 6.4.1 it was enough to "edit station" for each radio added to have thumbs and logo correct.
Now, passing from 6.4.1 to 6.4.2 I tried the same procedure but it runs until I reboot or shutdown the Player: after the reboot I see the thumb but the logos appear all "moOde".
I have tried also to begin from scratch (image 6.4.2) and than add .PLS, and related .JPG and thumbs and I had the same result: it run until reboot or shutdown.

Is there any command to "STORE" the situation after the "edit station"?

I am really new in the forum so please excuse me if I made something wrong and for my (not very good) english.
Reply
#2
Looking at the code, I don't see how editing a manually added station would result in a row for that station being added to the cfg_radio table. I see where the session variable is created which would explain why it things work until reboot where during moOde startup all the radio stations are purged from the PHP session to get rid of any orphaned stations i.e., those without a corresponding row in cfg_radio. The stations are then loaded into the session from cfg_radio table.

The session cleansing was added to 6.4.2 to cleanup a problem that has been present in moOde for a long time and resulted in the PHP session becoming out of sync with cfg_radio and cfg_system tables.

- UPD: Purge orphaned stations from session during startup

-Tim
Reply
#3
Hi Tim,
First of all thanks for your prompt reply.
I am sure you are right but the stations remained in the screen with their own thumbs and can be correctly selected and listened, but the logo, if I open the screen, are the default "moOde"; it seems that the radio stations are not purged, but only the link to the LOGO. 
I am sorry but I do not understand your statement:
- UPD: Purge orphaned stations from session during startup
Is it only a line of the release note?
Would you please be so kind to suggest any solution to see the tables and eventually modify them?
Thank again and best regards,
Francesco
Reply
#4
Yes, it was referring to a line in the release notes for the r642 release.

I think you prolly want to try the bulk station adder from @TheOldPresbyope
http://moodeaudio.org/forum/showthread.p...8#pid12198

There is also a PR from @duracell80 that's waiting to be reviewed and tested for the upcoming r650 release
https://github.com/moode-player/moode/pull/75
http://moodeaudio.org/forum/showthread.p...8#pid17018
Reply
#5
(03-01-2020, 04:29 PM)Tim Curtis Wrote: Yes, it was referring to a line in the release notes for the r642 release.

I think you prolly want to try the bulk station adder from @TheOldPresbyope
http://moodeaudio.org/forum/showthread.p...8#pid12198

There is also a PR from @duracell80 that's waiting to be reviewed and tested for the upcoming r650 release
https://github.com/moode-player/moode/pull/75
http://moodeaudio.org/forum/showthread.p...8#pid17018

Thank you very much for your precious support.
Best regards,
Francesco
Reply
#6
Hello "Duracell80",
thanks for your reply; I found just now time to test your manager but it seems that in addition to the PLS, Logo e Thumb, two additional file are needed:
import.json
import.sql
Do you have any suggestion on "how to build them"? Only manually?
Thanks in advance and best regards,
Francesco
Reply
#7
Thanks a lot, Duracell80,
finally I got it!!!
Everything is correctly running, now.
Best regards and thanks again,
Francesco
Reply


Forum Jump: