Thank you for your donation!


Problem: Piano 2.1 + Kali in 2.1 Subwoofer mode doesn't produce sound at subwoofer channel
#1
I'm trying to use Allo Piano 2.1 DAC along with Kali reclocker in "Subwoofer mode" set to 2.1. I've installed the firmware files from https://github.com/allocom/piano-firmware and I use:

Code:
amixer -c0 set 'Subwoofer mode' '2.1'

As can be set as well via the web interface.

I can get sound fine from the 2 L/R channels, but none from the 2 subwoofer RCA outputs. I'm using an amplifier and speaker that used to work when the DAC was configured for Dual Mono mode. I'm currently testing this with headphones connected straight to the subwoofer RCA outputs. I can hear sound with headphones without an amp via the 2 L/R RCAs but none via the Subwoofer outputs (without any settings change). Here's some debug info:

Code:
$ ~/piano.sh
Dual mode: None
Subw mode: 2.1
Sub xover: 60
Sub level: 0%
Main levl: 100%
Mstr levl: 100%

Code:
$ cat /boot/config.txt
# Screen

# no splash screen on boot
disable_splash=1
# no sound via HDMI
hdmi_drive=1
# HDMI output will be switched off and blanked when in power save
hdmi_blanking=1
# 270 degrees clockwise rotation
display_hdmi_rotate=3
hdmi_cvt=800 480 60 6
hdmi_group=2
hdmi_mode=87
# Cut the bottom and the top in accordance with the box rectangle
overscan_top=272
overscan_bottom=48
# overscan_left=272
# overscan_right=48

# Audio

dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=audio=off
dtoverlay=allo-piano-dac-plus-pcm512x-audio,glb_mclk
#dtoverlay=pi3-disable-wifi
#dtoverlay=pi3-disable-bt

Here's the "Audio Information" from the Web interface:

Code:
Input / Output
Source:   NAS/nux-downloads/Jerry Fuller Sextet - Clarinet Portrait - 1959/09 - Benny's Idea.flac
Encoded at:   16 bit, 44.1 kHz, Stereo FLAC
Decoded to:   16 bit, 44.1 kHz, Stereo, 849 kbps
Destination:   Local
Output rate:   32 bit, 192 kHz, Stereo, 12.288 Mbps
DSP operations
Volume ctl:   Hardware (on-chip volume controller)
Resampling:   32 bit, 192 kHz, Stereo (SoX very high quality)
Polarity inv:   off
Crossfade:   off
Crossfeed:   off
Parametric EQ:   off
Graphic EQ:   off
Replaygain:   off
Normalize vol:   off
Chip options:   FIR interpolation with de-emphasis, Gain=0dB, Boost=0dB
Audio Device
Device:   Allo Piano 2.1 Hi-Fi DAC
Chip:   Burr Brown PCM5142
Interface:   I2S
Formats:   S16_LE, S24_LE, S32_LE
Platform:   Pi-3B 1GB v1.2

And Here's the system's Info:

Code:
S Y S T E M   P A R A M E T E R S

moOde release = 6.4.2 2020-02-12
Raspbian OS = 10.2
Linux kernel = 4.19.97-v7+ #1293
Platform = Pi-3B 1GB v1.2
Architecture = armv7l (32-bit)
System uptime = up 1 hour, 30 minutes
Timezone = Asia/Tel_Aviv
Current time = 2020-03-13 21:57:08

Host name = moode
Ethernet address = unassigned
Ethernet MAC = b8:27:eb:d9:e7:6d
WLAN address = 192.168.14.61
WLAN MAC = b8:27:eb:8c:b2:38
WLAN country = IL

SoC identifier = bcm2837
Core count = 4
Kernel timer freq = 100 Hz
SDCard freq = 50 MHz
USB boot = not enabled
Warranty = OK

Root size = 3.4G
Root used = 79%
Root available = 687M
Root expand = not expanded
Memory free = 289 MB
Memory used = 268 MB
SoC temperature = 43.5°C

CPU governor = ondemand
Onboard WiFi = On
Onboard BT = On
HDMI output = On
Eth addr wait = On
Max USB current = Off
USB (UAC2) fix = Off
Pi-3B+ eth fix = Off
SSH term server = Off

PHP-FPM version = 7.3.11
NGINX version = 1.14.2
SQLite3 version = 3.27.2
Hostapd version = 2.8-devel
WiringPi version = 2.50
RPi.GPIO version = 0.7.0

A U D I O   P A R A M E T E R S

Audio device = Allo Piano 2.1 Hi-Fi DAC
Interface = I2S
Mixer name = Digital
Hardware volume = Controller detected
Max ALSA volume = 100
Audio source = Local
Output device = Local
Resume MPD = No
Volume knob = 0
Volume mute = Unmuted
Saved MPD vol = 0
Preamp volume = 0
ALSA version = 1.1.8-1+rpt1
SoX version = 0.1.2-3

Bluetooth controller = Off
Pairing agent = Off
Airplay receiver = Off
Spotify receiver = Off
Squeezelite = Off
UPnP client = Off
DLNA server = Off
GPIO button handler = Off
UPnP browser = Off

Auto-shuffle = Off
Autoplay = Off
Rotary encoder = Off
Encoder params = 100 2 3 23 24
Polarity inversion = Off
Crossfeed = Off
Crossfade = Off
Parametric EQ = Off
Graphic EQ = Off
MPD httpd = Off

A P P E A R A N C E   S E T T I N G S

Theme = Default
Accent color = Emerald
Alpha blend = 1.0
Adaptive background = No
Background image = No
Cover backdrop = No
Cover blur = 20px
Cover scale = 1.25
CoverView auto-display = Never
CoverView style = Animated
Auto-shuffle filter = None
Extra metadata = Yes
Playback history = No

L I B R A R Y   S E T T I N G S

Instant play action = Clear/Play
Show genres column = Yes
Album grouping = by Artist
Compilation identifier = Various Artists
Recently added = 1 Month
Ignore articles = a,an,the
UTF8 character filter = No
Hi-res thumbs = Auto
Cover search pri = Embedded cover
Pixel ratio = 1

M P D   S E T T I N G S

Version = 0.21.16
Volume control = hardware
ALSA device = hw:0
SoX resampling = 192000:32:2
SoX quality = very high
SoX multithreading = on
DSD over PCM (DoP) = no
Replaygain = off
Replaygain preamp = 0
Volume normalization = No
Audio buffer = 65535 (kb)
Output buffer size = 131072 (kb)

B L U E T O O T H   S E T T I N G S

Bluetooth ver = 5.50
Bluealsa ver = 2.0.0
Speaker sharing = No
Resume MPD = No
PCM buffer time = 500000 (µs)

shairport-sync: error while loading shared libraries: libconfig.so.9: cannot open shared object file: No such file or directory
A I R P L A Y   S E T T I N G S

Version =
Friendly name = Moode Airplay
ALSA device = hw:0
Interpolation = soxr
Output bit depth = S16
Output sample rate = 44100
Session interruption = no
Session timeout = 120 (ms)
Latency offset = 0.0 (secs)
Audio buffer = 0.2 (secs)
Resume MPD = No

S P O T I F Y   S E T T I N G S

Friendly name = Moode Spotify
ALSA device = plughw:0
Bit rate = 160
Initial volume = 0
Volume curve = Logarithmic
Volume normalization = No
Normalization pregain = 0
Resume MPD = No

S Q U E E Z E L I T E   S E T T I N G S

Version = 1.8.7-1052 "DSD/SRC enabled"
Friendly name = Moode
ALSA device = hw:0
ALSA params = 80:4::1
Output buffers = 40000:100000
Task priority = 45
Codec list = flac,pcm,mp3,ogg,aac,alac,dsd
Other options = -W -D 500 -R E -S /var/local
Resume MPD = No

L O C A L   D I S P L A Y   S E T T I N G S

Local UI display = On
Mouse cursor = On
Screen blank = 600 Secs
Wake display on play = Off
Brightness = 255
Pixel aspect ratio = Default
Rotate screen = 0 Deg

M O O D E   S T A R T U P   L O G

20200313 201718 worker: -- Start
20200313 201718 worker: Successfully daemonized
20200313 201718 worker: Integrity check (passed)
20200313 201718 worker: Session loaded
20200313 201718 worker: Debug logging (off)
20200313 201718 worker: Device raw: (0:PianoDACPlus|1:empty|i2s:Allo Piano 2.1 Hi-Fi DAC)
20200313 201718 worker: Device cfg: (Allo Piano 2.1 Hi-Fi DAC|0|0|Master|0)
20200313 201719 worker: ALSA volume set to (0%)
20200313 201719 worker: -- System
20200313 201721 worker: Host name     (moode)
20200313 201721 worker: moOde release (6.4.2 2020-02-12)
20200313 201721 worker: Raspbian OS   (10.2)
20200313 201721 worker: Linux kernel  (4.19.97-v7+ #1293)
20200313 201721 worker: Platform      (Pi-3B 1GB v1.2)
20200313 201721 worker: Architecture  (armv7l)
20200313 201721 worker: MPD version   (0.21.16)
20200313 201721 worker: CPU governor  (ondemand)
20200313 201721 worker: USB boot not enabled yet
20200313 201722 worker: File system not expanded yet
20200313 201722 worker: HDMI port on
20200313 201722 worker: File check (OK)
20200313 201722 worker: -- Network
20200313 201722 worker: eth0 exists
20200313 201722 worker: eth0 wait 0 for IP address
20200313 201725 worker: eth0 wait 1 for IP address
20200313 201729 worker: eth0 wait 2 for IP address
20200313 201732 worker: eth0 wait 3 for IP address
20200313 201735 worker: eth0 wait 4 for IP address
20200313 202743 worker: eth0 address not assigned
20200313 202743 worker: wlan0 exists
20200313 202743 worker: wifi country (IL)
20200313 202743 worker: wlan0 trying SSID (Behar)
20200313 202743 worker: IP addr (192.168.14.61)
20200313 202744 worker: Netmask (255.255.255.0)
20200313 202744 worker: Gateway (192.168.14.1)
20200313 202744 worker: Pri DNS (192.168.14.1)
20200313 202744 worker: Domain  (Home)
20200313 202744 worker: -- Audio
20200313 202744 worker: ALSA outputs unmuted
20200313 202744 worker: ALSA card number (0)
20200313 202744 worker: Audio output (I2S audio device)
20200313 202744 worker: Audio device (Allo Piano 2.1 Hi-Fi DAC)
20200313 202745 worker: Audio formats (S16_LE, S24_LE, S32_LE)
20200313 202745 worker: ALSA mixer name (Digital)
20200313 202745 worker: MPD volume control (hardware)
20200313 202745 worker: Hdwr volume controller exists
20200313 202745 worker: Max ALSA volume (100%)
20200313 202745 worker: Piano output mode (2.1)
20200313 202752 worker: Piano 2.1 initialized
20200313 202752 worker: -- Services
20200313 202752 worker: Reset renderer active state
20200313 202752 worker: MPD conf updated
20200313 202752 worker: MPD started
20200313 202753 worker: MPD accepting connections
20200313 202753 worker: Configure MPD outputs
20200313 202754 worker: MPD output 1 ALSA default (on)
20200313 202754 worker: MPD output 2 ALSA crossfeed (off)
20200313 202754 worker: MPD output 3 ALSA parametric eq (off)
20200313 202754 worker: MPD output 4 ALSA graphic eq (off)
20200313 202754 worker: MPD output 5 ALSA polarity inversion (off)
20200313 202754 worker: MPD output 6 ALSA bluetooth (off)
20200313 202754 worker: MPD output 7 HTTP stream (off)
20200313 202754 worker: MPD crossfade (off)
20200313 202754 worker: Audio source (Local)
20200313 202754 worker: Output device (Local)
20200313 202754 worker: USB auto-mounter (udisks-glue)
20200313 202754 worker: -- Music sources
20200313 202754 worker: USB sources (none attached)
20200313 202755 worker: NAS and UPnP sources (mountall initiated)
20200313 202755 worker: -- Miscellaneous
20200313 202755 worker: Saved MPD vol level (0)
20200313 202755 worker: Preamp volume level (0)
20200313 202755 worker: MPD volume level (0) restored
20200313 202755 worker: ALSA volume level (0%)
20200313 202755 worker: Auto-play (Off)
20200313 202755 worker: LocalUI started
20200313 202755 worker: Auto-shuffle service (Off)
20200313 202755 worker: Maintenance interval (3 hrs)
20200313 202755 worker: Screen saver activation (Never)
20200313 202755 worker: Session permissions (OK)
20200313 202755 worker: Watchdog started
20200313 202755 worker: Ready
Reply
#2
Your debug info shows:

Sub level: 0%
Reply
#3
(03-13-2020, 08:15 PM)Tim Curtis Wrote: Your debug info shows:

Sub level: 0%

Silly me! I thought I had that turned on, probably got muted when I fiddled with the SoX settings.. Thanks Tim! You are the best.
Reply


Forum Jump: